summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKamalavelan2017-08-15 22:53:01 +0530
committerKamalavelan2017-08-15 22:53:01 +0530
commit3b40d5bfe88608158880e8932afac27415701d13 (patch)
treefcab0be905f5b65fc29552feae1c5ae0f61056c9
downloadaur-3b40d5bfe88608158880e8932afac27415701d13.tar.gz
created the monocypher AUR package
Signed-off-by: Kamalavelan <sskamalavelan@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0975ed8c0065
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = monocypher
+ pkgdesc = Monocypher is an easy to use crypto library inspired by libsodium and TweetNaCl
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://loup-vaillant.fr/projects/monocypher/
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ depends = glibc
+ source = http://loup-vaillant.fr/projects/monocypher/monocypher-1.0.1.tar.gz
+ sha512sums = 9e5542a3e853a1e786dbf67c020fecb9c066ed272175a57b12fb8b80b0faef2441c4c11c506a00215f13477ee0b96614597dc80a8c38f29bc53313610d0f8cec
+
+pkgname = monocypher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e643d7a16f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Kamalavelan <sskamalavelan@gmail.com>
+
+pkgname=monocypher
+_pkgname=monocypher
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Monocypher is an easy to use crypto library inspired by libsodium and TweetNaCl"
+arch=('i686' 'x86_64')
+url="http://loup-vaillant.fr/projects/monocypher/"
+license=('custom:BSD')
+depends=('glibc')
+source=("http://loup-vaillant.fr/projects/$_pkgname/$_pkgname-${pkgver}.tar.gz")
+sha512sums=('9e5542a3e853a1e786dbf67c020fecb9c066ed272175a57b12fb8b80b0faef2441c4c11c506a00215f13477ee0b96614597dc80a8c38f29bc53313610d0f8cec')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -d -m 755 "$pkgdir/usr/include/$pkgname"
+ install -m 644 LICENCE.md "$pkgdir/usr/include/$pkgname/monocypher.c"
+ install -m 644 LICENCE.md "$pkgdir/usr/include/$pkgname/monocypher.h"
+ install -m 644 LICENCE.md "$pkgdir/usr/include/$pkgname/sha512.h"
+ install -m 644 LICENCE.md "$pkgdir/usr/include/$pkgname/sha512.c"
+ install -d -m 755 "$pkgdir/usr/share/licenses/$pkgname"
+ install -m 644 LICENCE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}
+
+# vim:set ts=2 sw=2 et: