summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Duell2021-01-04 11:16:36 +0100
committerMichael Duell2021-01-04 11:16:36 +0100
commit2f9561019dc257ba639d35cb792fc4de96bbfede (patch)
treeabc174f918de394b0e925b40e241c8f1dc214281
parent2da4ab52901b5991490ca3cf8b04c5e8183df18c (diff)
downloadaur-2f9561019dc257ba639d35cb792fc4de96bbfede.tar.gz
Updated git.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 336b06038237..a70ffe749d43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = monocypher-git
pkgdesc = Monocypher is an easy to use crypto library inspired by libsodium and TweetNaCl
- pkgver = 2.0.5.r16.g6cdecf9
+ pkgver = 3.1.2.r0.gbaca5d3
pkgrel = 1
- url = http://loup-vaillant.fr/projects/monocypher/
+ url = https://monocypher.org/
arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = custom:BSD
depends = glibc
provides = monocypher
diff --git a/PKGBUILD b/PKGBUILD
index 9cc6d2133ec8..fb745b4a6b2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: Michael Duell <mail at akurei dot me>
+# Maintainer: Michael Duell <dev at akurei dot me>
pkgname=monocypher-git
_pkgname=monocypher
provides=('monocypher')
conflicts=('monocypher')
-pkgver=2.0.5.r16.g6cdecf9
+pkgver=3.1.2.r0.gbaca5d3
pkgrel=1
pkgdesc="Monocypher is an easy to use crypto library inspired by libsodium and TweetNaCl"
-arch=('i686' 'x86_64')
-url="http://loup-vaillant.fr/projects/monocypher/"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://monocypher.org/"
license=('custom:BSD')
depends=('glibc')
source=("monocypher::git+https://github.com/LoupVaillant/Monocypher.git")
@@ -19,15 +19,21 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+
+
package() {
cd "$_pkgname"
install -d -m 755 "$pkgdir/usr/include/$_pkgname"
install -m 644 src/monocypher.c "$pkgdir/usr/include/$_pkgname/monocypher.c"
install -m 644 src/monocypher.h "$pkgdir/usr/include/$_pkgname/monocypher.h"
- install -m 644 src/optional/sha512.h "$pkgdir/usr/include/$_pkgname/sha512.h"
- install -m 644 src/optional/sha512.c "$pkgdir/usr/include/$_pkgname/sha512.c"
+ install -m 644 src/optional/monocypher-ed25519.c "$pkgdir/usr/include/$_pkgname/monocypher-ed25519.c"
+ install -m 644 src/optional/monocypher-ed25519.h "$pkgdir/usr/include/$_pkgname/monocypher-ed25519.h"
install -d -m 755 "$pkgdir/usr/share/licenses/$_pkgname"
install -m 644 LICENCE.md "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
install -d -m 755 "$pkgdir/usr/share/man/man3"
- install -m 644 doc/man/man3/* "$pkgdir/usr/share/man/man3/"
- }
+ install -m 644 doc/man/man3/*.3monocypher "$pkgdir/usr/share/man/man3/"
+ install -d -m 755 "$pkgdir/usr/share/man/man3/advanced"
+ install -m 644 doc/man/man3/advanced/*.3monocypher "$pkgdir/usr/share/man/man3/advanced/"
+ install -d -m 755 "$pkgdir/usr/share/man/man3/optional"
+ install -m 644 doc/man/man3/optional/*.3monocypher "$pkgdir/usr/share/man/man3/optional/"
+}