summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan2019-04-29 14:57:53 +1000
committerDan2019-04-29 14:57:53 +1000
commit86770ae9d9d3484afb6a9195df64550d72566fd2 (patch)
tree8ee44859e184ad27b00d23590dc3a7055c3a7fa8
parent9df258b007d926cc64ac822d2d5fac200b7a2ffa (diff)
downloadaur-86770ae9d9d3484afb6a9195df64550d72566fd2.tar.gz
Added temp fix edit on launcher for LD_LIBRARY_PATH and EXE_PATH until dev's add option as suggested by user fhdk.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7a064a65cfd..a955ff1777aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = monodevelop-stable
pkgdesc = An IDE primarily designed for C# and other .NET languages
pkgver = 7.8.3.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.monodevelop.com
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 8e0ab8456c58..ae3d39dded81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=monodevelop-stable
_pkgname=monodevelop
pkgver=7.8.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="An IDE primarily designed for C# and other .NET languages"
arch=('x86_64' 'i686')
url="http://www.monodevelop.com"
@@ -51,5 +51,8 @@ package() {
XDG_CONFIG_HOME="$srcdir"/config LD_PRELOAD="" make DESTDIR="$pkgdir" install
# delete conflicting files
find "$pkgdir"/usr/share/mime/ -type f -delete
-}
+ #Correct Invalid Env Paths in static launcher
+ sed -i "s/export LD_LIBRARY_PATH.*/export LD_LIBRARY_PATH\=\"\/usr\/lib\/monodevelop\/bin\:\$\{LD_LIBRARY_PATH\}\"/g" $pkgdir/usr/bin/monodevelop;
+ sed -i "s/EXE_PATH=.*/EXE_PATH=\/usr\/lib\/monodevelop\/bin\/MonoDevelop.exe/g" $pkgdir/usr/bin/monodevelop;
+}