summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-21 19:10:14 +0800
committerzxp198210052023-11-21 19:10:14 +0800
commit187cb27139708a181ef3f2476f26212ce31d47ab (patch)
tree9ad85c31d10d7bcca1a6e12b3e1726ef175cf3b8
parent405ac9d6ad10dbeb4691fa02adb6114129435171 (diff)
downloadaur-187cb27139708a181ef3f2476f26212ce31d47ab.tar.gz
fix errors
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 13 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f3666871738..ab126caf9325 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = monokle
pkgdesc = Lets you create, analyze, and deploy YAML manifests with a visual UI, and provides policy validation and cluster management.
pkgver = 2.4.3
- pkgrel = 1
+ pkgrel = 2
url = https://monokle.io/
arch = x86_64
license = MIT
@@ -9,8 +9,7 @@ pkgbase = monokle
makedepends = nodejs>=20
makedepends = jq
makedepends = gendesk
- depends = zlib
- depends = gcc-libs
+ makedepends = git
depends = at-spi2-core
depends = alsa-lib
depends = expat
@@ -20,23 +19,20 @@ pkgbase = monokle
depends = libxfixes
depends = libxdamage
depends = gtk3
- depends = glib2
depends = nspr
depends = mesa
depends = libxrandr
depends = cairo
depends = nss
- depends = dbus
depends = libxext
depends = python
depends = libx11
depends = pango
- depends = sh
depends = libcups
depends = libxcb
provides = monokle=2.4.3
conflicts = monokle
- source = monokle-2.4.3.zip::https://github.com/kubeshop/monokle/archive/refs/tags/v2.4.3.zip
- sha256sums = 87649dab2638040d7edccc74f44dc1507cec7ec89f49eb2630332cdaca1441e9
+ source = monokle-2.4.3::git+https://github.com/kubeshop/monokle#tags=v2.4.3
+ sha256sums = SKIP
pkgname = monokle
diff --git a/PKGBUILD b/PKGBUILD
index 7cd0676fca5f..e5edd6fff271 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,15 @@
pkgname=monokle
_pkgname=Monokle
pkgver=2.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="Lets you create, analyze, and deploy YAML manifests with a visual UI, and provides policy validation and cluster management."
arch=('x86_64')
url="https://monokle.io/"
-_githuburl="https://github.com/kubeshop/monokle"
+_ghurl="https://github.com/kubeshop/monokle"
license=('MIT')
provides=("${pkgname}=${pkgver}")
conflicts=("${pkgname}")
depends=(
- 'zlib'
- 'gcc-libs'
'at-spi2-core'
'alsa-lib'
'expat'
@@ -22,18 +20,15 @@ depends=(
'libxfixes'
'libxdamage'
'gtk3'
- 'glib2'
'nspr'
'mesa'
'libxrandr'
'cairo'
'nss'
- 'dbus'
'libxext'
'python'
'libx11'
'pango'
- 'sh'
'libcups'
'libxcb'
)
@@ -42,19 +37,17 @@ makedepends=(
'nodejs>=20'
'jq'
'gendesk'
+ 'git'
)
-source=("${pkgname}-${pkgver}.zip::${_githuburl}/archive/refs/tags/v${pkgver}.zip")
-sha256sums=('87649dab2638040d7edccc74f44dc1507cec7ec89f49eb2630332cdaca1441e9')
+source=(
+ "${pkgname}-${pkgver}::git+${_ghurl}#tags=v${pkgver}"
+)
+sha256sums=('SKIP')
build() {
gendesk -q -f -n --categories "Development" --name "${_pkgname}" --exec "${pkgname} --no-sandbox %U"
- 1cd "${srcdir}/${pkgname}-${pkgver}"
- if [ -d .git ];then
- rmdir .git && mkdir .git
- else
- mkdir .git
- fi
+ cd "${srcdir}/${pkgname}-${pkgver}"
sed -e "291,297d" -e "271,277d" -e "258,264d" -e '/arm64/d' -e 's|"x64",|"x64"|g' -i package.json
- npm ci
+ npm ci --cache "${srcdir}/npm-cache"
npm run electron:build
}
package() {