summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-12-27 21:25:48 -0500
committerJean Lucas2019-12-27 21:25:48 -0500
commit47d7332e209b6ecb3348ede4a529e1dd127acd84 (patch)
treee59d8c03b23bf08b2bbff11264f27de57bd82edb
parent813fd1064c9ae862e0e658b54d2683f7e910b120 (diff)
downloadaur-47d7332e209b6ecb3348ede4a529e1dd127acd84.tar.gz
2.1.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dfbbde847e5..a8df54e32b3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = monolith
pkgdesc = CLI to save web pages as single HTML files
- pkgver = 2.0.23
+ pkgver = 2.1.1
pkgrel = 1
url = https://github.com/Y2Z/monolith
arch = x86_64
@@ -8,10 +8,8 @@ pkgbase = monolith
license = custom:Unlicese
makedepends = cargo
depends = openssl
- provides = monolith
- conflicts = monolith
- source = monolith-2.0.23.tar.gz::https://github.com/Y2Z/monolith/archive/491185e191b09051f25ca5a0809ee576e42a9d44.tar.gz
- sha512sums = e507b4639d908457b167b6910196ceb066441527c59bb6737a57327dd97943c2a5673c67b35442cd1f354d67f3c97d2e4b8da4e79ec3ed35e95878ab91dbd78e
+ source = monolith-2.1.1.tar.gz::https://github.com/Y2Z/monolith/archive/v2.1.1.tar.gz
+ sha512sums = d88553d5c7d93d960cb9c6e9410fb4e3409387c9c4676ced70d337252bb257e52972fc69e5d84a18ea74cbc0dd68633a8f121a12ad239dff013feb5cf483027f
pkgname = monolith
diff --git a/PKGBUILD b/PKGBUILD
index 34e2f45bee3f..069fb04f7a93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=monolith
-pkgver=2.0.23
-_commit=491185e191b09051f25ca5a0809ee576e42a9d44 # Untagged release
+pkgver=2.1.1
pkgrel=1
pkgdesc='CLI to save web pages as single HTML files'
arch=(x86_64 aarch64)
@@ -10,18 +9,16 @@ url=https://github.com/Y2Z/monolith
license=(custom:Unlicese)
depends=(openssl)
makedepends=(cargo)
-provides=(monolith)
-conflicts=(monolith)
-source=($pkgname-$pkgver.tar.gz::$url/archive/$_commit.tar.gz)
-sha512sums=('e507b4639d908457b167b6910196ceb066441527c59bb6737a57327dd97943c2a5673c67b35442cd1f354d67f3c97d2e4b8da4e79ec3ed35e95878ab91dbd78e')
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
+sha512sums=('d88553d5c7d93d960cb9c6e9410fb4e3409387c9c4676ced70d337252bb257e52972fc69e5d84a18ea74cbc0dd68633a8f121a12ad239dff013feb5cf483027f')
build() {
- cd $pkgname-$_commit
+ cd $pkgname-$pkgver
cargo build --release
}
package() {
- cd $pkgname-$_commit
+ cd $pkgname-$pkgver
install -D target/release/monolith -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname