summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchaurwiki2015-09-04 19:32:18 +0000
committerarchaurwiki2015-09-04 19:32:18 +0000
commit2866857466b58c262d891f331e2c5159657e2813 (patch)
treef34da4e60b6524d77667b7ab578988c01c1591b5
downloadaur-2866857466b58c262d891f331e2c5159657e2813.tar.gz
First commit.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
-rw-r--r--monotone.install29
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b813e5c0131
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = monotone
+ pkgdesc = A free distributed version control system
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://code.monotone.ca/p/monotone
+ install = monotone.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = pcre
+ depends = lua
+ depends = botan-stable
+ depends = sqlite3
+ depends = libidn
+ depends = zlib
+ provides = monotone
+ conflicts = monotone
+ conflicts = monotone-snapshot
+ source = http://www.monotone.ca/downloads/1.1/monotone-1.1.tar.bz2
+ sha1sums = 2b97559b252decaee3a374b81bf714cf33441ba3
+
+pkgname = monotone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a4a25e3e116
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: archaurwiki <archaurwiki at i2pmail dot org>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
+# Contributor: Dan McGee <dpmcgee@gmail.com>
+
+pkgname=monotone
+pkgver=1.1
+pkgrel=1
+pkgdesc='A free distributed version control system'
+arch=('i686' 'x86_64')
+url='https://code.monotone.ca/p/monotone'
+license=('GPL')
+depends=('pcre' 'lua' 'botan-stable' 'sqlite3' 'libidn' 'zlib')
+makedepends=('boost')
+provides=('monotone')
+conflicts=('monotone' 'monotone-snapshot')
+install=monotone.install
+source=("http://www.monotone.ca/downloads/1.1/monotone-${pkgver}.tar.bz2")
+sha1sums=('2b97559b252decaee3a374b81bf714cf33441ba3')
+
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ aclocal
+ autoreconf --install
+}
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ export DISABLE_NETWORK_TESTS=1
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-nls
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ install -d "${pkgdir}/usr/share/vim/vimfiles/plugin/"
+ install -Dm644 contrib/monotone.zsh_completion "${pkgdir}/usr/share/zsh/site-functions/_mtn"
+ install -Dm644 contrib/{mtncommit,basicio}.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/"
+}
diff --git a/monotone.install b/monotone.install
new file mode 100644
index 000000000000..298adb64a082
--- /dev/null
+++ b/monotone.install
@@ -0,0 +1,29 @@
+infodir=usr/share/info
+filelist=(monotone.info.gz)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+
+ # arg 1: the new package version
+ # arg 2: the old package version
+ if [[ "$(vercmp $2 0.45)" -lt 0 ]]; then
+ echo ">>> Your monotone databases will need updating for an internal format"
+ echo ">>> change. Please run the following command on each of your databases"
+ echo ">>> (after remembering to take a backup copy):"
+ echo ">>> $ mtn -d dbname.mtn db migrate"
+ fi
+}
+
+pre_remove() {
+ [[ -x usr/bin/install-info ]] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}