summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Venries2017-03-18 00:03:04 +0100
committerThomas Venries2017-03-18 00:03:04 +0100
commitf8fd83110c42d90298578971362ae79c2674c624 (patch)
treeaf4ed0a0c204c3f7c0602dfaf6a11d47a9cddc4b
parent3d646105c594caa276643fbd3067158a23d330d4 (diff)
downloadaur-f8fd83110c42d90298578971362ae79c2674c624.tar.gz
Added release v0.5.
Fixes: - Generic XRandR executable-path finder Enhancement: - mons is POSIX-compliant (including posix-shell-list)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e329c0cbbdaf..ba2591cc5464 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = mons
- pkgdesc = Bash script to quickly manage 2-monitors display using xrandr.
- pkgver = 0.3
+ pkgdesc = Shell script to quickly manage 2-monitors.
+ pkgver = 0.5
pkgrel = 1
url = https://github.com/Ventto/mons.git
arch = any
license = MIT
makedepends = help2man
- depends = bash
depends = xorg-xrandr
provides = mons
conflicts = mons
- source = https://github.com/Ventto/mons/archive/v0.3.tar.gz
+ source = https://github.com/Ventto/mons/archive/v0.5.tar.gz
+ source = https://github.com/Ventto/posix-shell-list/archive/v1.0.tar.gz
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = mons
diff --git a/PKGBUILD b/PKGBUILD
index 2f57f20aa5f5..851f2c6038c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,35 @@
# Maintainer: Thomas "Ventto" Venriès <thomas.venries@gmail.com>
pkgname=mons
-pkgver=0.3
+pkgver=0.5
pkgrel=1
-pkgdesc='Bash script to quickly manage 2-monitors display using xrandr.'
+pkgdesc='Shell script to quickly manage 2-monitors.'
arch=('any')
url="https://github.com/Ventto/${pkgname}.git"
license=('MIT')
-depends=('bash' 'xorg-xrandr')
+depends=('xorg-xrandr')
provides=("${pkgname}")
conflicts=("${pkgname}")
makedepends=('help2man')
-source=("https://github.com/Ventto/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("https://github.com/Ventto/${pkgname}/archive/v${pkgver}.tar.gz"
+ "https://github.com/Ventto/posix-shell-list/archive/v1.0.tar.gz")
+
+sha256sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd ${srcdir}
+ rm -r ${pkgname}-${pkgver}/posix-shell-list
+ mv 'posix-shell-list-1.0' ${pkgname}-${pkgver}/posix-shell-list
+}
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- help2man -N -n "${pkgdesc}" -h -h -v -v src/${pkgname}.sh | gzip - > ${pkgname}.1.gz
+ help2man -N -n "${pkgdesc}" -h -h -v -v ${pkgname} | gzip - > ${pkgname}.1.gz
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
install -Dm644 ${pkgname}.1.gz ${pkgdir}/usr/share/man/man1/${pkgname}.1.gz
- install -Dm755 src/${pkgname}.sh ${pkgdir}/usr/bin/${pkgname}
+ make DESTDIR="${pkgdir}" install
}