summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bourgeois2017-02-10 02:37:30 +0100
committerQuentin Bourgeois2017-02-10 02:37:30 +0100
commite18ed23fb6ca2bedab83c85677a5314cf72cb7df (patch)
tree341b6207dbcd8f3e7e848771df588eefb085d633
downloadaur-e18ed23fb6ca2bedab83c85677a5314cf72cb7df.tar.gz
addpkg: moolticute_ssh-agent 20170210-1
moolticute_ssh-agent-20170210-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
-rw-r--r--moolticute_ssh-agent.install13
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9362736484cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = moolticute_ssh-agent
+ pkgdesc = Simple ssh-agent that loads keys stored from Moolticute
+ pkgver = 20170210
+ pkgrel = 1
+ url = https://github.com/bobsaintcool/moolticute_ssh-agent
+ install = moolticute_ssh-agent.install
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ depends = moolticute
+
+pkgname = moolticute_ssh-agent
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7ca62a335b00
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*moolticute_ssh-agent-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35b983ad52eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Quentin Bourgeois <quentin+archlinux@bourgeois.eu>
+
+pkgname=moolticute_ssh-agent
+pkgver=20170210
+pkgrel=1
+pkgdesc='Simple ssh-agent that loads keys stored from Moolticute'
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('moolticute')
+makedepends=('git'
+ 'go')
+url="https://github.com/bobsaintcool/${pkgname}"
+_gourl="${url##https://}"
+install="${pkgname}.install"
+
+build() {
+ cd "${srcdir}"
+
+ GOPATH="${srcdir}" go get -fix -v -x "${_gourl}"
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -p -Dm 755 "${srcdir}/bin/moolticute_ssh-agent" \
+ "${pkgdir}/usr/bin/moolticute_ssh-agent"
+ install -Dm 644 "${srcdir}/src/${_gourl}/systemd/moolticute-ssh-agent.service" \
+ "${pkgdir}/usr/lib/systemd/user/moolticute_ssh-agent.service"
+}
diff --git a/moolticute_ssh-agent.install b/moolticute_ssh-agent.install
new file mode 100644
index 000000000000..9e3ca1546316
--- /dev/null
+++ b/moolticute_ssh-agent.install
@@ -0,0 +1,13 @@
+post_install() {
+ _systemd_service_usage
+}
+
+post_upgrade() {
+ _systemd_service_usage
+}
+
+# print an usage on how to use the agent started by systemd
+_systemd_service_usage() {
+ echo "In order to use moolticute_ssh-agent one had to export the environment variable" \
+ 'SSH_AUTH_SOCK="${XDG_RUNTIME_DIR}/moolticute-ssh-agent.socket"'
+}