summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYidaozhan Ya2022-06-27 14:41:00 +0800
committerYidaozhan Ya2022-06-27 14:41:00 +0800
commitd65601a314f2a5e50f7c86d37b4da579e63f7d5f (patch)
treec3871cea963a3c77ac25780b426eb07eacf63a97
downloadaur-d65601a314f2a5e50f7c86d37b4da579e63f7d5f.tar.gz
initial package
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD44
-rw-r--r--moondust-calibrator.desktop15
-rw-r--r--moondust-editor.desktop15
-rw-r--r--moondust-engine.desktop15
-rw-r--r--moondust-maintainer.desktop15
-rw-r--r--moondust-musplay.desktop15
-rw-r--r--moondust-project.install18
8 files changed, 178 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24409eb7b2cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = moondust-project-stable-bin
+ pkgdesc = Moondust Project (formerly known as PGE Project) is a free and open-source game engine and development kit for it, giving developers the ability to create platform games. (Binary package - stable branch)
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = https://github.com/WohlSoft/Moondust-Project/
+ install = moondust-project.install
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ depends = desktop-file-utils
+ depends = qt5-base
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = mesa
+ depends = alsa-lib
+ depends = dbus
+ depends = mesa-utils
+ depends = libxrandr
+ depends = libxss
+ depends = libxt
+ depends = libxinerama
+ depends = sndio
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
+ depends = libxcursor
+ depends = libx11
+ depends = libpulse
+ depends = wayland
+ depends = systemd-libs
+ depends = libxv
+ depends = libxxf86vm
+ depends = sdl2
+ depends = freetype2
+ provides = moondust-project
+ source = https://wohlsoft.ru/projects/Moondust/_downloads/linux64/pge-project-stable-linux-ubuntu-16.04.tar.bz2
+ source = moondust.png::https://github.com/WohlSoft/Moondust-Project/raw/master/Editor/_resources/images/cat_builder/cat_builder_256.png
+ source = moondust-calibrator.png::https://github.com/WohlSoft/Moondust-Project/raw/master/PlayableCalibrator/_resources/icon/calibrator_256.png
+ source = moondust-musplay.png::https://github.com/WohlSoft/Moondust-Project/raw/master/MusicPlayer/_resources/cat_musplay/cat_musplay_256x256.png
+ sha512sums = 7693291730d98785a9dee22c8770c458014d567a813f40cc4319f0643a62bab04718e93e7c55e477ecaf3ab20131232fa7362952909766fa2274271042838d48
+
+pkgname = moondust-project-stable-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d9f75891659
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: YidaozhanYa <yidaozhan_ya@outlook.com>
+pkgname=moondust-project-stable-bin
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="Moondust Project (formerly known as PGE Project) is a free and open-source game engine and development kit for it, giving developers the ability to create platform games. (Binary package - stable branch)"
+arch=('x86_64')
+url="https://github.com/WohlSoft/Moondust-Project/"
+license=('GPLv3')
+depends=('desktop-file-utils' 'qt5-base' 'libjpeg-turbo' 'libpng' 'mesa' 'alsa-lib' 'dbus' 'mesa-utils' 'libxrandr' 'libxss' 'libxt' 'libxinerama' 'sndio' 'libxkbcommon' 'libxkbcommon-x11' 'libxcursor' 'libx11' 'libpulse' 'wayland' 'systemd-libs' 'libxv' 'libxxf86vm' 'sdl2' 'freetype2')
+makedepends=('git')
+optdepends=()
+provides=('moondust-project')
+install="moondust-project.install"
+source=(
+"https://wohlsoft.ru/projects/Moondust/_downloads/linux64/pge-project-stable-linux-ubuntu-16.04.tar.bz2"
+"moondust.png::https://github.com/WohlSoft/Moondust-Project/raw/master/Editor/_resources/images/cat_builder/cat_builder_256.png"
+"moondust-calibrator.png::https://github.com/WohlSoft/Moondust-Project/raw/master/PlayableCalibrator/_resources/icon/calibrator_256.png"
+"moondust-musplay.png::https://github.com/WohlSoft/Moondust-Project/raw/master/MusicPlayer/_resources/cat_musplay/cat_musplay_256x256.png"
+)
+sha512sums=(
+"7693291730d98785a9dee22c8770c458014d567a813f40cc4319f0643a62bab04718e93e7c55e477ecaf3ab20131232fa7362952909766fa2274271042838d48"
+)
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/games/thextech-aod"
+ cp -r "${srcdir}/battle" "${pkgdir}/usr/share/games/thextech-aod/battle"
+ cp -r "${srcdir}/graphics" "${pkgdir}/usr/share/games/thextech-aod/graphics"
+ cp -r "${srcdir}/music" "${pkgdir}/usr/share/games/thextech-aod/music"
+ cp -r "${srcdir}/sound" "${pkgdir}/usr/share/games/thextech-aod/sound"
+ cp -r "${srcdir}/worlds" "${pkgdir}/usr/share/games/thextech-aod/worlds"
+ chmod 0644 ${pkgdir}/usr/share/games/thextech-aod/sound/*
+ chmod 0644 ${pkgdir}/usr/share/games/thextech-aod/music/*
+ install -Dm0644 "${srcdir}/gameinfo.ini" "${pkgdir}/usr/share/games/thextech-aod/gameinfo.ini"
+ install -Dm0644 "${srcdir}/music.ini" "${pkgdir}/usr/share/games/thextech-aod/music.ini"
+ install -Dm0644 "${srcdir}/sounds.ini" "${pkgdir}/usr/share/games/thextech-aod/sounds.ini"
+ install -Dm0644 "${srcdir}/thextech.ini" "${pkgdir}/usr/share/games/thextech-aod/thextech.ini"
+ install -Dm0644 "${srcdir}/intro.lvlx" "${pkgdir}/usr/share/games/thextech-aod/intro.lvlx"
+ install -Dm0644 "${srcdir}/outro.lvlx" "${pkgdir}/usr/share/games/thextech-aod/outro.lvlx"
+ install -Dm0644 "${srcdir}/credits.txt" "${pkgdir}/usr/share/games/thextech-aod/credits.txt"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm0755 "${srcdir}/TheXTech/build/output/bin/thextech" "${pkgdir}/usr/bin/thextech-aod"
+ install -Dm0644 "${srcdir}/TheXTech/resources/icon/thextech_128.png" "${pkgdir}/usr/share/pixmaps/thextech-aod.png"
+ install -Dm0755 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/moondust-calibrator.desktop b/moondust-calibrator.desktop
new file mode 100644
index 000000000000..d011b64aa1de
--- /dev/null
+++ b/moondust-calibrator.desktop
@@ -0,0 +1,15 @@
+ [Desktop Entry]
+Name=Moondust Calibrator
+Name[zh_CN]=Moondust 调校工具
+GenericName=Moondust Calibrator
+GenericName[zh_CN]=Moondust 调校工具
+Comment=Calibrating incorrect frame positions and hitboxes
+Comment[zh_CN]=用于调校素材图的判定范围
+Encoding=UTF-8
+Version=1
+Type=Application
+Terminal=false
+Icon=moondust-calibrator
+Exec=pge_calibrator %F
+Categories=Game;
+StartupWMClass=pge_calibrator
diff --git a/moondust-editor.desktop b/moondust-editor.desktop
new file mode 100644
index 000000000000..e395c4fc072a
--- /dev/null
+++ b/moondust-editor.desktop
@@ -0,0 +1,15 @@
+ [Desktop Entry]
+Name=Moondust Editor
+Name[zh_CN]=Moondust 编辑器
+GenericName=Moondust Editor
+GenericName[zh_CN]=Moondust 编辑器
+Comment=The main development tool of Moondust Project
+Comment[zh_CN]=Moondust 项目的主要开发工具
+Encoding=UTF-8
+Version=1
+Type=Application
+Terminal=false
+Icon=moondust-editor
+Exec=pge_editor %F
+Categories=Game;
+StartupWMClass=pge_editor
diff --git a/moondust-engine.desktop b/moondust-engine.desktop
new file mode 100644
index 000000000000..d531898d28d2
--- /dev/null
+++ b/moondust-engine.desktop
@@ -0,0 +1,15 @@
+ [Desktop Entry]
+Name=Moondust Engine
+Name[zh_CN]=Moondust 引擎
+GenericName=Moondust Engine
+GenericName[zh_CN]=Moondust 引擎
+Comment=The the main part of the Moondust Project to play levels and episodes
+Comment[zh_CN]=Moondust 项目的主要部分,用于游玩关卡和地图
+Encoding=UTF-8
+Version=1
+Type=Application
+Terminal=false
+Icon=moondust-engine
+Exec=pge_engine %F
+Categories=Game;
+StartupWMClass=pge_engine
diff --git a/moondust-maintainer.desktop b/moondust-maintainer.desktop
new file mode 100644
index 000000000000..d7e0d1d47072
--- /dev/null
+++ b/moondust-maintainer.desktop
@@ -0,0 +1,15 @@
+ [Desktop Entry]
+Name=Moondust Maintainer Wizard
+Name[zh_CN]=Moondust 维护工具
+GenericName=Moondust Maintainer Wizard
+GenericName[zh_CN]=Moondust 维护工具
+Comment=Process and convert various stuff like level and episode data, resources, etc.
+Comment[zh_CN]=处理和转换各种资源文件,比如关卡和音乐
+Encoding=UTF-8
+Version=1
+Type=Application
+Terminal=false
+Icon=moondust-maintainer
+Exec=pge_maintainer %F
+Categories=Game;
+StartupWMClass=pge_maintainer
diff --git a/moondust-musplay.desktop b/moondust-musplay.desktop
new file mode 100644
index 000000000000..1796c2c5afd0
--- /dev/null
+++ b/moondust-musplay.desktop
@@ -0,0 +1,15 @@
+ [Desktop Entry]
+Name=Moondust Music Player
+Name[zh_CN]=Moondust 音乐播放器
+GenericName=Moondust Music Player
+GenericName[zh_CN]=Moondust 音乐播放器
+Comment=A lightweight music player based on SDL Mixer X library
+Comment[zh_CN]=基于 SDL Mixer X 的轻量级音乐播放器
+Encoding=UTF-8
+Version=1
+Type=Application
+Terminal=false
+Icon=moondust-musplay
+Exec=pge_musplay %F
+Categories=Game;
+StartupWMClass=pge_musplay
diff --git a/moondust-project.install b/moondust-project.install
new file mode 100644
index 000000000000..bc769e4ed7c4
--- /dev/null
+++ b/moondust-project.install
@@ -0,0 +1,18 @@
+post_install() {
+ update-desktop-database -q /usr/share/applications
+ echo ''
+ echo '======================================================================'
+ echo 'To create config directory, run mkdir -p "$HOME/.PGE_Project/configs",'
+ echo 'then you can place config packs there'
+ echo '======================================================================'
+ echo ''
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+