summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Herzberg2018-08-09 00:10:05 +0100
committerMichael Herzberg2018-08-09 00:10:05 +0100
commitc23787e40ad50bfe42d1bbb6a07b49117419e276 (patch)
treebfce670b9cedeacf213be377ac47cd13ea051395
downloadaur-c23787e40ad50bfe42d1bbb6a07b49117419e276.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6bba7039c56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = moonlight-qt
+ pkgdesc = GameStream client for PCs (Windows, Mac, and Linux)
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://moonlight-stream.com
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ optdepends = libva-intel-driver: hardware acceleration for Intel GPUs
+ source = moonlight-qt::git+https://github.com/moonlight-stream/moonlight-qt.git#tag=v0.1.0
+ md5sums = SKIP
+
+pkgname = moonlight-qt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faa4f37def67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
+
+pkgname=moonlight-qt
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='GameStream client for PCs (Windows, Mac, and Linux)'
+arch=('x86_64')
+license=('GPL')
+url='https://moonlight-stream.com'
+depends=('qt5-base' 'qt5-quickcontrols' 'qt5-quickcontrols2')
+optdepends=('libva-intel-driver: hardware acceleration for Intel GPUs')
+source=($pkgname::"git+https://github.com/moonlight-stream/${pkgname}.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$pkgname"
+ qmake PREFIX="$pkgdir/usr"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make install
+}