summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhonjow2025-03-23 13:03:59 +0000
committerhonjow2025-03-23 13:03:59 +0000
commit9ab0376bd1a99f9fca585583fe058f523254dc70 (patch)
tree661a376d4a0894007b4507570161e6beaa7081e5
downloadaur-9ab0376bd1a99f9fca585583fe058f523254dc70.tar.gz
Update AUR package
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD49
-rw-r--r--launcher.sh3
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b29b8eaab579
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = moonlight-qt-axi-appimage
+ pkgdesc = moonlight-qt by Axixi2233 bin from appimage
+ pkgver = 6.1.0
+ pkgrel = 1
+ url = https://github.com/Axixi2233/moonlight-qt
+ arch = x86_64
+ license = GPL3-or-later
+ depends = qt6-base
+ depends = qt6-declarative
+ depends = qt6-svg
+ depends = ffmpeg
+ depends = sdl2_ttf
+ optdepends = libva-intel-driver: hardware-acelerated decoding for Intel
+ optdepends = libva-mesa-driver: hardware-acelerated decoding for AMD/others
+ optdepends = libva-nvidia-driver: hardware-acelerated decoding for NVIDIA with NVDEC via VA-API
+ provides = moonlight-qt
+ provides = moonlight
+ conflicts = moonlight-qt
+ conflicts = moonlight
+ replaces = moonlight-qt
+ replaces = moonlight
+ options = !strip
+ source = moonlight-qt-6.1.0.AppImage::https://github.com/Axixi2233/moonlight-qt/releases/download/250306/Moonlight-6.1.0-x86_64-ax-0319.AppImage
+ source = launcher.sh
+ sha256sums = 75c1fc3e9a2f1c74d9e8f0c68db5c93b173edc1f918e5eba5bb95fe00b4b5cdc
+ sha256sums = 7dc324b4621067c01c1ea91570dec230fb43735f48f5f9eac91b0e487070a79d
+
+pkgname = moonlight-qt-axi-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c9fb3696424
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: honjow
+pkgname=moonlight-qt-axi-appimage
+_pkgname=moonlight-qt-bin
+pkgver=6.1.0
+pkgrel=1
+pkgdesc="moonlight-qt by Axixi2233 bin from appimage"
+arch=('x86_64')
+url="https://github.com/Axixi2233/moonlight-qt"
+license=('GPL3-or-later')
+depends=('qt6-base' 'qt6-declarative' 'qt6-svg' 'ffmpeg' 'sdl2_ttf')
+optdepends=(
+ 'libva-intel-driver: hardware-acelerated decoding for Intel'
+ 'libva-mesa-driver: hardware-acelerated decoding for AMD/others'
+ 'libva-nvidia-driver: hardware-acelerated decoding for NVIDIA with NVDEC via VA-API'
+)
+source=("${_pkgname%-bin}-$pkgver.AppImage::https://github.com/Axixi2233/moonlight-qt/releases/download/250306/Moonlight-6.1.0-x86_64-ax-0319.AppImage"
+ "launcher.sh")
+
+provides=("${_pkgname%-bin}" "moonlight")
+conflicts=("${_pkgname%-bin}" "moonlight")
+replaces=("${_pkgname%-bin}" "moonlight")
+sha256sums=('75c1fc3e9a2f1c74d9e8f0c68db5c93b173edc1f918e5eba5bb95fe00b4b5cdc'
+ '7dc324b4621067c01c1ea91570dec230fb43735f48f5f9eac91b0e487070a79d')
+options=(!strip)
+prepare() {
+ # extract appimage
+ chmod +x "${_pkgname%-bin}-$pkgver.AppImage"
+ ./"${_pkgname%-bin}-$pkgver.AppImage" --appimage-extract 1>/dev/null
+
+ # Rename file
+ mv "squashfs-root/com.moonlight_stream.Moonlight.desktop" "squashfs-root/${_pkgname%-bin}.desktop"
+
+ # Remove X-AppImage-Version
+ sed -i '/AppImage/d' "squashfs-root/${_pkgname%-bin}.desktop"
+}
+
+package() {
+ mkdir "${pkgdir}/opt/" -p
+ cp -r squashfs-root "${pkgdir}/opt/${_pkgname}"
+ mkdir "${pkgdir}/usr/bin/" -p
+ install -dm644 "${pkgdir}/opt/"
+ install -m755 "${srcdir}/launcher.sh" "${pkgdir}/usr/bin/moonlight"
+ install -m755 "squashfs-root/AppRun" "${pkgdir}/opt/${_pkgname}/AppRun"
+
+ install -Dm644 "squashfs-root/${_pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications/"
+
+ install -d "$pkgdir/usr/share/icons/"
+ cp -r squashfs-root/usr/share/icons/hicolor/ "$pkgdir/usr/share/icons/"
+} \ No newline at end of file
diff --git a/launcher.sh b/launcher.sh
new file mode 100644
index 000000000000..78dfe0299aa2
--- /dev/null
+++ b/launcher.sh
@@ -0,0 +1,3 @@
+#! /bin/sh
+cd /opt/moonlight-qt-bin/
+exec /opt/moonlight-qt-bin/usr/bin/moonlight "$@"