summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElias Blume2021-12-14 19:55:44 +0100
committerElias Blume2021-12-14 19:55:44 +0100
commit9c7d1a4982687a79643f40b144697988c6ef2201 (patch)
treefb32fc8d7401f1676116a4b3391438f966a7cee9
downloadaur-9c7d1a4982687a79643f40b144697988c6ef2201.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..569a75aec702
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = moonlight-qt-bin
+ pkgdesc = moonlight-qt bin from appimage
+ pkgver = 3.1.4
+ pkgrel = 1
+ url = https://github.com/moonlight-stream/moonlight-qt
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = qt5-quickcontrols2
+ depends = qt5-svg
+ depends = ffmpeg
+ depends = sdl2_ttf
+ depends = hicolor-icon-theme
+ optdepends = libva-intel-driver: hardware acceleration for Intel GPUs
+ provides = moonlight-qt
+ conflicts = moonlight-qt
+ source = moonlight-qt-3.1.4.AppImage::https://github.com/moonlight-stream/moonlight-qt/releases/download/v3.1.4/Moonlight-3.1.4-x86_64.AppImage
+ sha256sums = 6ce30a2b1014f072b2462055b55b1f4367625423e69a62c962421bdda38990fd
+
+pkgname = moonlight-qt-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4892987f2f41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=moonlight-qt-bin
+pkgver=3.1.4
+pkgrel=1
+pkgdesc="moonlight-qt bin from appimage"
+arch=('x86_64')
+url="https://github.com/moonlight-stream/moonlight-qt"
+license=('GPL3')
+#depends=('nss' 'libappindicator-gtk3' 'libnotify' 'org.freedesktop.secrets')
+#makedepends=('sed')
+depends=('qt5-base' 'qt5-quickcontrols2' 'qt5-svg' 'ffmpeg' 'sdl2_ttf' 'hicolor-icon-theme')
+optdepends=('libva-intel-driver: hardware acceleration for Intel GPUs')
+# https://github.com/moonlight-stream/moonlight-qt/releases/download/v3.1.4/Moonlight-3.1.4-x86_64.AppImage
+source=("${pkgname%-bin}-$pkgver.AppImage::https://github.com/moonlight-stream/moonlight-qt/releases/download/v${pkgver}/Moonlight-${pkgver}-x86_64.AppImage")
+_bin_name="${pkgname%-qt-bin}"
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+sha256sums=('6ce30a2b1014f072b2462055b55b1f4367625423e69a62c962421bdda38990fd')
+
+prepare() {
+ chmod +x "${pkgname%-bin}-$pkgver.AppImage"
+ ./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
+
+ # Correct path for .desktop file
+ mv "squashfs-root/com.moonlight_stream.Moonlight.desktop" "squashfs-root/${pkgname%-bin}.desktop"
+ #sed -i "s|Exec=${_bin_name}|Exec=/usr/bin/${_bin_name}|g" "squashfs-root/${pkgname%-bin}.desktop"
+
+ # Remove X-AppImage-Version
+ sed -i '/AppImage/d' "squashfs-root/${pkgname%-bin}.desktop"
+}
+
+package() {
+ install -Dm755 "squashfs-root/usr/bin/${_bin_name}" -t "$pkgdir/usr/bin/"
+
+ install -Dm644 "squashfs-root/${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications/"
+
+ install -d "$pkgdir/usr/share/icons/"
+ cp -r squashfs-root/usr/share/icons/hicolor/ "$pkgdir/usr/share/icons/"
+}