summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-16 15:03:11 +0300
committerCaleb Maclennan2023-03-16 15:03:11 +0300
commit2c4299c8120e0c0e94bff66b7b6fdfcffa4dd79a (patch)
tree94bd0f0e18d7258ba201c4fd24bfeabc1415ab6f
parent90df5e5d69cd7fddc1ff38aa8201d03e1096ed80 (diff)
downloadaur-2c4299c8120e0c0e94bff66b7b6fdfcffa4dd79a.tar.gz
upgpkg: moonray-git 1.0.0.0-1
upstream release Use same source module locations as stable package
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD48
2 files changed, 81 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a18b753afe8..2e2c652da243 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,42 @@ pkgbase = moonray-git
license = Apache2
makedepends = cmake
source = openmoonray::git+https://github.com/dreamworksanimation/openmoonray#tag=v1.0.0.0
+ source = openmoonray+arras+arras4_core::git+https://github.com/dreamworksanimation/arras4_core.git
+ source = openmoonray+arras+arras_render::git+https://github.com/dreamworksanimation/arras_render.git
+ source = openmoonray+arras+distributed+arras4_node::git+https://github.com/dreamworksanimation/arras4_node.git
+ source = openmoonray+arras+distributed+minicoord::git+https://github.com/dreamworksanimation/minicoord.git
+ source = openmoonray+cmake_modules::git+https://github.com/dreamworksanimation/cmake_modules.git
+ source = openmoonray+moonray+hydra+hdMoonray::git+https://github.com/dreamworksanimation/hdMoonray.git
+ source = openmoonray+moonray+hydra+moonray_sdr_plugins::git+https://github.com/dreamworksanimation/moonray_sdr_plugins.git
+ source = openmoonray+moonray+mcrt_denoise::git+https://github.com/dreamworksanimation/mcrt_denoise.git
+ source = openmoonray+moonray+moonray::git+https://github.com/dreamworksanimation/moonray.git
+ source = openmoonray+moonray+moonray_arras+mcrt_computation::git+https://github.com/dreamworksanimation/mcrt_computation.git
+ source = openmoonray+moonray+moonray_arras+mcrt_dataio::git+https://github.com/dreamworksanimation/mcrt_dataio.git
+ source = openmoonray+moonray+moonray_arras+mcrt_messages::git+https://github.com/dreamworksanimation/mcrt_messages.git
+ source = openmoonray+moonray+moonray_dcc_plugins::git+https://github.com/dreamworksanimation/moonray_dcc_plugins.git
+ source = openmoonray+moonray+moonray_gui::git+https://github.com/dreamworksanimation/moonray_gui.git
+ source = openmoonray+moonray+moonshine::git+https://github.com/dreamworksanimation/moonshine.git
+ source = openmoonray+moonray+moonshine_usd::git+https://github.com/dreamworksanimation/moonshine_usd.git
+ source = openmoonray+moonray+render_profile_viewer::git+https://github.com/dreamworksanimation/render_profile_viewer.git
+ source = openmoonray+moonray+scene_rdl2::git+https://github.com/dreamworksanimation/scene_rdl2.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = moonray-git
diff --git a/PKGBUILD b/PKGBUILD
index bf946af755ce..13b0939582e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,53 @@ pkgdesc='DreamWorks’ production MCRT renderer'
arch=(x86_64)
license=(Apache2)
url="https://$_pkgname.org"
-_url="https://github.com/dreamworksanimation/$_pkgname"
+_url="https://github.com/dreamworksanimation"
depends=()
makedepends=(cmake)
-source=("$_pkgname::git+$_url#tag=v$pkgver")
-sha256sums=('SKIP')
+source=("$_pkgname::git+$_url/$_pkgname#tag=v$pkgver"
+ "$_pkgname+arras+arras4_core::git+$_url/arras4_core.git"
+ "$_pkgname+arras+arras_render::git+$_url/arras_render.git"
+ "$_pkgname+arras+distributed+arras4_node::git+$_url/arras4_node.git"
+ "$_pkgname+arras+distributed+minicoord::git+$_url/minicoord.git"
+ "$_pkgname+cmake_modules::git+$_url/cmake_modules.git"
+ "$_pkgname+moonray+hydra+hdMoonray::git+$_url/hdMoonray.git"
+ "$_pkgname+moonray+hydra+moonray_sdr_plugins::git+$_url/moonray_sdr_plugins.git"
+ "$_pkgname+moonray+mcrt_denoise::git+$_url/mcrt_denoise.git"
+ "$_pkgname+moonray+moonray::git+$_url/moonray.git"
+ "$_pkgname+moonray+moonray_arras+mcrt_computation::git+$_url/mcrt_computation.git"
+ "$_pkgname+moonray+moonray_arras+mcrt_dataio::git+$_url/mcrt_dataio.git"
+ "$_pkgname+moonray+moonray_arras+mcrt_messages::git+$_url/mcrt_messages.git"
+ "$_pkgname+moonray+moonray_dcc_plugins::git+$_url/moonray_dcc_plugins.git"
+ "$_pkgname+moonray+moonray_gui::git+$_url/moonray_gui.git"
+ "$_pkgname+moonray+moonshine::git+$_url/moonshine.git"
+ "$_pkgname+moonray+moonshine_usd::git+$_url/moonshine_usd.git"
+ "$_pkgname+moonray+render_profile_viewer::git+$_url/render_profile_viewer.git"
+ "$_pkgname+moonray+scene_rdl2::git+$_url/scene_rdl2.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+# git submodule status | cut -c2- | awk '{s=$2; gsub("/", "+", s); gsub(".*/", "", $2); print "\"$_pkgname+" s "::git+$_url/" $2 ".git\"" }'
+
+prepare() {
+ cd "$_pkgname"
+}
build() {
cd "$_pkgname"