summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCory Sanin2022-02-20 19:08:48 -0600
committerCory Sanin2022-02-20 19:08:48 -0600
commit133d7d08f11fa643de7376415ebd0b5107487a50 (patch)
tree11d4f818f6093f06a57b1a199bcc72c1c4bc3e55
downloadaur-133d7d08f11fa643de7376415ebd0b5107487a50.tar.gz
add moonscraper-chart-editor-bin to the AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e02c23838f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = moonscraper-chart-editor-bin
+ pkgdesc = Moonscraper Chart Editor is a song editor for Guitar Hero style rhythm games.
+ pkgver = 1.4.3.4
+ pkgrel = 0
+ url = https://github.com/FireFox2000000/Moonscraper-Chart-Editor
+ arch = x86_64
+ arch = i686
+ license = BSD-3-Clause
+ provides = moonscraper-chart-editor
+ conflicts = moonscraper-chart-editor
+ options = !strip
+ source = moonscraper.tar.gz::https://github.com/FireFox2000000/Moonscraper-Chart-Editor/releases/download/1.4.3.4/Moonscraper.Chart.Editor.v1.4.3.4.Linux.Universal.tar.gz
+ source = moonscraper-chart-editor.desktop::https://raw.githubusercontent.com/FireFox2000000/Moonscraper-Chart-Editor/1.4.3.4/aur/moonscraper-chart-editor.desktop
+ source = https://raw.githubusercontent.com/FireFox2000000/Moonscraper-Chart-Editor/1.4.3.4/LICENSE
+ sha1sums = 8d782b2b72c057cb47789007d5fe75bfdcff3113
+ sha1sums = e4c64c84730ee05b26e521537fc09fa82925fe72
+ sha1sums = 2d61750d08d43082718a1548810f76be186a9030
+
+pkgname = moonscraper-chart-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74e459376d4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Cory Sanin <corysanin@outlook.com>
+
+_pkgname=moonscraper-chart-editor
+pkgname=${_pkgname}-bin
+pkgdesc="Moonscraper Chart Editor is a song editor for Guitar Hero style rhythm games."
+pkgver=1.4.3.4
+pkgrel=0
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+url="https://github.com/FireFox2000000/Moonscraper-Chart-Editor"
+arch=("x86_64"
+ "i686")
+license=("BSD-3-Clause")
+_commit="$pkgver"
+source=("moonscraper.tar.gz"::"https://github.com/FireFox2000000/Moonscraper-Chart-Editor/releases/download/1.4.3.4/Moonscraper.Chart.Editor.v1.4.3.4.Linux.Universal.tar.gz"
+ "$_pkgname.desktop"::"https://raw.githubusercontent.com/FireFox2000000/Moonscraper-Chart-Editor/$_commit/aur/moonscraper-chart-editor.desktop"
+ "https://raw.githubusercontent.com/FireFox2000000/Moonscraper-Chart-Editor/$_commit/LICENSE")
+sha1sums=("8d782b2b72c057cb47789007d5fe75bfdcff3113"
+ "e4c64c84730ee05b26e521537fc09fa82925fe72"
+ "2d61750d08d43082718a1548810f76be186a9030")
+options=(!strip)
+
+package() {
+ find "$srcdir" -maxdepth 1 -type d -name "Moonscraper Chart Editor * Linux (Universal)" -exec mv '{}' "$srcdir/moonscraper" \;
+ if [ "$CARCH" = "i686" ]; then
+ _UNITY_ARCH=x86
+ else
+ _UNITY_ARCH=$CARCH
+ fi
+ _executable="Moonscraper Chart Editor.$_UNITY_ARCH"
+
+ # Install application to /opt
+ install -d "$pkgdir/opt/$_pkgname"
+ cp "$srcdir/moonscraper/$_executable" "$pkgdir/opt/$_pkgname/"
+ cp -R "$srcdir/moonscraper/Moonscraper Chart Editor_Data" "$pkgdir/opt/$_pkgname/"
+ printf "#\041/bin/sh\nexec \"/opt/$_pkgname/$_executable\" \"\$@\"" > "$pkgdir/opt/$_pkgname/$_pkgname"
+ chmod 755 "$pkgdir/opt/$_pkgname/$_pkgname"
+
+ # Install binary symlink and desktop files
+ install -d "$pkgdir"/usr/{bin,share/{pixmaps,applications,licenses}}
+ ln -s "/opt/$_pkgname/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "$_pkgname.desktop" "$pkgdir/usr/share/applications"
+
+ # Icon
+ ln -s "/opt/$_pkgname/Moonscraper Chart Editor_Data/Resources/UnityPlayer.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+
+ # License
+ install -Dm 644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm 644 "$srcdir/moonscraper/Documentation/attribution.txt" "$pkgdir/usr/share/licenses/$_pkgname/attribution.txt"
+}