summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Löthberg2014-09-20 19:10:56 +0100
committerJohannes Löthberg2015-06-08 12:35:58 +0200
commit37dc05266eda14955fe866021c98546be45f2432 (patch)
tree0fed3776d9ab7f11286e5c1ee1f1f4c744f79f33
downloadaur-37dc05266eda14955fe866021c98546be45f2432.tar.gz
moonshine: Import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4b9108d0044
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 1 13:54:06 UTC 2015
+pkgbase = moonshine
+ pkgdesc = A lightweight Lua VM for the browser
+ pkgver = 0.0.11
+ pkgrel = 1
+ url = http://moonshinejs.org
+ arch = any
+ license = GPL3
+ depends = lua
+ depends = nodejs
+ noextract = moonshine-0.0.11.tgz
+ source = http://registry.npmjs.org/moonshine/-/moonshine-0.0.11.tgz
+ sha1sums = ae822c99c67974e323c98607cc3caef0b2d5f6ad
+
+pkgname = moonshine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c8172383d08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=moonshine
+pkgver=0.0.11
+pkgrel=1
+
+pkgdesc="A lightweight Lua VM for the browser"
+url="http://moonshinejs.org"
+arch=('any')
+license=('GPL3')
+
+depends=('lua' 'nodejs')
+
+source=(http://registry.npmjs.org/moonshine/-/moonshine-$pkgver.tgz)
+
+noextract=(moonshine-$pkgver.tgz)
+
+sha1sums=(ae822c99c67974e323c98607cc3caef0b2d5f6ad)
+
+package() {
+ npm install -g --prefix "$pkgdir"/usr moonshine-$pkgver.tgz
+}