summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjzbor2021-04-23 13:31:13 +0200
committerjzbor2021-04-23 13:31:13 +0200
commit131b85648b1919fdec001a1071fe6f49adb9fd9f (patch)
tree8ab3a1396e34db3de95b79b6ac18a6c46c0e8357
downloadaur-131b85648b1919fdec001a1071fe6f49adb9fd9f.tar.gz
Initial commit (7.0.0)
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD41
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b6b69cf4858
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = moonwm
+ pkgdesc = My own outstandingly named Window Manager (a dynamic window manager)
+ pkgver = 7.0.0
+ pkgrel = 1
+ url = https://github.com/jzbor/moonwm
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = libx11
+ depends = libxcb
+ depends = libxinerama
+ depends = slop
+ depends = xmenu
+ depends = xorg-xsetroot
+ depends = dmenu
+ depends = ffmpeg
+ depends = geoclue
+ depends = i3lock
+ depends = imagemagick
+ depends = kdeconnect
+ depends = libnotify
+ depends = light
+ depends = network-manager-applet
+ depends = notification-daemon
+ depends = otf-nerd-fonts-fira-code
+ depends = pamixer
+ depends = picom
+ depends = polkit-gnome
+ depends = redshift
+ depends = skippy-xd
+ depends = wmname
+ depends = xdotool
+ depends = xfce4-power-manager
+ depends = xorg-setxkbmap
+ depends = xorg-xrandr
+ depends = xorg-xrdb
+ depends = xwallpaper
+ optdepends = matcha-gtk-theme: a fitting GTK theme (Matcha-dark-aliz),
+ optdepends = numix-circle-icon-theme: an icon theme that fits nicely,
+ optdepends = lxappearance: GUI for configuring GTK and icon theme,
+ optdepends = xfce4-notifyd: a good default notification-daemon
+ provides = moonwm
+ conflicts = moonwm
+ source = https://github.com/jzbor/moonwm/archive/refs/tags/7.0.0.tar.gz
+ md5sums = 26d04522e165f1626285efbd3463c97d
+
+pkgname = moonwm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..198b36ff778e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: jzbor <zborof at posteo dot de>
+pkgname=moonwm
+pkgver=7.0.0
+pkgrel=1
+pkgdesc="My own outstandingly named Window Manager (a dynamic window manager)"
+arch=(x86_64 i686)
+url="https://github.com/jzbor/moonwm"
+license=('MIT')
+groups=()
+depends=(libx11 libxcb libxinerama slop xmenu xorg-xsetroot dmenu ffmpeg geoclue i3lock imagemagick kdeconnect libnotify light network-manager-applet notification-daemon otf-nerd-fonts-fira-code pamixer picom polkit-gnome redshift skippy-xd wmname xdotool xfce4-power-manager xorg-setxkbmap xorg-xrandr xorg-xrdb xwallpaper)
+makedepends=()
+checkdepends=()
+optdepends=(\
+ 'matcha-gtk-theme: a fitting GTK theme (Matcha-dark-aliz)',
+ 'numix-circle-icon-theme: an icon theme that fits nicely',
+ 'lxappearance: GUI for configuring GTK and icon theme',
+ 'xfce4-notifyd: a good default notification-daemon')
+provides=(moonwm)
+conflicts=(moonwm)
+replaces=()
+backup=()
+options=()
+source=("git+$url")
+source=("$url/archive/refs/tags/$pkgver.tar.gz")
+noextract=()
+md5sums=('26d04522e165f1626285efbd3463c97d')
+validpgpkeys=()
+
+build() {
+ cd "${pkgname}"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 FREETYPEINC=/usr/include/freetype2
+}
+
+package() {
+ cd "${pkgname}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install install-scripts
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/moonwm/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/moonwm/README.md"
+}
+
+