summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Wienke2021-10-02 19:01:31 +0200
committerJohannes Wienke2021-10-02 19:01:31 +0200
commitf1f0b4412b905b656c21fc012737fc232351378a (patch)
tree66f27b29b0b75cf35bc0cde6e15bce6e8b20b58e
parentf74fe5f33b0fba5e7c4f95726d88fd9773f70a2a (diff)
downloadaur-f1f0b4412b905b656c21fc012737fc232351378a.tar.gz
ci: add a renovate config
-rw-r--r--.gitlab-ci.yml42
1 files changed, 42 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..7a4567ff98bb
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,42 @@
+build:
+ stage: build
+ image:
+ name: countstarlight/makepkg:latest
+ entrypoint: [""]
+ before_script:
+ - yay -Syu --noconfirm
+ script:
+ - |
+ depends=()
+ makedepends=()
+ checkdepends=()
+ . ./PKGBUILD
+ deps=( "${depends[@]}" "${makedepends[@]}" "${checkdepends[@]}" )
+ (pacman --deptest "${deps[@]}" || true) | xargs yay -Sy --noconfirm
+ - makepkg -f
+ artifacts:
+ untracked: false
+ expire_in: 5 days
+ paths:
+ - '*.pkg.tar.zst'
+
+deploy:
+ stage: deploy
+ image: bitnami/git:latest
+ rules:
+ - if: $CI_COMMIT_BRANCH == $CI_DEFAULT_BRANCH
+ variables:
+ GIT_DEPTH: "0"
+ before_script:
+ - mkdir -p ~/.ssh
+ - chmod 700 ~/.ssh
+
+ - ssh-keyscan aur.archlinux.org >> ~/.ssh/known_hosts
+ - chmod 644 ~/.ssh/known_hosts
+
+ - eval $(ssh-agent -s)
+ - echo "$SSH_PRIVATE_KEY" | tr -d '\r' | ssh-add -
+
+ script:
+ - git remote add aur ssh://aur@aur.archlinux.org/mopidy-alsamixer.git
+ - git push aur origin/master:master