summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Maunier2021-06-04 16:49:53 +0200
committerFlorian Maunier2021-06-04 16:49:53 +0200
commit12a8fb88a797864b9f0ca5231fce1d851472bb4b (patch)
treebfc5b85b86cfd313884fac64aa9fd07cc590c758
downloadaur-12a8fb88a797864b9f0ca5231fce1d851472bb4b.tar.gz
Initial packaging with version 0.2.2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2ad7d9c4147
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mopidy-autoplay
+ pkgdesc = Mopidy extension to automatically pick up where you left off and start playing the last track from the position before Mopidy was shut down.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/sphh/mopidy-autoplay
+ arch = any
+ license = APACHE
+ depends = mopidy>=3
+ depends = python-pykka
+ depends = python-setuptools
+ source = mopidy-autoplay-0.2.2.tar.gz::https://github.com/sphh/mopidy-autoplay/archive/v0.2.2.tar.gz
+ sha256sums = fc49aca41ff5ae77559dabac4219b6d9dfa32962bcabef73c4933548d6d1182b
+
+pkgname = mopidy-autoplay
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..58e481c22754
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+pkg/
+src/
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51c8f6d44340
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Florian Maunier <fmauneko@dissidence.ovh>
+
+pkgname=mopidy-autoplay
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Mopidy extension to automatically pick up where you left off and start playing the last track from the position before Mopidy was shut down."
+arch=('any')
+url="https://github.com/sphh/mopidy-autoplay"
+license=('APACHE')
+depends=(
+ 'mopidy>=3'
+ python-pykka
+ python-setuptools
+)
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/sphh/$pkgname/archive/v$pkgver.tar.gz"
+)
+sha256sums=('fc49aca41ff5ae77559dabac4219b6d9dfa32962bcabef73c4933548d6d1182b')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}