summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormitts2016-11-27 16:18:35 -0800
committermitts2016-11-27 16:18:35 -0800
commite94e130149733bce7fa5d19012e1871286cf6244 (patch)
treed867e52e5fd136af97090ed6093a5509f34cde8f
downloadaur-e94e130149733bce7fa5d19012e1871286cf6244.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f1f3724d344
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mopidy-gmusic
+ pkgdesc = Mopidy extension for playing music from Google Play Music
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/mopidy/mopidy-gmusic
+ arch = any
+ license = APACHE
+ makedepends = python2-setuptools
+ depends = python2-setuptools
+ depends = mopidy>=1.0.0
+ depends = python2-pykka>=1.1.0
+ depends = python2-gmusicapi>=10.1.0
+ depends = python2-requests>=2.0
+ depends = python2-cachetools>=1.0.0
+ source = https://github.com/mopidy/mopidy-gmusic/archive/v2.0.0.tar.gz
+ md5sums = 5b209aa86a9598710cd892d2947538a9
+
+pkgname = mopidy-gmusic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86fd4928b55e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: mitts <mittens2001@opmbx.org>
+
+pkgname=mopidy-gmusic
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Mopidy extension for playing music from Google Play Music"
+arch=('any')
+url="https://github.com/mopidy/mopidy-gmusic"
+license=('APACHE')
+depends=('python2-setuptools' 'mopidy>=1.0.0' 'python2-pykka>=1.1.0' 'python2-gmusicapi>=10.1.0'
+ 'python2-requests>=2.0' 'python2-cachetools>=1.0.0')
+makedepends=('python2-setuptools')
+source=("https://github.com/mopidy/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('14ccbd465b1911992d20b4d35e397158')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}