summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2017-12-23 15:46:35 +0100
committerMarcin Wieczorek2017-12-23 15:46:35 +0100
commit67729f6865d9e6e27255783aaf15eafb1fe0a3d5 (patch)
tree5f74bf55b13c342ab15e896108197c6fcf577fca
parent19fd22164c14b389654c01f00388a45ac8514b27 (diff)
downloadaur-67729f6865d9e6e27255783aaf15eafb1fe0a3d5.tar.gz
Version 3.9.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b4119eca7af..15c0080f9816 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mopidy-iris
pkgdesc = A Mopidy Web client that utilizes the Spotify and EchoNest frameworks. (Formerly Spotmop)
- pkgver = 3.8.9
+ pkgver = 3.9.0
pkgrel = 1
url = https://github.com/jaedb/iris
arch = any
@@ -16,8 +16,8 @@ pkgbase = mopidy-iris
depends = python2-pylast
depends = python2-raven
optdepends = mopidy-local-sqlite: local library support
- source = https://files.pythonhosted.org/packages/source/M/Mopidy-Iris/Mopidy-Iris-3.8.9.tar.gz
- sha256sums = 13a13511d1404efd7df2526ad00f3995aab3e4b41cc63fe534944b286edbf2cf
+ source = https://files.pythonhosted.org/packages/source/M/Mopidy-Iris/Mopidy-Iris-3.9.0.tar.gz
+ sha256sums = e4b000e33952c89e1ffe641dd3d9ba4eadb132b989990547ec99bf4c5fdd92a0
pkgname = mopidy-iris
diff --git a/PKGBUILD b/PKGBUILD
index a4982717a8cf..972463ba39f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,20 @@
_pkgname=iris
pkgname=mopidy-${_pkgname}
-pkgver=3.8.9
+pkgver=3.9.0
pkgrel=1
pkgdesc='A Mopidy Web client that utilizes the Spotify and EchoNest frameworks. (Formerly Spotmop)'
arch=('any')
url="https://github.com/jaedb/${_pkgname}"
license=('APACHE')
depends=('python2' 'mopidy' 'mopidy-spotify' 'python2-configobj'
- 'mopidy-local-images' 'python2-pylast'
- 'python2-raven')
+ 'mopidy-local-images' 'python2-pylast' 'python2-raven')
makedepends=('python2' 'python2-setuptools' 'python2-pip')
optdepends=('mopidy-local-sqlite: local library support')
source=("https://files.pythonhosted.org/packages/source/M/Mopidy-Iris/Mopidy-Iris-${pkgver}.tar.gz")
-sha256sums=('13a13511d1404efd7df2526ad00f3995aab3e4b41cc63fe534944b286edbf2cf')
+sha256sums=('e4b000e33952c89e1ffe641dd3d9ba4eadb132b989990547ec99bf4c5fdd92a0')
package() {
cd "${srcdir}/Mopidy-Iris-${pkgver}"
- PIP_CONFIG_FILE=/dev/null pip2 install \
- --isolated \
- --root="${pkgdir}" \
- --ignore-installed \
- --no-deps .
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
}