summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Moak2015-06-12 20:22:06 -0700
committerScott Moak2015-06-12 20:22:06 -0700
commit3d1078009ebc762986c56d1d8d510875e6805037 (patch)
treec348e63bb52531a261b8213a8a4e69f5e2d45705
downloadaur-3d1078009ebc762986c56d1d8d510875e6805037.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55f593c6db68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mopidy-musicbox
+ pkgdesc = Web Client for Mopidy Music Server and the Pi MusicBox
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/woutervanwijk/Mopidy-MusicBox-Webclient
+ arch = any
+ license = APACHE
+ makedepends = python2
+ makedepends = python2-setuptools
+ depends = python2
+ depends = mopidy>=0.19
+ source = https://pypi.python.org/packages/source/M/Mopidy-MusicBox-Webclient/Mopidy-MusicBox-Webclient-1.0.1.tar.gz
+ md5sums = 6a709cb058a6d30beb86e5204a8441b3
+
+pkgname = mopidy-musicbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa73f9e4d37a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Scott Moak <scott dot moak at gmail dot com>
+
+pkgname=mopidy-musicbox
+_pypiname=Mopidy-MusicBox-Webclient
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Web Client for Mopidy Music Server and the Pi MusicBox"
+arch=('any')
+url="https://github.com/woutervanwijk/Mopidy-MusicBox-Webclient"
+license=('APACHE')
+depends=('python2' 'mopidy>=0.19')
+makedepends=('python2' 'python2-setuptools')
+source=("https://pypi.python.org/packages/source/M/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('6a709cb058a6d30beb86e5204a8441b3')
+
+package() {
+ cd "${srcdir}/${_pypiname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: