summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSasha Moak2020-05-16 11:22:18 -0700
committerSasha Moak2020-05-16 11:22:18 -0700
commitf6b32c27537a0419ca317f7e7033c1495702ecfd (patch)
treea43b98344fd858a28af840c7acb22a9add3ec457
parent452aea7f61896a083ffde1e9b09460b6dae4d4f5 (diff)
downloadaur-f6b32c27537a0419ca317f7e7033c1495702ecfd.tar.gz
Updating to v3.1.0
Removing license install. Its not needed since Apache license is already installed via the licenses package Updating to use the github for the source download instead of pypi
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c1cb8c5292c..9e4b287d136e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = mopidy-musicbox
pkgdesc = Web Client for Mopidy Music Server and the Pi MusicBox
- pkgver = 3.0.1
- pkgrel = 2
- url = https://github.com/woutervanwijk/Mopidy-MusicBox-Webclient
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://github.com/pimusicbox/mopidy-musicbox-webclient
arch = any
- license = APACHE
+ license = Apache
makedepends = python
makedepends = python-setuptools
depends = python
depends = mopidy>=3.0
- depends = python-pykka
- source = https://pypi.python.org/packages/90/b9/ffdbb35edcaeb7b957a0bf0c19134e4da7eec12826596761180fdfda2461/Mopidy-MusicBox-Webclient-3.0.1.tar.gz
- sha256sums = 1f094c55d3034159ecba511a1e57ec300336f560f8d910d58ee7dd406409d0ff
+ source = https://github.com/pimusicbox/mopidy-musicbox-webclient/archive/v3.1.0.tar.gz
+ sha256sums = 7c9dc906923280809e38a326a539a82ab5eaeb9c3d526b12fefbc93efac0be96
pkgname = mopidy-musicbox
diff --git a/PKGBUILD b/PKGBUILD
index da06ce87dec2..935f77b6e8df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
# Maintainer: Sasha Moak <sasha dot moak at gmail dot com>
pkgname=mopidy-musicbox
-_pypiname=Mopidy-MusicBox-Webclient
-pkgver=3.0.1
-pkgrel=2
+pkgver=3.1.0
+pkgrel=1
pkgdesc="Web Client for Mopidy Music Server and the Pi MusicBox"
arch=('any')
-url="https://github.com/woutervanwijk/Mopidy-MusicBox-Webclient"
-license=('APACHE')
-depends=('python' 'mopidy>=3.0' 'python-pykka')
+url="https://github.com/pimusicbox/mopidy-musicbox-webclient"
+license=('Apache')
+depends=('python' 'mopidy>=3.0')
makedepends=('python' 'python-setuptools')
-source=("https://pypi.python.org/packages/90/b9/ffdbb35edcaeb7b957a0bf0c19134e4da7eec12826596761180fdfda2461/${_pypiname}-${pkgver}.tar.gz")
-sha256sums=('1f094c55d3034159ecba511a1e57ec300336f560f8d910d58ee7dd406409d0ff')
+source=("https://github.com/pimusicbox/${pkgname}-webclient/archive/v${pkgver}.tar.gz")
+sha256sums=('7c9dc906923280809e38a326a539a82ab5eaeb9c3d526b12fefbc93efac0be96')
package() {
- cd "${srcdir}/${_pypiname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-webclient-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
-
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: