summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2015-06-08 21:04:16 +0200
committerBjoern Franke2015-06-08 21:04:16 +0200
commit7ff4ab4a9aae0995bbb3cf11336180faf27f3d96 (patch)
tree394f663e4ada6c41ff3767296ed02db91e83656a
downloadaur-7ff4ab4a9aae0995bbb3cf11336180faf27f3d96.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..163bde8fc4ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mopidy-podcast-itunes
+ pkgdesc = Mopidy-Podcast extension for searching and browsing podcasts on the iTunes Store
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/tkem/mopidy-podcast-itunes
+ arch = any
+ license = APACHE
+ makedepends = python2
+ makedepends = git
+ depends = mopidy>=1.0
+ depends = mopidy-podcast
+ depends = python2-requests
+ source = https://pypi.python.org/packages/source/M/Mopidy-Podcast-iTunes/Mopidy-Podcast-iTunes-1.0.0.tar.gz
+ md5sums = c405fffd9ada8115a8b5ae35865105d8
+
+pkgname = mopidy-podcast-itunes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecbd037aab07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: bjo@nord-west.org
+
+pkgname=mopidy-podcast-itunes
+_pypiname=Mopidy-Podcast-iTunes
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Mopidy-Podcast extension for searching and browsing podcasts on the iTunes Store"
+arch=('any')
+url="https://github.com/tkem/mopidy-podcast-itunes"
+license=('APACHE')
+depends=(
+ 'mopidy>=1.0'
+ 'mopidy-podcast'
+ 'python2-requests'
+)
+makedepends=('python2' 'git')
+source=("https://pypi.python.org/packages/source/M/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('c405fffd9ada8115a8b5ae35865105d8')
+
+package() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}