summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDušan Simić2023-05-22 02:04:04 +0200
committerDušan Simić2023-05-22 02:04:04 +0200
commitd3bd0db27c9cd0da27b848f1339406df19c971d3 (patch)
treeef03d786f296a81ca929959ac44c0c7fc1cefb32
parentf1cd982e7f1d5e0e72716be5a05f156c6736b15b (diff)
downloadaur-d3bd0db27c9cd0da27b848f1339406df19c971d3.tar.gz
Don't install junk files
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f9e9485a7b4..7608eb16f008 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = morewaita-git
pkgdesc = An Adwaita style extra icons theme for Gnome Shell.
- pkgver = 44.r2.g70390da
+ pkgver = 44.1.r54.g79fd860
pkgrel = 1
url = https://github.com/somepaulo/MoreWaita
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index fed6f95f53f7..48248f6a8483 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=morewaita-git
_reponame=MoreWaita
-pkgver=44.r2.g70390da
+pkgver=44.1.r54.g79fd860
pkgrel=1
pkgdesc='An Adwaita style extra icons theme for Gnome Shell.'
arch=(any)
@@ -21,8 +21,16 @@ pkgver() {
}
package() {
- install -d "$pkgdir/usr/share/icons"
+ local themedir="$pkgdir/usr/share/icons/MoreWaita"
+ install -d "$themedir"
- rm -rf "$_reponame/.git"
- cp -r "$_reponame" "$pkgdir/usr/share/icons"
+ cp -r "$_reponame/apps" "$themedir/apps"
+ cp -r "$_reponame/mimes" "$themedir/mimes"
+ cp -r "$_reponame/panel" "$themedir/panel"
+ cp -r "$_reponame/places" "$themedir/places"
+ cp -P "$_reponame/apps@2x" "$themedir/apps@2x"
+ cp -P "$_reponame/mimes@2x" "$themedir/mimes@2x"
+ cp -P "$_reponame/panel@2x" "$themedir/panel@2x"
+ cp -P "$_reponame/places@2x" "$themedir/places@2x"
+ cp "$_reponame/index.theme" "$themedir/index.theme"
}