summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Rydzewski2018-02-10 23:03:35 +0100
committerJan Rydzewski2018-02-10 23:03:35 +0100
commit13885547d26d904351feaa22faf0e6a942adca0a (patch)
tree85dd49a6f374a35586da19031e610de4c578c4e2
downloadaur-13885547d26d904351feaa22faf0e6a942adca0a.tar.gz
Initial, version 20180204
-rw-r--r--.SRCINFO22
-rw-r--r--LICENCE14
-rw-r--r--PKGBUILD48
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1401bbda329e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = morfeusz2
+ pkgdesc = Morphological analyser Morfeusz
+ pkgver = 20180204
+ pkgrel = 1
+ url = http://sgjp.pl/morfeusz/
+ arch = x86_64
+ license = BSD
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = LICENCE
+ source = http://sgjp.pl/morfeusz/download/20180204/morfeusz-src-20180204.tar.gz
+ sha256sums = 16c7ca379ef9fb6368c20d0ee71a9c83dd9c55e3b9fc34aade443c33d731d829
+ sha256sums = 663138c8a73f76b442582582f13a1946d4d70c6cb81a235e113126faa5365722
+
+pkgname = morfeusz2
+ depends = gcc-libs
+
+pkgname = python2-morfeuszbuilder
+ arch = any
+ depends = python2
+ depends = python2-pyparsing
+
diff --git a/LICENCE b/LICENCE
new file mode 100644
index 000000000000..d974806bd530
--- /dev/null
+++ b/LICENCE
@@ -0,0 +1,14 @@
+* The copyright holder of Morfeusz 2 (the program) is Institute of Computer Science PAS (http://www.ipipan.waw.pl/).
+* The authors and copyright holders of SGJP inflectional data are Zygmunt Saloni, Włodzimierz Gruszczyński, Marcin Woliński, Robert Wołosz i Danuta Skowrońska.
+* The copyright holder of Polimorf inflectional data is Institute of Computer Science PAS (http://www.ipipan.waw.pl/).
+
+The program including contained linguistic data is hereby released under the conditions of the so called 2-clause BSD License:
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY COPYRIGHT HOLDERS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..657944d95032
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jan Rydzewski <flegmer@gmail.com>
+
+pkgname=(morfeusz2 python2-morfeuszbuilder)
+pkgver=20180204
+pkgrel=1
+pkgdesc="Morphological analyser Morfeusz"
+arch=('x86_64')
+url='http://sgjp.pl/morfeusz/'
+license=('BSD')
+
+makedepends=('python2' 'python2-setuptools')
+
+source=("LICENCE"
+ "http://sgjp.pl/morfeusz/download/$pkgver/morfeusz-src-$pkgver.tar.gz")
+sha256sums=("16c7ca379ef9fb6368c20d0ee71a9c83dd9c55e3b9fc34aade443c33d731d829"
+ "663138c8a73f76b442582582f13a1946d4d70c6cb81a235e113126faa5365722")
+
+function prepare {
+ # disable wrappers building
+ echo "" > "$srcdir/trunk/morfeusz/wrappers/CMakeLists.txt"
+}
+
+function build {
+ cd "$srcdir/trunk"
+ cmake \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D SKIP_DICTIONARY_BUILDING=1 \
+ -D DEFAULT_DICT_NAME=sgjp \
+ -D EMBEDDED_DEFAULT_DICT=0 \
+ .
+ make libmorfeusz morfeusz_analyzer morfeusz_generator morfeusz_analyzer_old
+ make CXX_FLAGS=-std=c++11 test_runner
+}
+
+function package_morfeusz2 {
+ depends=('gcc-libs')
+ cd "$srcdir/trunk"
+ make DESTDIR="$pkgdir/" install
+ install -D -t "$pkgdir/usr/share/licenses/morfeusz2" "$srcdir/LICENCE"
+}
+
+function package_python2-morfeuszbuilder {
+ depends=('python2' 'python2-pyparsing')
+ arch=('any')
+ cd "$srcdir/trunk/fsabuilder"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -t "$pkgdir/usr/share/licenses/python2-morfeuszbuilder" "$srcdir/LICENCE"
+}