summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Sonnleitner2022-07-26 13:07:21 +0200
committerErik Sonnleitner2022-07-26 13:07:21 +0200
commit1d3c9bc4b5a45efd44feabcf5d1d2f8f7d4847b3 (patch)
tree60845db0539fd8faa51b1c98dafd29e0fedfbe50
parent43c31002900858e88074942f57d0908ca23209a3 (diff)
downloadaur-1d3c9bc4b5a45efd44feabcf5d1d2f8f7d4847b3.tar.gz
Updated to 2.5.8. Startscript now detects Wayland
-rw-r--r--.SRCINFO6
-rw-r--r--ChangeLog23
-rw-r--r--PKGBUILD4
-rwxr-xr-xmorgen9
4 files changed, 36 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f229a1a90af..fab7419c2cac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = morgen-bin
pkgdesc = Morgen is a modern, intuitive and smart calendar application and successor to MineTime
- pkgver = 2.5.6
+ pkgver = 2.5.8
pkgrel = 1
url = https://morgen.so
changelog = ChangeLog
@@ -12,9 +12,9 @@ pkgbase = morgen-bin
depends = hicolor-icon-theme
depends = desktop-file-utils
provides = morgen
- source = https://download.todesktop.com/210203cqcj00tw1/morgen-2.5.6.deb
+ source = https://download.todesktop.com/210203cqcj00tw1/morgen-2.5.8.deb
source = morgen
- b2sums = b14a1e1d277b930b78f0bd63034098184ad7b71e6ccc5b7cca070841355e22b154ff9c1d341bbe1f8dfef9a9f7c33803f6a54196039a897983785ede3c87d047
+ b2sums = 14fc344aa04a69560155c13b8ab357ad5484683354a0843c42e6a1addc36a9eb9d60d60ebe37fc7910e50def26c85a294470c8ac12f91a9e65153fcdf076a17e
b2sums = 22bb3535edf2320bcb51a81e8865b0775b129ff1fad8007c6c9f385f4cdc241b0d166dd8e51a700ad7a1bf72efdcb2d5a13bb3b39ec8aa2db0a71fc22dfeeb57
pkgname = morgen-bin
diff --git a/ChangeLog b/ChangeLog
index 9de47d61e32d..9c83d6329a98 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -418,3 +418,26 @@ Fixes:
- An issue that occurred when copying an event where the new timezone differs from the original one has been fixed
- Morgen custom notifications on Linux are back on track
- We fixed an issue that caused possible double bookings from scheduling links when clicking twice on the Confirmation button
+
+=== Morgen 2.5.7
+New Features:
+- If you are like us and rely on your calendar throughout the day, you surely enjoy the Morgen global shortcut. With Alt+C (Option+C on macOS) you can bring your calendar to the foreground wherever you are, without searching through tens of open tabs.
+
+Improvements:
+- is particularly helpful if you are working with multiple Google accounts to save you from finding the right Google user in your browser while your call is already starting. Make sure you are logged in on your browser with all your Google accounts for this to work best.
+- cannot be completed within the planned time. With this release, Morgen shows all the tasks that are left behind in the sidebar so you won't forget them in your calendar.
+
+Fixes:
+- We fixed a layout issue in the Month view
+- We fixed a problem preventing some Outlook/Exchange events to be edited
+
+=== Morgen 2.5.8
+New Features:
+- Sometimes copy-pasting an event to another day comes in handy so we made it easier. Use Right click -> Copy followed by Right click -> Paste on an empty slot. You can paste the same events multiple times if you wish.
+
+Improvements:
+- UTC can be selected as a primary or secondary time zone
+- when you copy availability as text, the time zone abbreviation now respects Daylight saving
+- in the (unlikely 😉) case that something goes wrong with one of the tasks or video conferencing integrations, Morgen will let you know more clearly
+- the event merging feature is now enabled by default
+
diff --git a/PKGBUILD b/PKGBUILD
index cb889de1b116..20509b49b8d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Erik Sonnleitner <es at delta-xi dot net>
pkgname=morgen-bin
-pkgver=2.5.6
+pkgver=2.5.8
pkgrel=1
pkgdesc='Morgen is a modern, intuitive and smart calendar application and successor to MineTime'
arch=('x86_64')
@@ -11,7 +11,7 @@ changelog='ChangeLog'
depends=('libsecret' 'libxss' 'dbus' 'hicolor-icon-theme' 'desktop-file-utils')
provides=('morgen')
source=("https://download.todesktop.com/210203cqcj00tw1/morgen-${pkgver}.deb" morgen)
-b2sums=('b14a1e1d277b930b78f0bd63034098184ad7b71e6ccc5b7cca070841355e22b154ff9c1d341bbe1f8dfef9a9f7c33803f6a54196039a897983785ede3c87d047'
+b2sums=('14fc344aa04a69560155c13b8ab357ad5484683354a0843c42e6a1addc36a9eb9d60d60ebe37fc7910e50def26c85a294470c8ac12f91a9e65153fcdf076a17e'
'22bb3535edf2320bcb51a81e8865b0775b129ff1fad8007c6c9f385f4cdc241b0d166dd8e51a700ad7a1bf72efdcb2d5a13bb3b39ec8aa2db0a71fc22dfeeb57')
package() {
diff --git a/morgen b/morgen
index 98f2bb4509de..8334ed815764 100755
--- a/morgen
+++ b/morgen
@@ -1,3 +1,10 @@
#!/bin/env sh
-/opt/Morgen/morgen $@
+if [ "$XDG_SESSION_TYPE" = "wayland" ]; then
+ /opt/Morgen/morgen \
+ --enable-features=UseOzonePlatform,WaylandWindowDecorations \
+ --ozone-platform=wayland \
+ $@
+else
+ /opt/Morgen/morgen $@
+fi