summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2020-09-01 04:39:25 +0200
committerMichal Wojdyla2020-09-01 04:39:25 +0200
commit3383507f464bd957ef3012a7090d76e63b2408b0 (patch)
tree929bb4523afeaf3eef44b2fc7fd9865671a9ebd4
parent1855be6e418e1adb150185d321ccba254f1fbbf7 (diff)
downloadaur-morinus.tar.gz
update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--addicon.patch14
-rw-r--r--morinus.patch28
-rw-r--r--options.patch13
-rw-r--r--placedb.patch22
6 files changed, 18 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fd2986f8c94..78932041064b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,18 @@
pkgbase = morinus
pkgdesc = Astrology software in wxPython
- pkgver = 6.2
- pkgrel = 5
- url = https://sites.google.com/site/pymorinus/
+ pkgver = 8.1.0
+ pkgrel = 1
+ url = https://sites.google.com/site/pymorinus7/
install = morinus.install
arch = i686
arch = x86_64
license = GPL3
depends = wxpython
depends = python2-imaging
- source = https://sites.google.com/site/pymorinus/Home/Morinus.zip
- source = morinus.patch
- source = options.patch
- source = placedb.patch
- source = addicon.patch
+ source = https://sites.google.com/site/pymorinus7/home/Morinus810.zip
source = morinus-portrait.png
source = morinus.desktop
- md5sums = 48b46dcf208d3099ab7e7a12fae30d55
- md5sums = b49217822e54ca07f54c59381a857574
- md5sums = eb443f82da4cf176aa6bbc7c9a08fd1a
- md5sums = 0d9894dae21c06c167fc5a321e3ccdc0
- md5sums = b9d737b537a18c1e66b775dafd878fed
+ md5sums = dff0075f797060dd928ad375eabe35ec
md5sums = 4140ef94ff63a7b650e98fedc165945f
md5sums = d5325556826e5a3bf1cd65c71f645576
diff --git a/PKGBUILD b/PKGBUILD
index 36408a403c55..d8ec1cd3e00d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,34 @@
# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
pkgname=morinus
-pkgver=6.2
-pkgrel=5
+pkgver=8.1.0
+pkgrel=1
pkgdesc="Astrology software in wxPython"
-url="https://sites.google.com/site/pymorinus/"
+url="https://sites.google.com/site/pymorinus7/"
license=("GPL3")
install=${pkgname}.install
depends=(wxpython python2-imaging)
arch=(i686 x86_64)
-source=("https://sites.google.com/site/pymorinus/Home/Morinus.zip"
- 'morinus.patch'
- 'options.patch'
- 'placedb.patch'
- 'addicon.patch'
+source=("https://sites.google.com/site/pymorinus7/home/Morinus810.zip"
'morinus-portrait.png'
'morinus.desktop'
)
-md5sums=('48b46dcf208d3099ab7e7a12fae30d55'
- 'b49217822e54ca07f54c59381a857574'
- 'eb443f82da4cf176aa6bbc7c9a08fd1a'
- '0d9894dae21c06c167fc5a321e3ccdc0'
- 'b9d737b537a18c1e66b775dafd878fed'
+md5sums=('dff0075f797060dd928ad375eabe35ec'
'4140ef94ff63a7b650e98fedc165945f'
'd5325556826e5a3bf1cd65c71f645576')
-build() {
- cd $srcdir/Morinus/SWEP/src/
+package() {
+ cd $srcdir/Morinus810/SWEP/src/
python2 setup.py build
- cp build/lib.linux-$CARCH-2.7/sweastrology.so $srcdir/Morinus/
- cd $srcdir/Morinus/
+ cp build/lib.linux-$CARCH-2.7/sweastrology.so $srcdir/Morinus810/
+ cd $srcdir/Morinus810/
rm -r SWEP/src Images Opts
mkdir -p $pkgdir/usr/bin
- cp $srcdir/Morinus/morinus.py $pkgdir/usr/bin/morinus
- rm $srcdir/Morinus/morinus.py
+ cp $srcdir/Morinus810/morinus.py $pkgdir/usr/bin/morinus
+ rm $srcdir/Morinus810/morinus.py
mkdir -p $pkgdir/usr/lib/python2.7/site-packages/$pkgname
- patch $srcdir/Morinus/options.py $srcdir/../options.patch
- patch $srcdir/Morinus/placedb.py $srcdir/../placedb.patch
- patch $srcdir/Morinus/morin.py $srcdir/../addicon.patch
- sed -i 's/import Image/from PIL import Image/g' $srcdir/Morinus/*.py
- cp -pr $srcdir/Morinus/* $pkgdir/usr/lib/python2.7/site-packages/$pkgname/
- patch $pkgdir/usr/bin/morinus $srcdir/../morinus.patch
+ sed -i 's/import Image/from PIL import Image/g' $srcdir/Morinus810/*.py
+ cp -pr $srcdir/Morinus810/* $pkgdir/usr/lib/python2.7/site-packages/$pkgname/
touch $pkgdir/usr/lib/python2.7/site-packages/morinus/__init__.py
chmod 755 $pkgdir/usr/bin/morinus
mkdir -p "$pkgdir/usr/share/"{applications,icons}
diff --git a/addicon.patch b/addicon.patch
deleted file mode 100644
index ce95ea6bb5f1..000000000000
--- a/addicon.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -aur src/Morinus/morin.py src/Morinus.mod/morin.py
---- src/Morinus/morin.py 2012-07-06 09:02:26.000000000 +0000
-+++ src/Morinus.mod/morin.py 2013-01-06 18:37:44.724247880 +0000
-@@ -114,6 +114,10 @@
- self.title = title
- self.origtitle = title
- self.hortitle = title
-+
-+ _icon=wx.EmptyIcon()
-+ _icon.CopyFromBitmap(wx.ArtProvider.GetBitmap("morinus-portrait", wx.ART_MENU))
-+ self.SetIcon(_icon)
-
- self.options = opts
-
diff --git a/morinus.patch b/morinus.patch
deleted file mode 100644
index 27099889a66b..000000000000
--- a/morinus.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- morinus/src/Morinus/morinus.py 2010-12-27 10:55:22.000000000 +0100
-+++ /usr/bin/morinus 2013-01-04 14:46:12.995707104 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
-
-
- #Morinus, Astrology program
-@@ -21,15 +21,15 @@
- import os
- import sys
- import wx
--import options
--import mtexts
--import morin
-+import morinus.options as options
-+import morinus.mtexts as mtexts
-+import morinus.morin as morin
-
-
- class Morinus(wx.App):
- def OnInit(self):
- try:
-- progPath = os.path.dirname(sys.argv[0])
-+ progPath = "/usr/lib/python2.7/site-packages/morinus"
- os.chdir(progPath)
- except:
- pass
diff --git a/options.patch b/options.patch
deleted file mode 100644
index 7edbd2ee1bec..000000000000
--- a/options.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- options.py 2013-01-04 16:19:29.753595074 +0100
-+++ options.user.py 2013-01-04 16:19:12.103812584 +0100
-@@ -361,7 +361,9 @@
- self.optionsfilestxt = ('appearance1.opt', 'appearance2.opt', 'symbols.opt', 'dignities.opt', 'triplicities.opt', 'terms.opt', 'decans.opt',
- 'almutenchart.opt', 'almutentopicalandparts.opt', 'ayanamsa.opt', 'colors.opt', 'housesystem.opt', 'nodes.opt', 'orbs.opt',
- 'primarydirs.opt', 'primarykeys.opt', 'fortune.opt', 'syzygy.opt', 'fixedstars.opt', 'profections.opt', 'pdsinchart.opt', 'languages.opt', 'autosave.opt')
-- self.optsdirtxt = 'Opts'
-+ self.optsdirtxt = os.path.expanduser('~/.config/morinus')
-+ if not os.path.exists(self.optsdirtxt):
-+ os.makedirs(self.optsdirtxt)
-
- self.appearance1opt = os.path.join(self.optsdirtxt, self.optionsfilestxt[0])
- self.appearance2opt = os.path.join(self.optsdirtxt, self.optionsfilestxt[1])
diff --git a/placedb.patch b/placedb.patch
deleted file mode 100644
index 18c77ec3d643..000000000000
--- a/placedb.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- placedb.orig 2013-01-06 12:48:31.576937271 +0100
-+++ placedb2.py 2013-01-06 12:53:06.693886827 +0100
-@@ -1,6 +1,6 @@
- import os
- import pickle
--
-+import shutil
-
- class PlaceDB:
-
-@@ -23,7 +23,10 @@
- self.alt = alt
-
-
-- FILENAME = os.path.join('Res', 'placedb.dat')
-+ ORIG_FILENAME = os.path.join('Res', 'placedb.dat')
-+ FILENAME = os.path.join(os.path.expanduser('~/.config/morinus'), 'placedb.dat')
-+ if not os.path.exists(FILENAME):
-+ shutil.copyfile(os.path.join("/usr/lib/python2.7/site-packages/morinus", ORIG_FILENAME), FILENAME)
-
- def __init__(self):
- self.placedb = []