summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-06-09 11:43:05 +0200
committerMartin Doege2015-06-09 11:43:05 +0200
commit24de97a605a518b5f2bb0b2ecd2a184101a4eb82 (patch)
tree63c5262503e2934cb42c5a129adcf75f147200ef
downloadaur-24de97a605a518b5f2bb0b2ecd2a184101a4eb82.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD50
-rw-r--r--addicon.patch14
-rw-r--r--morinus-portrait-bw.pngbin0 -> 101475 bytes
-rw-r--r--morinus.patch28
-rwxr-xr-xmorinustrad.desktop21
-rw-r--r--morinustrad.install9
-rw-r--r--options.patch13
-rw-r--r--placedb.patch22
9 files changed, 185 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58bfa6da737f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = morinustrad
+ pkgdesc = Software for traditional astrology in wxPython
+ pkgver = 6.2
+ pkgrel = 6
+ url = https://sites.google.com/site/tradmorinus/morinus
+ install = morinustrad.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = wxpython
+ depends = python2-imaging
+ source = https://sites.google.com/site/tradmorinus/morinus/Morinus.zip
+ source = morinus.patch
+ source = options.patch
+ source = placedb.patch
+ source = addicon.patch
+ source = morinus-portrait-bw.png
+ source = morinustrad.desktop
+ md5sums = 0c910c8dea994a1967251bca1e704712
+ md5sums = 3ddfbe09219d79fd0c9bf5b1cf07a95f
+ md5sums = 572e4f8dfe4b91e37973915f63ee6098
+ md5sums = 9fc85211a841fa3a5a9c57891c28e429
+ md5sums = b8b578d9f4bc3b79b9715992ebb0e101
+ md5sums = d88ce0420453dda75aa4c6404b4c604f
+ md5sums = 08f8c2045e5318b2d824d29cd18b053f
+
+pkgname = morinustrad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1588abe6e60c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
+
+pkgname=morinustrad
+pkgver=6.2
+pkgrel=6
+pkgdesc="Software for traditional astrology in wxPython"
+url="https://sites.google.com/site/tradmorinus/morinus"
+license=("GPL3")
+install=${pkgname}.install
+depends=(wxpython python2-imaging)
+arch=(i686 x86_64)
+source=("https://sites.google.com/site/tradmorinus/morinus/Morinus.zip"
+ 'morinus.patch'
+ 'options.patch'
+ 'placedb.patch'
+ 'addicon.patch'
+ 'morinus-portrait-bw.png'
+ 'morinustrad.desktop'
+ )
+md5sums=('0c910c8dea994a1967251bca1e704712'
+ '3ddfbe09219d79fd0c9bf5b1cf07a95f'
+ '572e4f8dfe4b91e37973915f63ee6098'
+ '9fc85211a841fa3a5a9c57891c28e429'
+ 'b8b578d9f4bc3b79b9715992ebb0e101'
+ 'd88ce0420453dda75aa4c6404b4c604f'
+ '08f8c2045e5318b2d824d29cd18b053f')
+
+build() {
+ cd $srcdir/Morinus/SWEP/src/
+ python2 setup.py build
+ cp build/lib.linux-$CARCH-2.7/sweastrology.so $srcdir/Morinus/
+ cd $srcdir/Morinus/
+ rm -r SWEP/src Images Opts
+ mkdir -p $pkgdir/usr/bin
+ cp $srcdir/Morinus/morinus.py $pkgdir/usr/bin/$pkgname
+ rm $srcdir/Morinus/morinus.py
+ mkdir -p $pkgdir/usr/lib/python2.7/site-packages/$pkgname
+ patch $srcdir/Morinus/options.py $srcdir/../options.patch
+ patch $srcdir/Morinus/placedb.py $srcdir/../placedb.patch
+ patch $srcdir/Morinus/morin.py $srcdir/../addicon.patch
+ sed -i 's/import Image/from PIL import Image/g' $srcdir/Morinus/*.py
+ chmod 755 SWEP SWEP/Ephem Hors Res
+ cp -pr $srcdir/Morinus/* $pkgdir/usr/lib/python2.7/site-packages/$pkgname/
+ patch $pkgdir/usr/bin/$pkgname $srcdir/../morinus.patch
+ touch $pkgdir/usr/lib/python2.7/site-packages/$pkgname/__init__.py
+ chmod 755 $pkgdir/usr/bin/$pkgname
+ mkdir -p "$pkgdir/usr/share/"{applications,icons}
+ cp "$srcdir/morinustrad.desktop" "$pkgdir/usr/share/applications"
+ cp "$srcdir/morinus-portrait-bw.png" "$pkgdir/usr/share/icons"
+ }
diff --git a/addicon.patch b/addicon.patch
new file mode 100644
index 000000000000..2a66f8df61ea
--- /dev/null
+++ b/addicon.patch
@@ -0,0 +1,14 @@
+diff -aur src/Morinus/morin.py src/Morinus.mod/morin.py
+--- src/Morinus/morin.py 2012-07-06 09:02:26.000000000 +0000
++++ src/Morinus.mod/morin.py 2013-01-06 18:37:44.724247880 +0000
+@@ -114,6 +114,10 @@
+ self.title = title
+ self.origtitle = title
+ self.hortitle = title
++
++ _icon=wx.EmptyIcon()
++ _icon.CopyFromBitmap(wx.ArtProvider.GetBitmap("morinus-portrait-bw", wx.ART_MENU))
++ self.SetIcon(_icon)
+
+ self.options = opts
+
diff --git a/morinus-portrait-bw.png b/morinus-portrait-bw.png
new file mode 100644
index 000000000000..66f41c6a022a
--- /dev/null
+++ b/morinus-portrait-bw.png
Binary files differ
diff --git a/morinus.patch b/morinus.patch
new file mode 100644
index 000000000000..1c067bde1fbc
--- /dev/null
+++ b/morinus.patch
@@ -0,0 +1,28 @@
+--- morinus.py 2012-03-29 15:19:20.000000000 +0200
++++ morinus.2.py 2013-01-05 00:34:05.633000298 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+
+ #Morinus, Astrology program
+@@ -21,15 +21,15 @@
+ import os
+ import sys
+ import wx
+-import options
+-import mtexts
+-import morin
++import morinustrad.options as options
++import morinustrad.mtexts as mtexts
++import morinustrad.morin as morin
+
+
+ class Morinus(wx.App):
+ def OnInit(self):
+ try:
+- progPath = os.path.dirname(sys.argv[0])
++ progPath = "/usr/lib/python2.7/site-packages/morinustrad"
+ os.chdir(progPath)
+ except:
+ pass
diff --git a/morinustrad.desktop b/morinustrad.desktop
new file mode 100755
index 000000000000..1715ab10d072
--- /dev/null
+++ b/morinustrad.desktop
@@ -0,0 +1,21 @@
+[Desktop Entry]
+Comment[de]=
+Comment=
+Encoding=UTF-8
+Exec=morinustrad
+GenericName[de]=
+GenericName=
+Icon=morinus-portrait-bw
+MimeType=
+Name[de]=Morinus (klassisch)
+Name=Morinus (traditional)
+Path=
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+Version=1.0
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/morinustrad.install b/morinustrad.install
new file mode 100644
index 000000000000..9999f7ecda73
--- /dev/null
+++ b/morinustrad.install
@@ -0,0 +1,9 @@
+post_install() {
+cat << EOF
+The built-in ephemeris should be accurate enough for
+the years 1900 to 2100 or so. If you need accurate
+calculations outside this range, you should download
+Ephem[1234].zip from upstream and unzip them to
+"/usr/lib/python2.7/site-packages/morinustrad/SWEP/Ephem/".
+EOF
+}
diff --git a/options.patch b/options.patch
new file mode 100644
index 000000000000..8467d5beb804
--- /dev/null
+++ b/options.patch
@@ -0,0 +1,13 @@
+--- options.py 2012-12-09 12:19:20.000000000 +0100
++++ options.2.py 2013-01-05 00:25:15.082279322 +0100
+@@ -335,7 +335,9 @@
+ self.optionsfilestxt = ('appearance1.opt', 'appearance2.opt', 'dignities.opt', 'triplicities.opt', 'terms.opt', 'decans.opt',
+ 'almutenchart.opt', 'almutentopicalandlots.opt', 'ayanamsa.opt', 'colors.opt', 'housesystem.opt', 'nodes.opt', 'orbs.opt',
+ 'primarydirs.opt', 'primarykeys.opt', 'syzygy.opt', 'fixedstars.opt', 'profections.opt', 'firdaria.opt', 'deflocation.opt', 'pdsinchart.opt', 'menusel.opt', 'languages.opt', 'autosave.opt')
+- self.optsdirtxt = 'Opts'
++ self.optsdirtxt = os.path.expanduser('~/.config/morinus-traditional')
++ if not os.path.exists(self.optsdirtxt):
++ os.makedirs(self.optsdirtxt)
+
+ self.appearance1opt = os.path.join(self.optsdirtxt, self.optionsfilestxt[0])
+ self.appearance2opt = os.path.join(self.optsdirtxt, self.optionsfilestxt[1])
diff --git a/placedb.patch b/placedb.patch
new file mode 100644
index 000000000000..a18379684c92
--- /dev/null
+++ b/placedb.patch
@@ -0,0 +1,22 @@
+--- placedb.orig 2013-01-06 12:57:25.141031702 +0100
++++ placedb2.py 2013-01-06 12:59:59.199334105 +0100
+@@ -1,6 +1,6 @@
+ import os
+ import pickle
+-
++import shutil
+
+ class PlaceDB:
+
+@@ -23,7 +23,10 @@
+ self.alt = alt
+
+
+- FILENAME = os.path.join('Res', 'placedb.dat')
++ ORIG_FILENAME = os.path.join('Res', 'placedb.dat')
++ FILENAME = os.path.join(os.path.expanduser('~/.config/morinus-traditional'), 'placedb.dat')
++ if not os.path.exists(FILENAME):
++ shutil.copyfile(os.path.join("/usr/lib/python2.7/site-packages/morinustrad", ORIG_FILENAME), FILENAME)
+
+ def __init__(self):
+ self.placedb = []