summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2016-12-21 16:30:46 +0300
committerLev Levitsky2016-12-21 16:30:46 +0300
commit056bdbcc7a19e600aef73893b74db6e80fd75ab8 (patch)
tree13d8f6d52443fa81241d5dfe7c347f251a4d16a1
parent5d1b3aa4b3ac431241d45b3183aefd642d299489 (diff)
downloadaur-056bdbcc7a19e600aef73893b74db6e80fd75ab8.tar.gz
Update to rev272, change URL to github
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--morpheus2
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fd4857adefe..08b66417c468 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
# Generated by mksrcinfo v8
-# Sat Mar 5 21:47:27 UTC 2016
+# Wed Dec 21 13:28:52 UTC 2016
pkgbase = morpheus
pkgdesc = A mass spectrometry–based proteomics database search algorithm
- pkgver = 200
+ pkgver = 272
pkgrel = 1
- url = http://sourceforge.net/projects/morpheus-ms/
+ url = http://cwenger.github.io/Morpheus/
install = morpheus.install
arch = any
license = MIT
depends = mono
- source = http://sourceforge.net/projects/morpheus-ms/files/revision%20200/Morpheus%20%28mzML%20Linux%29.tar.gz/download
+ source = https://github.com/cwenger/Morpheus/releases/download/r272/Morpheus_mzML_Mono.tar.gz
source = morpheus_cl
source = morpheus
- md5sums = cf12f9244d70d5aee4565dca470cbe1e
+ md5sums = fdcb22eede1757083b3afe87f7c9f4a1
md5sums = 71ab85a987af41daf56c3b806c53c49b
- md5sums = 274d39f13400d681af86fa8a51c4e758
+ md5sums = 13af6d888daf9c4a30ec7253312a67b3
pkgname = morpheus
diff --git a/PKGBUILD b/PKGBUILD
index 742e689341e8..f6454cd81b9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Lev Levitsky <levlev@mail.ru>
pkgname=morpheus
-pkgver=200
+pkgver=272
pkgrel=1
pkgdesc="A mass spectrometry–based proteomics database search algorithm"
arch=('any')
-url="http://sourceforge.net/projects/morpheus-ms/"
+url="http://cwenger.github.io/Morpheus/"
license=('MIT')
depends=('mono')
-source=("http://sourceforge.net/projects/morpheus-ms/files/revision%20${pkgver}/Morpheus%20%28mzML%20Linux%29.tar.gz/download"
+source=("https://github.com/cwenger/Morpheus/releases/download/r${pkgver}/Morpheus_mzML_Mono.tar.gz"
"morpheus_cl"
"morpheus")
install=${pkgname}.install
-md5sums=('cf12f9244d70d5aee4565dca470cbe1e'
+md5sums=('fdcb22eede1757083b3afe87f7c9f4a1'
'71ab85a987af41daf56c3b806c53c49b'
- '274d39f13400d681af86fa8a51c4e758')
+ '13af6d888daf9c4a30ec7253312a67b3')
package() {
opt="$pkgdir/opt/$pkgname"
install -d "$opt"
install -D "$srcdir/morpheus_cl" "$pkgdir/usr/bin/morpheus_cl"
install -D "$srcdir/morpheus" "$pkgdir/usr/bin/morpheus"
- cp -rT "$srcdir/Morpheus (mzML Linux)" "$opt"
+ cp -rT "$srcdir/Morpheus (mzML Mono)" "$opt"
rm "$opt"/MIT_License.*.txt
install -d "$pkgdir/usr/share/licenses/$pkgname"
- install -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/Morpheus (mzML Linux)"/MIT_License.{CommandLine,Morpheus}.txt
+ install -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/Morpheus (mzML Mono)"/MIT_License.{CommandLine,Morpheus}.txt
}
diff --git a/morpheus b/morpheus
index b6a24bc83248..81f4e977c723 100644
--- a/morpheus
+++ b/morpheus
@@ -1,2 +1,2 @@
#!/usr/bin/sh
-mono '/opt/morpheus/Morpheus %28mzML Mono%29.exe' "$@"
+mono '/opt/morpheus/Morpheus (mzML Mono).exe' "$@"