summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerhard Burger2019-11-15 16:06:17 +0100
committerGerhard Burger2019-11-15 16:43:13 +0100
commit11b8146dbe09d85afbab3febef86e2164a9cab5b (patch)
tree6fc305d4a601dc6ba231913dc073e3453e7f9e20
parentcc73acfde953d5aa5644a4eb786683702265ca46 (diff)
downloadaur-11b8146dbe09d85afbab3febef86e2164a9cab5b.tar.gz
Update to morpheus 2.1.0
-rw-r--r--.SRCINFO19
-rw-r--r--CMakeLists.txt4
-rw-r--r--PKGBUILD50
-rw-r--r--package.patch11
4 files changed, 43 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8330ad07068..50f6ba9db116 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,29 @@
pkgbase = morpheus-modeling
- pkgdesc = It's a modeling and simulation environment for the study of multiscale and multicellular systems.
- pkgver = 2.0
- pkgrel = 2
- url = https://imc.zih.tu-dresden.de/wiki/morpheus
- arch = i686
+ pkgdesc = A modeling and simulation environment for the study of multiscale and multicellular systems.
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://morpheus.gitlab.io
arch = x86_64
license = BSD
makedepends = gcc>=4.6
- makedepends = cmake>=1.8
+ makedepends = cmake>=2.8
makedepends = libxslt
makedepends = doxygen
makedepends = git
- makedepends = qt5-svg
+ makedepends = boost
+ makedepends = libxml2
depends = zlib
depends = libtiff
depends = graphviz
depends = qt4
depends = sqlite
depends = qtwebkit
- optdepends = libxml2:
optdepends = gnuplot: Used for generating graphics
optdepends = ffmpeg: Used for generating movies
- source = morpheus-modeling-2.0::git+https://gitlab.com/morpheus.lab/morpheus.git
+ source = morpheus-modeling-2.1.0::git+https://gitlab.com/morpheus.lab/morpheus.git#tag=v2.1.0
+ source = package.patch
md5sums = SKIP
+ md5sums = d628593b5861820476f1bfa7acb677e3
pkgname = morpheus-modeling
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index 4dd8bfa728d4..000000000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,4 +0,0 @@
-add_subdirectory(muParser)
-add_subdirectory(xmlParser)
-add_subdirectory(gnuplot_i)
-add_subdirectory(qtsingleapp)
diff --git a/PKGBUILD b/PKGBUILD
index a75f70e8e237..17342f82ec16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,38 @@
# Maintainer: Augusto Borges <aborges@iflysib.unlp.edu.ar>
# Contributor: Emanuel Cura Costa <ecuracosta@gmail.com>
+# Contributor: Gerhard Burger <burger.ga@gmail.com>
+
pkgname=morpheus-modeling
-pkgver=2.0
-pkgrel=2
-pkgdesc="It's a modeling and simulation environment for the study of multiscale and multicellular systems."
-arch=('i686' 'x86_64')
-url="https://imc.zih.tu-dresden.de/wiki/morpheus"
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="A modeling and simulation environment for the study of multiscale and multicellular systems."
+arch=('x86_64')
+url="https://morpheus.gitlab.io"
license=('BSD')
depends=('zlib' 'libtiff' 'graphviz' 'qt4' 'sqlite' 'qtwebkit')
-makedepends=('gcc>=4.6' 'cmake>=1.8' 'libxslt' 'doxygen' 'git' 'qt5-svg')
-optdepends=("libxml2: "
- "gnuplot: Used for generating graphics"
+makedepends=('gcc>=4.6' 'cmake>=2.8' 'libxslt' 'doxygen' 'git' 'boost' 'libxml2')
+optdepends=("gnuplot: Used for generating graphics"
"ffmpeg: Used for generating movies" )
-source=("$pkgname-$pkgver::git+https://gitlab.com/morpheus.lab/morpheus.git")
+source=("$pkgname-$pkgver::git+https://gitlab.com/morpheus.lab/morpheus.git#tag=v$pkgver" "package.patch")
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP'
+ 'd628593b5861820476f1bfa7acb677e3')
build() {
- if ! test -e "$pkgname-$pkgver"; then
- mkdir "$pkgname-$pkgver";
- fi
+ mkdir -p "$pkgname-$pkgver/build"
+ cd "$pkgname-$pkgver/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+}
+
+prepare() {
cd "$pkgname-$pkgver"
- if ! test -e "build"; then
- mkdir "build";
- fi
- cp "../../CMakeLists.txt" "3rdparty/CMakeLists.txt"
- sed -e '3s/# //' CMakeLists.txt > temporal.txt
- mv temporal.txt CMakeLists.txt
- cd "morpheus/core"
- sed -e '3s/# //' CMakeLists.txt > temporal.txt
- mv temporal.txt CMakeLists.txt
+ patch --forward --strip=1 --input="${srcdir}/package.patch"
- cd "../.."
- cd "build"
- cmake ..
}
package() {
cd "$pkgname-$pkgver"
- cd "build"
- pwd
- make && make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd build
+ make DESTDIR="$pkgdir" install
}
diff --git a/package.patch b/package.patch
new file mode 100644
index 000000000000..e0bab4d8689b
--- /dev/null
+++ b/package.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text morpheus-modeling-2.1.0/3rdparty/libSBML/CMakeLists.txt morpheus-modeling-2.1.0.new/3rdparty/libSBML/CMakeLists.txt
+--- morpheus-modeling-2.1.0/3rdparty/libSBML/CMakeLists.txt 2019-10-23 18:50:39.151914168 +0200
++++ morpheus-modeling-2.1.0.new/3rdparty/libSBML/CMakeLists.txt 2019-10-23 18:54:12.568575697 +0200
+@@ -37,6 +37,7 @@
+ CMAKE_ARGS ${sbml_cmake_args}
+ # Import depenency definitions into project cache
+ CMAKE_CACHE_ARGS ${sbml_cache_args}
++ INSTALL_COMMAND make DESTDIR= install
+ )
+
+ SET(LIBSBML_STATIC_DEPENDENCY_LIBRARIES ${LIBXML2_LIBRARIES} ${ZLIB_LIBRARY}) \ No newline at end of file