summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerhard Burger2019-11-26 10:05:18 +0100
committerGerhard Burger2019-11-26 10:05:18 +0100
commite7a3a9c1a5e0bdafb088cf6cfb1871f010f4e7d9 (patch)
tree6c8374e538a13689f1a01f6007ce78b74ac19641
parent11b8146dbe09d85afbab3febef86e2164a9cab5b (diff)
downloadaur-e7a3a9c1a5e0bdafb088cf6cfb1871f010f4e7d9.tar.gz
Update morpheus to v2.1.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
-rw-r--r--package.patch11
3 files changed, 7 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50f6ba9db116..fc40a5e9a3ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = morpheus-modeling
pkgdesc = A modeling and simulation environment for the study of multiscale and multicellular systems.
- pkgver = 2.1.0
+ pkgver = 2.1.1
pkgrel = 1
url = https://morpheus.gitlab.io
arch = x86_64
@@ -18,12 +18,11 @@ pkgbase = morpheus-modeling
depends = qt4
depends = sqlite
depends = qtwebkit
+ depends = libsbml
optdepends = gnuplot: Used for generating graphics
optdepends = ffmpeg: Used for generating movies
- source = morpheus-modeling-2.1.0::git+https://gitlab.com/morpheus.lab/morpheus.git#tag=v2.1.0
- source = package.patch
+ source = morpheus-modeling-2.1.1::git+https://gitlab.com/morpheus.lab/morpheus.git#tag=v2.1.1
md5sums = SKIP
- md5sums = d628593b5861820476f1bfa7acb677e3
pkgname = morpheus-modeling
diff --git a/PKGBUILD b/PKGBUILD
index 17342f82ec16..eb178b4437ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,19 @@
# Contributor: Gerhard Burger <burger.ga@gmail.com>
pkgname=morpheus-modeling
-pkgver=2.1.0
+pkgver=2.1.1
pkgrel=1
pkgdesc="A modeling and simulation environment for the study of multiscale and multicellular systems."
arch=('x86_64')
url="https://morpheus.gitlab.io"
license=('BSD')
-depends=('zlib' 'libtiff' 'graphviz' 'qt4' 'sqlite' 'qtwebkit')
+depends=('zlib' 'libtiff' 'graphviz' 'qt4' 'sqlite' 'qtwebkit' 'libsbml')
makedepends=('gcc>=4.6' 'cmake>=2.8' 'libxslt' 'doxygen' 'git' 'boost' 'libxml2')
optdepends=("gnuplot: Used for generating graphics"
"ffmpeg: Used for generating movies" )
-source=("$pkgname-$pkgver::git+https://gitlab.com/morpheus.lab/morpheus.git#tag=v$pkgver" "package.patch")
+source=("$pkgname-$pkgver::git+https://gitlab.com/morpheus.lab/morpheus.git#tag=v$pkgver")
noextract=()
-md5sums=('SKIP'
- 'd628593b5861820476f1bfa7acb677e3')
+md5sums=('SKIP')
build() {
mkdir -p "$pkgname-$pkgver/build"
@@ -24,12 +23,6 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
}
-prepare() {
- cd "$pkgname-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/package.patch"
-
-}
-
package() {
cd "$pkgname-$pkgver"
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
diff --git a/package.patch b/package.patch
deleted file mode 100644
index e0bab4d8689b..000000000000
--- a/package.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --unified --recursive --text morpheus-modeling-2.1.0/3rdparty/libSBML/CMakeLists.txt morpheus-modeling-2.1.0.new/3rdparty/libSBML/CMakeLists.txt
---- morpheus-modeling-2.1.0/3rdparty/libSBML/CMakeLists.txt 2019-10-23 18:50:39.151914168 +0200
-+++ morpheus-modeling-2.1.0.new/3rdparty/libSBML/CMakeLists.txt 2019-10-23 18:54:12.568575697 +0200
-@@ -37,6 +37,7 @@
- CMAKE_ARGS ${sbml_cmake_args}
- # Import depenency definitions into project cache
- CMAKE_CACHE_ARGS ${sbml_cache_args}
-+ INSTALL_COMMAND make DESTDIR= install
- )
-
- SET(LIBSBML_STATIC_DEPENDENCY_LIBRARIES ${LIBXML2_LIBRARIES} ${ZLIB_LIBRARY}) \ No newline at end of file