summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraugusfis2016-09-06 16:31:04 -0300
committeraugusfis2016-09-06 16:31:04 -0300
commitf6e2fc8a8a53306b89ba287a8569cf4af1295b55 (patch)
tree32e4ceac98dea58414aba0040a3984e88b66f8b0
parent9c5686456b01e2f621bbb9f4f8bbe764cabb1be9 (diff)
downloadaur-f6e2fc8a8a53306b89ba287a8569cf4af1295b55.tar.gz
Fixing qtsingleapp 3rdparty not building
-rw-r--r--CMakeLists.txt4
-rw-r--r--PKGBUILD2
2 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000000..4dd8bfa728d4
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,4 @@
+add_subdirectory(muParser)
+add_subdirectory(xmlParser)
+add_subdirectory(gnuplot_i)
+add_subdirectory(qtsingleapp)
diff --git a/PKGBUILD b/PKGBUILD
index 0a6e7737f200..db85c03633d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,11 +23,13 @@ build() {
if ! test -e "build"; then
mkdir "build";
fi
+ cp "../../CMakeLists.txt" "3rdparty/CMakeLists.txt"
sed -e '3s/# //' CMakeLists.txt > temporal.txt
mv temporal.txt CMakeLists.txt
cd "morpheus/core"
sed -e '3s/# //' CMakeLists.txt > temporal.txt
mv temporal.txt CMakeLists.txt
+
cd "../.."
cd "build"
cmake ..