summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-20 15:43:26 -0800
committerclintval2018-01-20 15:43:26 -0800
commita9450a1db79514ef691d68308fb5a81dfc6bdfa1 (patch)
tree3e9f39d9e6deb47ab76f6e89309e91c1fcdd9639
downloadaur-a9450a1db79514ef691d68308fb5a81dfc6bdfa1.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2aa823594d38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mosdepth
+ pkgdesc = Fast BAM/CRAM depth calculation for WGS, exome, or targeted sequencing
+ pkgver = 0.2.1
+ pkgrel = 2
+ url = https://github.com/brentp/mosdepth
+ arch = any
+ license = MIT
+ provides = mosdepth
+ conflicts = mosdepth
+ source = https://github.com/brentp/mosdepth/releases/download/v0.2.1/mosdepth
+ source = mosdepth-0.2.1.tar.gz::https://github.com/brentp/mosdepth/archive/v0.2.1.tar.gz
+ sha256sums = 6e3dbd2ac93ee9e770f922de4b1641882558e1e70cf2168e509c6bc07d9486e7
+ sha256sums = 7aadd0f322a50723a5b396cfe8eb640728be03918a8d41b5a8ab1ba4943c26c6
+
+pkgname = mosdepth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3125cbbf1fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=mosdepth
+pkgver=0.2.1
+pkgrel=2
+pkgdesc="Fast BAM/CRAM depth calculation for WGS, exome, or targeted sequencing"
+arch=('any')
+url="https://github.com/brentp/mosdepth"
+license=('MIT')
+provides=('mosdepth')
+conflicts=('mosdepth')
+source=(
+ https://github.com/brentp/"${pkgname}"/releases/download/v"${pkgver}"/"${pkgname}"
+ "${pkgname}"-"${pkgver}".tar.gz::https://github.com/brentp/"${pkgname}"/archive/v"${pkgver}".tar.gz)
+sha256sums=(
+ '6e3dbd2ac93ee9e770f922de4b1641882558e1e70cf2168e509c6bc07d9486e7'
+ '7aadd0f322a50723a5b396cfe8eb640728be03918a8d41b5a8ab1ba4943c26c6')
+
+package() {
+ install -Dm755 "${pkgname}" "${pkgdir}"/usr/bin/"${pkgname}"
+
+ # Complete tar archive downloaded just for current license.
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}