summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhuo FENG2021-09-16 17:24:10 +1000
committerZhuo FENG2021-09-16 17:24:10 +1000
commit5802740d6cfe851839721962a3c4034582b21053 (patch)
tree60171e73622ff054c52b36772c3dae5cca324962
downloadaur-5802740d6cfe851839721962a3c4034582b21053.tar.gz
first commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a75778759117
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mosdns-cn-bin
+ pkgdesc = A DNS forwarder
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/IrineSistiana/mosdns-cn
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ optdepends = v2ray-domain-list-community: geosite.dat
+ optdepends = v2ray-geoip: geoip.dat
+ optdepends = v2ray-rules-dat-git: geosite.dat & geoip.dat
+ provides = mosdns-cn
+ conflicts = mosdns-cn
+ source_x86_64 = mosdns-cn-bin-1.0.1.zip::https://github.com/IrineSistiana/mosdns-cn/releases/download/v1.0.1/mosdns-cn-linux-amd64.zip
+ sha256sums_x86_64 = a6b1d46b64dd722c6b2e44b49fbca05ed5afcd24e38d90a7214f301c1b729a80
+ source_armv7h = mosdns-cn-bin-1.0.1.zip::https://github.com/IrineSistiana/mosdns-cn/releases/download/v1.0.1/mosdns-cn-linux-arm-7.zip
+ sha256sums_armv7h = bc3021d3e443fd751ac89f49504150c811bd1df21a88093384c528bcd7425c32
+ source_aarch64 = mosdns-cn-bin-1.0.1.zip::https://github.com/IrineSistiana/mosdns-cn/releases/download/v1.0.1/mosdns-cn-linux-arm-7.zip
+ sha256sums_aarch64 = 3a627c2792550325fc48c993b2fa529a8568d5c3bd1593fd7b4fd6704b9f6f0a
+
+pkgname = mosdns-cn-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4ea29aaf3e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+# Maintainer: Zhuo FENG <fenprace.i@gmail.com>
+
+pkgname=mosdns-cn-bin
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A DNS forwarder"
+license=("GPL3")
+arch=("x86_64" "armv7h" "aarch64")
+url="https://github.com/IrineSistiana/mosdns-cn"
+optdepends=('v2ray-domain-list-community: geosite.dat'
+ 'v2ray-geoip: geoip.dat'
+ 'v2ray-rules-dat-git: geosite.dat & geoip.dat')
+provides=("mosdns-cn")
+conflicts=("mosdns-cn")
+
+source_x86_64=("$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns-cn/releases/download/v$pkgver/mosdns-cn-linux-amd64.zip")
+source_armv7h=("$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns-cn/releases/download/v$pkgver/mosdns-cn-linux-arm-7.zip")
+source_aarch64=("$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns-cn/releases/download/v$pkgver/mosdns-cn-linux-arm-7.zip")
+
+package() {
+ install -Dm755 mosdns-cn "$pkgdir/usr/bin/mosdns-cn"
+}
+
+sha256sums_x86_64=('a6b1d46b64dd722c6b2e44b49fbca05ed5afcd24e38d90a7214f301c1b729a80')
+sha256sums_armv7h=('bc3021d3e443fd751ac89f49504150c811bd1df21a88093384c528bcd7425c32')
+sha256sums_aarch64=('3a627c2792550325fc48c993b2fa529a8568d5c3bd1593fd7b4fd6704b9f6f0a')