summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorava1ar2015-06-16 23:19:41 -0400
committerava1ar2015-06-16 23:19:41 -0400
commitb21186ece8e81cde5654236d6bd5d688a7b974b3 (patch)
tree9c7222b7344ba8d073819ae437a239b72e289f43
downloadaur-b21186ece8e81cde5654236d6bd5d688a7b974b3.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD36
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3e5d3ad1e4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mosh-git
+ pkgdesc = Mobile shell, surviving disconnects with local echo and line editing, development version
+ pkgver = 20150611
+ pkgrel = 1
+ url = http://mosh.mit.edu/
+ arch = i686
+ arch = x86_64
+ arch = arm
+ license = GPL3
+ makedepends = git
+ depends = protobuf
+ depends = ncurses
+ depends = zlib
+ depends = openssh
+ depends = perl
+ depends = perl-io-tty
+ depends = libutempter
+ optdepends = perl-io-socket-ip: for IPv6 support
+ optdepends = vte-mosh-fix: to work properly in vte
+ optdepends = vte3-mosh-fix: to work properly in vte3
+ conflicts = mosh
+ source = git+https://github.com/keithw/mosh.git
+ md5sums = SKIP
+
+pkgname = mosh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f6be4d204df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Christian Neukirchen <chneukirchen@gmail.com>
+# Maintainer: ava1ar <mail(at)ava1ar(dot)me>
+
+pkgname=mosh-git
+pkgver=20150611
+pkgrel=1
+pkgdesc="Mobile shell, surviving disconnects with local echo and line editing, development version"
+arch=('i686' 'x86_64' 'arm')
+url="http://mosh.mit.edu/"
+license=('GPL3')
+depends=('protobuf' 'ncurses' 'zlib' 'openssh' 'perl' 'perl-io-tty' 'libutempter')
+makedepends=('git')
+optdepends=('perl-io-socket-ip: for IPv6 support'
+ 'vte-mosh-fix: to work properly in vte'
+ 'vte3-mosh-fix: to work properly in vte3')
+conflicts=('mosh')
+source=('git+https://github.com/keithw/mosh.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/mosh"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+build() {
+ cd "${srcdir}/mosh"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/mosh"
+ make DESTDIR="${pkgdir}" install
+ rmdir "${pkgdir}/usr/etc"
+}