summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2018-06-02 15:38:11 -0400
committerAndrew O'Neill2018-06-02 15:38:11 -0400
commit194e871338dfde1e384984d8730a630d6ece5a1e (patch)
tree9f5b9c678a1f23d9de626a2446887667e99277eb
parent97bf5ac31d744c0c1b276af8bc0ab056ae96e7fe (diff)
downloadaur-194e871338dfde1e384984d8730a630d6ece5a1e.tar.gz
Version bump
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f943c97de9b5..94e48f30833f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = mothur
- pkgdesc = A bioinformatics program for analyzing microbial communities
- pkgver = 1.40.3
+ pkgdesc = A bioinformatics program for analyzing microbial communities.
+ pkgver = 1.40.4
pkgrel = 1
url = https://www.mothur.org/
- arch = i686
arch = x86_64
license = GPL3
makedepends = boost
depends = boost-libs
- source = https://github.com/mothur/mothur/archive/v1.40.3.tar.gz
- sha256sums = 7237e763b046ade1034bf39e3e76ee0256013b1d50103330f0177c3b0cb876f7
+ source = https://github.com/mothur/mothur/archive/v1.40.4.tar.gz
+ sha256sums = cb3321b1c7e36e79a318a52671d20d5ea5891d1de1125371b8f325cdf6d6d10c
pkgname = mothur
diff --git a/PKGBUILD b/PKGBUILD
index 0da6133fb864..9539bdba5c03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
-pkgver=1.40.3
+pkgver=1.40.4
pkgrel=1
-pkgdesc="A bioinformatics program for analyzing microbial communities"
-arch=('i686' 'x86_64')
-url="https://www.mothur.org/"
+pkgdesc='A bioinformatics program for analyzing microbial communities.'
+arch=('x86_64')
+url='https://www.mothur.org/'
license=('GPL3')
depends=('boost-libs')
makedepends=('boost')
-source=(https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz)
-sha256sums=('7237e763b046ade1034bf39e3e76ee0256013b1d50103330f0177c3b0cb876f7')
+source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('cb3321b1c7e36e79a318a52671d20d5ea5891d1de1125371b8f325cdf6d6d10c')
prepare() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
sed -e 's|BOOST_LIBRARY_DIR="\\"Enter_your_boost_library_path_here\\""|BOOST_LIBRARY_DIR = /usr/lib|' \
-e 's|BOOST_INCLUDE_DIR="\\"Enter_your_boost_include_path_here\\""|BOOST_INCLUDE_DIR = /usr/include|' \
@@ -22,14 +22,14 @@ prepare() {
}
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
- install -Dm755 mothur $pkgdir/usr/bin/mothur
- install -Dm755 uchime $pkgdir/usr/bin/uchime
+ install -Dm755 mothur "${pkgdir}/usr/bin/mothur"
+ install -Dm755 uchime "${pkgdir}/usr/bin/uchime"
}