summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2016-09-25 13:23:04 +0200
committerSebastiaan Lokhorst2016-09-25 13:23:04 +0200
commit22444a966323392fbcd4f3f23bbdf73c7a026c68 (patch)
treeae99c0c88883a4437400848535b57c291f7cce94
parentca09092d1f90fee1b14de79dc1fb7fc5cc069050 (diff)
downloadaur-22444a966323392fbcd4f3f23bbdf73c7a026c68.tar.gz
Add provides, conflicts.
Put configuration files in the right place.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9867a9db76e..aaee4e633f9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 25 11:14:09 UTC 2016
+# Sun Sep 25 11:23:02 UTC 2016
pkgbase = motion-git
pkgdesc = A software motion detector which grabs images from video4linux devices and/or from webcams
pkgver = release.3.4.1.r98.g7e16a9e
- pkgrel = 1
+ pkgrel = 2
url = https://motion-project.github.io/
arch = i686
arch = x86_64
@@ -11,6 +11,8 @@ pkgbase = motion-git
depends = libjpeg
depends = v4l-utils
depends = ffmpeg
+ provides = motion
+ conflicts = motion
backup = etc/motion/motion.conf
source = motion::git+https://github.com/Motion-Project/motion.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0dde4bafce36..fe7afdd94ec6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,14 @@
pkgname=motion-git
_pkgname=motion
pkgver=release.3.4.1.r98.g7e16a9e
-pkgrel=1
+pkgrel=2
pkgdesc="A software motion detector which grabs images from video4linux devices and/or from webcams"
arch=('i686' 'x86_64')
license=('GPL')
url="https://motion-project.github.io/"
depends=('libjpeg' 'v4l-utils' 'ffmpeg')
+provides=('motion')
+conflicts=('motion')
backup=('etc/motion/motion.conf')
source=($_pkgname::git+https://github.com/Motion-Project/${_pkgname}.git)
md5sums=('SKIP')
@@ -29,5 +31,10 @@ build() {
package(){
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}"/etc/motion/motion{-dist,}.conf
+ mv "${pkgdir}"/etc/motion/camera1{-dist,}.conf
+ mv "${pkgdir}"/etc/motion/camera2{-dist,}.conf
+ mv "${pkgdir}"/etc/motion/camera3{-dist,}.conf
+ mv "${pkgdir}"/etc/motion/camera4{-dist,}.conf
install -Dm644 "${pkgdir}/usr/share/motion/examples/motion.service" "${pkgdir}/usr/lib/systemd/system/motion.service"
}