summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2022-10-26 17:10:40 +0200
committerGiovanni Harting2022-10-26 17:10:40 +0200
commit6439bece358ac4273f8558265d9a1b800727c430 (patch)
tree040f8056b8c0e965e63f57d1bd0965bf62c62428
parentbfd7a8909fd6d9173be367903fcb866f9a39e020 (diff)
downloadaur-6439bece358ac4273f8558265d9a1b800727c430.tar.gz
upgpkg: motion-git 3.4.1.r793.db94a89-1
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD61
-rw-r--r--motion.service12
-rw-r--r--motion.sysusers2
-rw-r--r--motion.tmpfiles1
5 files changed, 68 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 087c40d0d4a2..2167de4abe2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
-# Generated by mksrcinfo v8
-# Tue Jun 6 21:41:31 UTC 2017
pkgbase = motion-git
- pkgdesc = A software motion detector which grabs images from video4linux devices and/or from webcams
- pkgver = 4.0.r178.ga801f19
+ pkgdesc = Monitor and record video signals from many types of cameras
+ pkgver = 3.4.1.r793.db94a89
pkgrel = 1
- url = https://motion-project.github.io/
- arch = i686
+ url = https://motion-project.github.io
arch = x86_64
- arch = armv6h
- arch = armv7h
- arch = aarch64
license = GPL
- depends = libjpeg
- depends = v4l-utils
+ makedepends = git
+ depends = sqlite
depends = ffmpeg
- provides = motion
+ depends = libmicrohttpd
+ depends = libwebp
+ depends = mariadb-libs
+ optdepends = gettext: native language support
conflicts = motion
backup = etc/motion/motion.conf
- source = motion::git+https://github.com/Motion-Project/motion.git
- md5sums = SKIP
+ source = git+https://github.com/Motion-Project/motion.git
+ source = motion.service
+ source = motion.sysusers
+ source = motion.tmpfiles
+ b2sums = SKIP
+ b2sums = c66ca8a7723b78f05cf4750377276891cb6025a74ec33960ccaa3939a25edb6eca713d36ded94d20db70cd1bd6694629eb6d43ba63e8165be145bb9d6a668771
+ b2sums = e923b20ceb893fb52cffc530f3d777ccbaffd7aef447f368a6a83b73043795acfb6a26da0bcdeb695a3b356baebe9ad89ea9aabd27e986c482dcd71670957a84
+ b2sums = 3f39854b561200ad052529f187a83f135be3ca4ea20e9897fe41fbae7ed898850017bdd496996199afc00f151a2302314aef8c2f6847337cf1b8e8e7579be4e7
pkgname = motion-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4121042cb50a..a35d46797dac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,52 @@
-# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Maintainer: Giovanni Harting <539@idlegandalf.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: mrxx <mrxx at cyberhome dot at>
+# Contributor: Evgeny Kurnevsky <kurnevsky@gmail.com>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
pkgname=motion-git
-_pkgname=motion
-pkgver=4.0.r178.ga801f19
+pkgver=3.4.1.r793.db94a89
pkgrel=1
-pkgdesc="A software motion detector which grabs images from video4linux devices and/or from webcams"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+pkgdesc="Monitor and record video signals from many types of cameras"
+arch=('x86_64')
license=('GPL')
-url="https://motion-project.github.io/"
-depends=('libjpeg' 'v4l-utils' 'ffmpeg')
-provides=('motion')
-conflicts=('motion')
+url="https://motion-project.github.io"
+conflicts=(motion)
+depends=('sqlite' 'ffmpeg' 'libmicrohttpd' 'libwebp' 'mariadb-libs')
+makedepends=(git)
+optdepends=('gettext: native language support')
backup=('etc/motion/motion.conf')
-source=($_pkgname::git+https://github.com/Motion-Project/${_pkgname}.git)
-md5sums=('SKIP')
+source=("git+https://github.com/Motion-Project/motion.git"
+ 'motion.service'
+ 'motion.sysusers'
+ 'motion.tmpfiles')
+b2sums=('SKIP'
+ 'c66ca8a7723b78f05cf4750377276891cb6025a74ec33960ccaa3939a25edb6eca713d36ded94d20db70cd1bd6694629eb6d43ba63e8165be145bb9d6a668771'
+ 'e923b20ceb893fb52cffc530f3d777ccbaffd7aef447f368a6a83b73043795acfb6a26da0bcdeb695a3b356baebe9ad89ea9aabd27e986c482dcd71670957a84'
+ '3f39854b561200ad052529f187a83f135be3ca4ea20e9897fe41fbae7ed898850017bdd496996199afc00f151a2302314aef8c2f6847337cf1b8e8e7579be4e7')
pkgver() {
- cd "${_pkgname}"
- # cutting off 'release-' prefix that presents in the git tag
- git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/release-//g;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {
- cd "${srcdir}/${_pkgname}"
- autoreconf
- ./configure --prefix=/usr --sysconfdir=/etc --without-mysql --without-pgsql
+ cd ${pkgname%-git}
+ autoreconf -fi
+ ./configure --prefix=/usr \
+ --without-pgsql \
+ --without-mysql \
+ --sysconfdir=/etc \
+ --with-ffmpeg \
+ --with-webp
make
}
package(){
- cd "${srcdir}/${_pkgname}"
- make DESTDIR="${pkgdir}" install
- mv "${pkgdir}"/etc/motion/motion{-dist,}.conf
- mv "${pkgdir}"/etc/motion/camera1{-dist,}.conf
- mv "${pkgdir}"/etc/motion/camera2{-dist,}.conf
- mv "${pkgdir}"/etc/motion/camera3{-dist,}.conf
- mv "${pkgdir}"/etc/motion/camera4{-dist,}.conf
- install -Dm644 "${pkgdir}/usr/share/motion/examples/motion.service" "${pkgdir}/usr/lib/systemd/system/motion.service"
+ cd ${pkgname%-git}
+ make DESTDIR="$pkgdir" install
+ install -Dm644 data/motion-dist.conf "$pkgdir"/etc/motion/motion.conf
+ install -Dm644 "$srcdir"/motion.service "$pkgdir"/usr/lib/systemd/system/motion.service
+ install -Dm644 "$srcdir"/motion.sysusers "$pkgdir"/usr/lib/sysusers.d/motion.conf
+ install -Dm644 "$srcdir"/motion.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/motion.conf
}
diff --git a/motion.service b/motion.service
new file mode 100644
index 000000000000..943585b23704
--- /dev/null
+++ b/motion.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Motion daemon
+After=local-fs.target network.target
+
+[Service]
+User=motion
+ExecStart=/usr/bin/motion -n
+Type=simple
+StandardError=null
+
+[Install]
+WantedBy=multi-user.target
diff --git a/motion.sysusers b/motion.sysusers
new file mode 100644
index 000000000000..1489a53dff34
--- /dev/null
+++ b/motion.sysusers
@@ -0,0 +1,2 @@
+u motion - - /var/lib/motion
+m motion video
diff --git a/motion.tmpfiles b/motion.tmpfiles
new file mode 100644
index 000000000000..8342ff355406
--- /dev/null
+++ b/motion.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/motion 0700 motion motion - -