summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2016-09-25 13:14:46 +0200
committerSebastiaan Lokhorst2016-09-25 13:14:46 +0200
commitca09092d1f90fee1b14de79dc1fb7fc5cc069050 (patch)
tree0a7e8a249ce29cbe8475f93cae6d940851ad4787
downloadaur-ca09092d1f90fee1b14de79dc1fb7fc5cc069050.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9867a9db76e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 25 11:14:09 UTC 2016
+pkgbase = motion-git
+ pkgdesc = A software motion detector which grabs images from video4linux devices and/or from webcams
+ pkgver = release.3.4.1.r98.g7e16a9e
+ pkgrel = 1
+ url = https://motion-project.github.io/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libjpeg
+ depends = v4l-utils
+ depends = ffmpeg
+ backup = etc/motion/motion.conf
+ source = motion::git+https://github.com/Motion-Project/motion.git
+ md5sums = SKIP
+
+pkgname = motion-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dde4bafce36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=motion-git
+_pkgname=motion
+pkgver=release.3.4.1.r98.g7e16a9e
+pkgrel=1
+pkgdesc="A software motion detector which grabs images from video4linux devices and/or from webcams"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://motion-project.github.io/"
+depends=('libjpeg' 'v4l-utils' 'ffmpeg')
+backup=('etc/motion/motion.conf')
+source=($_pkgname::git+https://github.com/Motion-Project/${_pkgname}.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ autoreconf
+ ./configure --prefix=/usr --sysconfdir=/etc --without-mysql --without-pgsql
+ make
+}
+
+package(){
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${pkgdir}/usr/share/motion/examples/motion.service" "${pkgdir}/usr/lib/systemd/system/motion.service"
+}