summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRunningDroid2015-10-06 00:11:18 -0400
committerRunningDroid2015-10-06 00:11:18 -0400
commit5b008371057893903c4b23f1a7123950a79969f4 (patch)
tree92ac9c74e01ab16d2b5b8d7b30b5ed9d3c1fb038
downloadaur-5b008371057893903c4b23f1a7123950a79969f4.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--motion.install7
-rw-r--r--motion.service12
-rw-r--r--motion.tmpfiles1
5 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..025402225d6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = motion-mrdave-git
+ pkgdesc = A software motion detector which grabs images from video4linux devices and/or from webcams - Mr-Dave's fork
+ pkgver = r654.2caced3
+ pkgrel = 1
+ url = http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
+ install = motion.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libjpeg
+ depends = v4l-utils
+ depends = ffmpeg-compat
+ backup = etc/motion/motion.conf
+ source = git+https://github.com/Mr-Dave/motion.git
+ source = motion.service
+ source = motion.tmpfiles
+ md5sums = SKIP
+ md5sums = b5b589f8f39939b7a1802cbd9dbe2e1a
+ md5sums = f863f8c025f7f025b2178def8418decd
+
+pkgname = motion-mrdave-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc8da83ae880
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: RunningDroid <runningdroid AT zoho.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=motion-mrdave-git
+pkgver=r654.2caced3
+pkgrel=1
+pkgdesc="A software motion detector which grabs images from video4linux devices and/or from webcams - Mr-Dave's fork"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
+depends=('libjpeg' 'sqlite' 'ffmpeg')
+backup=('etc/motion/motion.conf')
+install=motion.install
+source=(git+https://github.com/Mr-Dave/motion.git
+ motion.service
+ motion.tmpfiles)
+md5sums=('SKIP'
+ 'b5b589f8f39939b7a1802cbd9dbe2e1a'
+ 'f863f8c025f7f025b2178def8418decd')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-mrdave-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-mrdave-git}"
+ autoreconf
+ ./configure --prefix=/usr \
+ --without-pgsql \
+ --without-mysql \
+ --sysconfdir=/etc/motion \
+ --with-ffmpeg
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname%-mrdave-git}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}/motion.service" "${pkgdir}/usr/lib/systemd/system/motion.service"
+ install -Dm644 "${srcdir}/motion.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/motion.conf"
+}
diff --git a/motion.install b/motion.install
new file mode 100644
index 000000000000..f36054033304
--- /dev/null
+++ b/motion.install
@@ -0,0 +1,7 @@
+post_install() {
+ systemd-tmpfiles --create motion.conf
+}
+
+post_upgrade() {
+ systemd-tmpfiles --create motion.conf
+}
diff --git a/motion.service b/motion.service
new file mode 100644
index 000000000000..23aba29cd920
--- /dev/null
+++ b/motion.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Motion daemon
+After=local-fs.target
+
+[Service]
+ExecStart=/usr/bin/motion
+Type=forking
+#StandardOutput=null
+StandardError=null
+
+[Install]
+WantedBy=multi-user.target
diff --git a/motion.tmpfiles b/motion.tmpfiles
new file mode 100644
index 000000000000..b558b66df115
--- /dev/null
+++ b/motion.tmpfiles
@@ -0,0 +1 @@
+D /var/run/motion 0755 root root