summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraquarius2016-07-28 12:44:10 +0300
committeraquarius2016-07-28 12:44:10 +0300
commit5235053bea0e620ca1bf452753eff36795cb5073 (patch)
treef46fe6090d6bc44576bd438667a4b4adcac0ae50
parent9e7b7826afef93789b22dbf9ea6dfb5dda368a94 (diff)
downloadaur-5235053bea0e620ca1bf452753eff36795cb5073.tar.gz
fix
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD11
-rw-r--r--maya.install68
-rw-r--r--maya_start.sh12
4 files changed, 80 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a03fb98d21f4..399749626876 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = maya
arch = x86_64
license = custom: unlimited
makedepends = rpmextract
+ makedepends = gcc
depends = libpng12
depends = tcsh
depends = libxp
diff --git a/PKGBUILD b/PKGBUILD
index 769f56cf428e..74a59d0b631a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,17 @@ arch=('x86_64')
url="http://www.autodesk.com/products/maya/overview"
license=('custom: unlimited')
depends=('libpng12' 'tcsh' 'libxp' 'openssl' 'libjpeg' 'libtiff')
-makedepends=('rpmextract')
+makedepends=('rpmextract' 'gcc')
conflicts=()
install=maya.install
-source=(http://download.autodesk.com/us/support/files/maya_2016_service_pack_5/Autodesk_Maya_2016_SP5_EN_Linux_64bit.tgz)
+source=('http://download.autodesk.com/us/support/files/maya_2016_service_pack_5/Autodesk_Maya_2016_SP5_EN_Linux_64bit.tgz')
md5sums=('5b88676c1c3239ea26b9de656340e974')
package() {
+ install "$pkgdir"/opt/Autodesk/MayaSetup
+ rsync -av --exclude='*.rpm' ./ "$pkgdir"/opt/Autodesk/MayaSetup
+
cd "$pkgdir"
msg2 "Unpacking Red Hat .rpm files. This could take a while..."
@@ -23,5 +26,9 @@ package() {
rpmextract.sh $i
done
+ mv "$pkgdir"/usr/local/bin/maya "$pkgdir"/usr/local/bin/oriMaya
+
+ cp "$srcdir"/maya_start.sh "$pkgdir"/usr/local/bin/maya
+
}
diff --git a/maya.install b/maya.install
index e190fc6b1b79..b5c6b7abfbec 100644
--- a/maya.install
+++ b/maya.install
@@ -3,12 +3,12 @@
# you don't need (and this header).
## arg 1: the new package version
-pre_install() {
- echo "If you have not already done so, you can get your serial number from: http://students.autodesk.com"
- read -p "Please enter your serial number: " SERIALNUMBER
- read -p "Please enter your product id: " PRODUCTID
- echo ""
-}
+#pre_install() {
+ #echo "If you have not already done so, you can get your serial number from: http://students.autodesk.com"
+ #read -p "Please enter your serial number: " SERIALNUMBER
+ #read -p "Please enter your product id: " PRODUCTID
+ #echo ""
+#}
## arg 1: the new package version
post_install() {
@@ -20,7 +20,7 @@ post_install() {
echo -e 'MAYA_LICENSE=unlimited\nMAYA_LICENSE_METHOD=standalone' > /usr/autodesk/maya2016/bin/License.env
- /usr/autodesk/maya2016/bin/adlmreg -i S $PRODUCTID $PRODUCTID 2016.0.0.F $SERIALNUMBER /var/opt/Autodesk/Adlm/Maya2016/MayaConfig.pit
+ #/usr/autodesk/maya2016/bin/adlmreg -i S $PRODUCTID $PRODUCTID 2016.0.0.F $SERIALNUMBER /var/opt/Autodesk/Adlm/Maya2016/MayaConfig.pit
/opt/Autodesk/Adlm/FLEXnet/bin/install_fnp.sh /opt/Autodesk/Adlm/FLEXnet/bin/FNPLicensingService
@@ -32,6 +32,54 @@ post_install() {
mkdir /usr/autodesk/maya2016/plugin-backups
mv /usr/autodesk/maya2016/plug-ins/bifrost /usr/autodesk/maya2016/plugin-backups/
+
+ read -r -d '' POSTINSTALLMGG << EOF
+######################################
+## Run this commands once after install
+######################################
+#export MAYA_LOCATION=/usr/autodesk/maya2016/
+#export LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R11/lib64/
+
+#nano mayainstall.c
+
+##add the following in nano, save and close
+#int main (void) {return 0;}
+
+#gcc mayainstall.c
+
+#if [ -f "/usr/bin/rpm" ] && sudo mv /usr/bin/rpm /usr/bin/rpm_backup
+
+#gcc mayainstall.c
+#sudo cp a.out /usr/bin/rpm
+
+#chmod +x /opt/Autodesk/MayaSetup/setup
+#sudo /opt/Autodesk/MayaSetup/setup
+
+##Then, follow the GUI, Accept, put your Serial Number and the 657G1 thing
+
+#sudo rm /usr/bin/rpm
+#if [ -f "/usr/bin/rpm_backup" ] && sudo mv /usr/bin/rpm_backup /usr/bin/rpm
+
+## Run once as sudo to activate the licence
+
+#sudo maya
+
+##If didn’t activate so go to https://registeronce.autodesk.com and when it asks you for request file, get from /tmp/MAYA2016en_USLongCode.xml while maya activation screen is open. You will get a file named Long_Response_Code.xml which will allow you to activate.
+
+## Close maya and run the following
+## Since Maya was ran once with sudo, reset the owner of the maya folder to user
+#sudo chown -R "$USER":"$USER" ~/maya
+
+## Close the file and you are almost done
+## Maya uses the windows key to move around, so disable the Unity hints so that they don't pop up
+##Install compizconfig-settings-manager
+##Disable Shortcut Hints Overlay
+##Uninstall it when you are done
+
+EOF
+
+ echo "$POSTINSTALLMGG"
+
}
## arg 1: the new package version
@@ -47,7 +95,7 @@ post_install() {
#}
## arg 1: the old package version
-#pre_remove() {
+pre_remove() {
rm /usr/lib/libadlmPIT.so.11
rm /usr/lib/libadlmutil.so.11
@@ -59,10 +107,10 @@ post_install() {
rm /usr/autodesk/maya2016/lib/libcrypto.so.10
rm /usr/autodesk/maya2016/lib/libjpeg.so.62
- rm/usr/autodesk/maya2016/lib/libtiff.so.3
+ rm /usr/autodesk/maya2016/lib/libtiff.so.3
rm -rf /usr/autodesk/maya2016/plugin-backups
-#}
+}
## arg 1: the old package version
#post_remove() {
diff --git a/maya_start.sh b/maya_start.sh
new file mode 100644
index 000000000000..e87ec108bf7b
--- /dev/null
+++ b/maya_start.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+sudo -v
+## Bug with openGL populate
+sudo mv /usr/lib/x86_64-linux-gnu/libGL.so /usr/lib/x86_64-linux-gnu/baklibGL.so
+sudo ldconfig
+
+## Maya does not need sudo to run
+oriMaya
+
+sudo mv /usr/lib/x86_64-linux-gnu/baklibGL.so /usr/lib/x86_64-linux-gnu/libGL.so
+sudo ldconfig \ No newline at end of file