summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2016-11-26 09:43:00 +1000
committerKyle De'Vir2016-11-26 09:43:00 +1000
commitda43d89b91da8b572938f13b4b44dbfe6d181bc4 (patch)
tree926796730e356622e2c07422e98f8cf237e3e874
parente64c0f5137734fb39a0aa71bb615a0b8ca8c55de (diff)
downloadaur-da43d89b91da8b572938f13b4b44dbfe6d181bc4.tar.gz
Reorganize & update to 2017
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD77
-rw-r--r--maya.desktop10
-rw-r--r--maya.install128
4 files changed, 97 insertions, 141 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d95b14ba8b58..45dea3277ac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,28 @@
pkgbase = maya
- pkgdesc = Maya software helps you tackle challenging character creation and digital animation productions. Get powerful, integrated 3D tools on a robust, extensible CG pipeline core.
- pkgver = 2016_SP5
+ pkgdesc = Autodesk Maya 3D modelling software suite
+ pkgver = 2017_UPDATE_1
pkgrel = 1
url = http://www.autodesk.com/products/maya/overview
install = maya.install
arch = x86_64
license = custom: unlimited
- makedepends = rpmextract
- makedepends = gcc
depends = libpng12
depends = tcsh
depends = libxp
depends = openssl
- depends = libjpeg
+ depends = libjpeg6-turbo
depends = libtiff
- source = http://download.autodesk.com/us/support/files/maya_2016_service_pack_5/Autodesk_Maya_2016_SP5_EN_Linux_64bit.tgz
- source = maya_start.sh::https://aur.archlinux.org/maya.git
- md5sums = 5b88676c1c3239ea26b9de656340e974
- md5sums = 9ba05fd94f32ae0a4462851063316d4e
+ depends = gamin
+ depends = audiofile
+ depends = e2fsprogs
+ depends = xorg-fonts-75dpi
+ depends = xorg-fonts-100dpi
+ depends = xorg-fonts-misc
+ options = !strip
+ source = http://up.autodesk.com/2017/MAYA/Autodesk_Maya_2017_Update1_EN_Linux_64bit.tgz
+ source = maya.desktop
+ sha512sums = 984f3c943f762bdf8b6f967874014077bc47086348fbcc4c468dd208569d9a2286d02377a5291129ad7ce55122a462d0ce0b0adf9bb788dd5e1dfcfb6021059b
+ sha512sums = 1050ff7d4ff5e0686cab8c7977b83fd8c911f88afa8a93b7cb7d4a095f1a441d9f3732be9a59406856904a406ffe07c4633f92b7c91b052f8d4cd1422f5e7f3f
pkgname = maya
diff --git a/PKGBUILD b/PKGBUILD
index 9e9c9ce07da5..ef168b0b6582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,57 @@
+# Maintainer ~ kyle[dot]devir[at]mykolab[dot]com
+
pkgname=maya
-pkgver=2016_SP5
+pkgver=2017_UPDATE_1
pkgrel=1
-pkgdesc="Maya software helps you tackle challenging character creation and digital animation productions. Get powerful, integrated 3D tools on a robust, extensible CG pipeline core."
+pkgdesc="Autodesk Maya 3D modelling software suite"
arch=('x86_64')
url="http://www.autodesk.com/products/maya/overview"
license=('custom: unlimited')
-depends=('libpng12' 'tcsh' 'libxp' 'openssl' 'libjpeg' 'libtiff')
-makedepends=('rpmextract' 'gcc')
-conflicts=()
-install=maya.install
-source=('http://download.autodesk.com/us/support/files/maya_2016_service_pack_5/Autodesk_Maya_2016_SP5_EN_Linux_64bit.tgz'
- 'maya_start.sh::https://aur.archlinux.org/maya.git')
-md5sums=('5b88676c1c3239ea26b9de656340e974'
- '9ba05fd94f32ae0a4462851063316d4e')
+depends=('libpng12' 'tcsh' 'libxp' 'openssl' 'libjpeg6-turbo' 'libtiff' 'gamin'
+ 'audiofile' 'e2fsprogs' 'xorg-fonts-75dpi' 'xorg-fonts-100dpi'
+ 'xorg-fonts-misc')
+install="maya.install"
+options=(!strip)
+source=('http://up.autodesk.com/2017/MAYA/Autodesk_Maya_2017_Update1_EN_Linux_64bit.tgz'
+ 'maya.desktop')
+sha512sums=('984f3c943f762bdf8b6f967874014077bc47086348fbcc4c468dd208569d9a2286d02377a5291129ad7ce55122a462d0ce0b0adf9bb788dd5e1dfcfb6021059b'
+ '1050ff7d4ff5e0686cab8c7977b83fd8c911f88afa8a93b7cb7d4a095f1a441d9f3732be9a59406856904a406ffe07c4633f92b7c91b052f8d4cd1422f5e7f3f')
+
+prepare() {
+ cd "$srcdir"
+
+ rm -Rf ../maya-setup
+ mkdir -p ../maya-setup
+ mv * ../maya-setup
+}
package() {
-
- install "$pkgdir"/opt/Autodesk/MayaSetup
- rsync -av --exclude='*.rpm' ./ "$pkgdir"/opt/Autodesk/MayaSetup
-
- cd "$pkgdir"
-
- msg2 "Unpacking Red Hat .rpm files. This could take a while..."
-
- for i in "$srcdir"/*.rpm; do
- msg2 $i
- rpmextract.sh $i
- done
-
- mv "$pkgdir"/usr/local/bin/maya "$pkgdir"/usr/local/bin/oriMaya
-
- cp "$srcdir"/maya_start.sh "$pkgdir"/usr/local/bin/maya
-
+ cd "$pkgdir"
+
+ # Extract RPMs
+ for i in ../../maya-setup/*.rpm; do
+ msg2 "Extracting ${i}"
+ bsdtar -xf $i
+ done
+
+ mkdir "$pkgdir"/usr/tmp/
+ chmod 777 "$pkgdir"/usr/tmp/
+
+ mkdir -p "$pkgdir"/usr/lib/
+ chmod 755 "$pkgdir"/usr/lib/
+ cp "$pkgdir"/opt/Autodesk/Adlm/R12/lib64/libadlmPIT.so.12 "$pkgdir"/usr/lib/libadlmPIT.so.12
+ cp "$pkgdir"/opt/Autodesk/Adlm/R12/lib64/libadlmutil.so.12 "$pkgdir"/usr/lib/libadlmutil.so.12
+
+ ln -s /usr/lib/libssl.so "$pkgdir"/usr/autodesk/maya2017/lib/libssl.so.10
+ ln -s /usr/lib/libcrypto.so "$pkgdir"/usr/autodesk/maya2017/lib/libcrypto.so.10
+ ln -s /usr/lib/libjpeg.so.62 "$pkgdir"/usr/autodesk/maya2017/lib/libjpeg.so.62
+ ln -s /usr/lib/libtiff.so "$pkgdir"/usr/autodesk/maya2017/lib/libtiff.so.3
+
+ mkdir -p "$pkgdir"/usr/bin/
+ chmod 755 "$pkgdir"/usr/bin/
+ ln -s "$pkgdir"/usr/autodesk/maya2017/bin/maya2017 "$pkgdir"/usr/bin/maya2017
+
+ mkdir -p "$pkgdir"/usr/share/applications/
+ chmod 755 "$pkgdir"/usr/share/applications/
+ install -Dm644 ../../maya-setup/maya.desktop "$pkgdir"/usr/share/applications/maya.desktop
}
-
diff --git a/maya.desktop b/maya.desktop
new file mode 100644
index 000000000000..e10d1df57695
--- /dev/null
+++ b/maya.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Autodesk Maya 2017
+GenericName=Maya
+Comment=3D modeling, animation, rendering and post-production
+Keywords=3d;cg;modeling;animation;painting;sculpting;texturing;rendering;render engine;python;
+Exec=/usr/autodesk/maya2017/bin/maya2017
+Icon=/usr/autodesk/maya2017/icons/mayaico.png
+Terminal=false
+Type=Application
+Categories=Graphics;3DGraphics;
diff --git a/maya.install b/maya.install
index b5c6b7abfbec..a08a35d84d82 100644
--- a/maya.install
+++ b/maya.install
@@ -1,118 +1,38 @@
-# This is a default template for a post-install scriptlet.
-# Uncomment only required functions and remove any functions
-# you don't need (and this header).
-
-## arg 1: the new package version
-#pre_install() {
- #echo "If you have not already done so, you can get your serial number from: http://students.autodesk.com"
- #read -p "Please enter your serial number: " SERIALNUMBER
- #read -p "Please enter your product id: " PRODUCTID
- #echo ""
-#}
-
-## arg 1: the new package version
post_install() {
- mkdir /usr/tmp
- chmod 777 /usr/tmp
-
- cp /opt/Autodesk/Adlm/R11/lib64/libadlmPIT.so.11 /usr/lib/libadlmPIT.so.11
- cp /opt/Autodesk/Adlm/R11/lib64/libadlmutil.so.11 /usr/lib/libadlmutil.so.11
-
- echo -e 'MAYA_LICENSE=unlimited\nMAYA_LICENSE_METHOD=standalone' > /usr/autodesk/maya2016/bin/License.env
-
- #/usr/autodesk/maya2016/bin/adlmreg -i S $PRODUCTID $PRODUCTID 2016.0.0.F $SERIALNUMBER /var/opt/Autodesk/Adlm/Maya2016/MayaConfig.pit
-
- /opt/Autodesk/Adlm/FLEXnet/bin/install_fnp.sh /opt/Autodesk/Adlm/FLEXnet/bin/FNPLicensingService
-
- ln -s /usr/lib/libssl.so /usr/autodesk/maya2016/lib/libssl.so.10
- ln -s /usr/lib/libcrypto.so /usr/autodesk/maya2016/lib/libcrypto.so.10
-
- ln -s /usr/lib/libjpeg.so /usr/autodesk/maya2016/lib/libjpeg.so.62
- ln -s /usr/lib/libtiff.so /usr/autodesk/maya2016/lib/libtiff.so.3
-
- mkdir /usr/autodesk/maya2016/plugin-backups
- mv /usr/autodesk/maya2016/plug-ins/bifrost /usr/autodesk/maya2016/plugin-backups/
-
- read -r -d '' POSTINSTALLMGG << EOF
-######################################
-## Run this commands once after install
-######################################
-#export MAYA_LOCATION=/usr/autodesk/maya2016/
-#export LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R11/lib64/
-
-#nano mayainstall.c
-
-##add the following in nano, save and close
-#int main (void) {return 0;}
-
-#gcc mayainstall.c
+ echo -e 'MAYA_LICENSE=unlimited\nMAYA_LICENSE_METHOD=standalone' > /usr/autodesk/maya2017/bin/License.env
-#if [ -f "/usr/bin/rpm" ] && sudo mv /usr/bin/rpm /usr/bin/rpm_backup
+ /opt/Autodesk/Adlm/FLEXnet/bin/install_fnp.sh /opt/Autodesk/Adlm/FLEXnet/bin/FNPLicensingService
-#gcc mayainstall.c
-#sudo cp a.out /usr/bin/rpm
+ read -r -d '' POSTINSTALLMGG << EOF
+## In order to activate Maya, you need to run its registration setup file and
+## enter your registration information.
-#chmod +x /opt/Autodesk/MayaSetup/setup
-#sudo /opt/Autodesk/MayaSetup/setup
+## Find the folder where your Maya package was built, look under maya-setup,
+## and run:
-##Then, follow the GUI, Accept, put your Serial Number and the 657G1 thing
+$ export LD_LIBRARY_PATH=/opt/Autodesk/Adlm/R12/lib64/
+$ sudo ./setup
-#sudo rm /usr/bin/rpm
-#if [ -f "/usr/bin/rpm_backup" ] && sudo mv /usr/bin/rpm_backup /usr/bin/rpm
+## When it asks for your registration information,
+## go to http://www.autodesk.com/education/free-software/maya
+## and create a student account. Next, select Maya 2017 for the version,
+## Linux as the operating system, and English for the language.
-## Run once as sudo to activate the licence
+## Follow the setup all the way through. Installation will fail, but that's
+## normal.
+
+## Next, run Maya to activate the licence.
-#sudo maya
+$ maya
-##If didn’t activate so go to https://registeronce.autodesk.com and when it asks you for request file, get from /tmp/MAYA2016en_USLongCode.xml while maya activation screen is open. You will get a file named Long_Response_Code.xml which will allow you to activate.
+## Maya uses the Alt key to move around, so if your window manager uses
+## pure Alt for moving the window around, change it to Meta or something.
-## Close maya and run the following
-## Since Maya was ran once with sudo, reset the owner of the maya folder to user
-#sudo chown -R "$USER":"$USER" ~/maya
-
-## Close the file and you are almost done
-## Maya uses the windows key to move around, so disable the Unity hints so that they don't pop up
-##Install compizconfig-settings-manager
-##Disable Shortcut Hints Overlay
-##Uninstall it when you are done
+## If you use Plasma 5 with Kwin, which does use this behavior by default:
+## Go to System Settings -> Window Behavior -> Window Actions,
+## And change the Modifier Key for Inner Window to Meta
EOF
- echo "$POSTINSTALLMGG"
-
-}
-
-## arg 1: the new package version
-## arg 2: the old package version
-#pre_upgrade() {
- # do something here
-#}
-
-## arg 1: the new package version
-## arg 2: the old package version
-#post_upgrade() {
- # do something here
-#}
-
-## arg 1: the old package version
-pre_remove() {
- rm /usr/lib/libadlmPIT.so.11
- rm /usr/lib/libadlmutil.so.11
-
- rm /usr/autodesk/maya2016/bin/License.env
-
- rm /var/opt/Autodesk/Adlm/Maya2016/MayaConfig.pit
-
- rm /usr/autodesk/maya2016/lib/libssl.so.10
- rm /usr/autodesk/maya2016/lib/libcrypto.so.10
-
- rm /usr/autodesk/maya2016/lib/libjpeg.so.62
- rm /usr/autodesk/maya2016/lib/libtiff.so.3
-
- rm -rf /usr/autodesk/maya2016/plugin-backups
+ echo "$POSTINSTALLMGG"
}
-
-## arg 1: the old package version
-#post_remove() {
- # do something here
-#}