summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hardy2017-03-12 16:11:18 +1100
committerJoshua Hardy2017-03-12 16:11:18 +1100
commit6118ca8025cd894135b32e6d2b17af976709f6d7 (patch)
treefe97eb8feec19aa8f43f3e3835929bd0bb0d7c14
downloadaur-6118ca8025cd894135b32e6d2b17af976709f6d7.tar.gz
first upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b4d3c2c6a43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = motioncor2
+ pkgdesc = A multi-GPU program that corrects beam-induced sample motion on dose fractionated movie stacks
+ pkgver = 01302017
+ pkgrel = 1
+ url = http://msg.ucsf.edu/em/software/motioncor2.html
+ arch = x86_64
+ license = CCPL:cc-by-nc-nd-3.0
+ depends = cuda
+ depends = nvidia-utils
+ source = http://msg.ucsf.edu/MotionCor2/MotionCor2-01-30-2017.tar.gz
+ md5sums = aec2f2653ba948e6d9a91a851171ce27
+
+pkgname = motioncor2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..255fc1179456
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Joshua Hardy joshinsilico@gmail.com
+pkgname=motioncor2
+pkgver=01302017
+pkgrel=1
+pkgdesc="A multi-GPU program that corrects beam-induced sample motion on dose fractionated movie stacks"
+arch=(x86_64)
+url="http://msg.ucsf.edu/em/software/motioncor2.html"
+license=('CCPL:cc-by-nc-nd-3.0')
+depends=('cuda' 'nvidia-utils')
+makedepends=()
+optdepends=()
+source=("http://msg.ucsf.edu/MotionCor2/MotionCor2-01-30-2017.tar.gz")
+md5sums=('aec2f2653ba948e6d9a91a851171ce27')
+build() {
+ cd "${srcdir}"/
+ execstack -c MotionCor2-??-??-????
+ echo "MotionCor2 was designed by Shawn Zheng@University of California and is free for academic use. Cite publication: Shawn Q. Zheng, Eugene Palovcak, Jean-Paul Armache, Yifan Cheng and David A. Agard (2016) Anisotropic Correction of Beam-induced Motion for Improved Single-particle Electron Cryo-microscopy, Nature Methods, submitted. BioArxiv: http://biorxiv.org/content/early/2016/07/04/061960"
+}
+package() {
+ install -d "${pkgdir}"/usr "${pkgdir}"/usr/bin
+ install -D -m755 "${srcdir}"/MotionCor2-??-??-???? "${pkgdir}"/usr/bin/MotionCor2
+}