summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2022-04-07 16:20:58 +0200
committerJose Riha2022-04-07 16:20:58 +0200
commit2ac1b952908bbe7919b1423e1f8f5dac493ee697 (patch)
treed7dbf2f412c6b593700460badc13213d6589db63
parentf0718cc353c8c1c858aafce986d216bbefe673ce (diff)
downloadaur-2ac1b952908bbe7919b1423e1f8f5dac493ee697.tar.gz
Drop tmpfiles, EN by default, set perms, remove prep
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--motioneye.install7
-rw-r--r--motioneye.service1
-rw-r--r--motioneye.tmpfiles4
5 files changed, 14 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ae260e5ec1e..bccfa8b7852f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = motioneye-git
pkgdesc = A web frontend for the motion daemon, Python 3 development branch
- pkgver = 0.42.1.r310.g601bcfb
+ pkgver = 0.42.1.r318.g6a5953b
pkgrel = 1
url = https://github.com/ccrisan/motioneye.git
install = motioneye.install
@@ -17,10 +17,8 @@ pkgbase = motioneye-git
conflicts = motioneye
backup = etc/motioneye/motioneye.conf
source = git+https://github.com/ccrisan/motioneye.git#branch=dev
- source = motioneye.tmpfiles
source = motioneye.service
sha256sums = SKIP
- sha256sums = e7447bf9ab023326e7c396ecad8933eaa3399b16d844a34f288cf55b8c917bfa
- sha256sums = 55a72fe49d2bacbc1cc9231ef80afab3859a48c558fe030f46ce8c7d3a95341e
+ sha256sums = 9de27c851809664a8aa4ca8ee48cae1db2954ccb09978a85c127745bf7445286
pkgname = motioneye-git
diff --git a/PKGBUILD b/PKGBUILD
index 68421f7482d9..667007d314d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Niklas Hedlund <nojan1989@gmail.com>
pkgname=motioneye-git
-pkgver=0.42.1.r310.g601bcfb
+pkgver=0.42.1.r318.g6a5953b
pkgrel=1
pkgdesc="A web frontend for the motion daemon, Python 3 development branch"
url="https://github.com/ccrisan/motioneye.git"
@@ -21,11 +21,9 @@ depends=("motion"
makedepends=("python-setuptools")
backup=("etc/motioneye/motioneye.conf")
source=("git+$url#branch=dev"
- "motioneye.tmpfiles"
"motioneye.service")
sha256sums=('SKIP'
- 'e7447bf9ab023326e7c396ecad8933eaa3399b16d844a34f288cf55b8c917bfa'
- '55a72fe49d2bacbc1cc9231ef80afab3859a48c558fe030f46ce8c7d3a95341e')
+ '9de27c851809664a8aa4ca8ee48cae1db2954ccb09978a85c127745bf7445286')
backup=("etc/motioneye/motioneye.conf")
install=motioneye.install
@@ -34,17 +32,10 @@ pkgver(){
git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//"
}
-prepare(){
- cd motioneye/motioneye
- sed -i "extra/motioneye.conf.sample" \
- -e 's|^run_path /run/motioneye$|run_path /var/run/motioneye|'
-}
-
package(){
cd motioneye
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps .
# configuration folder must be writable by motioneye
- install -D -m 660 "motioneye/extra/motioneye.conf.sample" "$pkgdir/etc/motioneye/motioneye.conf"
- install -D -m 644 "$srcdir/motioneye.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/motioneye.conf"
- install -D -m 644 "$srcdir/motioneye.service" "$pkgdir/usr/lib/systemd/system/motioneye.service"
+ install -Dm 660 "motioneye/extra/motioneye.conf.sample" "$pkgdir/etc/motioneye/motioneye.conf"
+ install -Dm 644 "$srcdir/motioneye.service" "$pkgdir/usr/lib/systemd/system/motioneye.service"
}
diff --git a/motioneye.install b/motioneye.install
index 87c10345490d..a8984899bb81 100644
--- a/motioneye.install
+++ b/motioneye.install
@@ -7,4 +7,11 @@ post_install(){
password: (no password)
INFO
+ chown motion:motion /etc/motioneye/motioneye.conf
+ chown motion:motion /etc/motioneye
+}
+
+post_upgrade() {
+ chown motion:motion /etc/motioneye/motioneye.conf
+ chown motion:motion /etc/motioneye
}
diff --git a/motioneye.service b/motioneye.service
index 3c4534d99e62..426a1105cca0 100644
--- a/motioneye.service
+++ b/motioneye.service
@@ -4,6 +4,7 @@ After=local-fs.target network.target
[Service]
User=motion
+Environment="LANGUAGE=en_EN"
RuntimeDirectory=motioneye
LogsDirectory=motioneye
StateDirectory=motioneye
diff --git a/motioneye.tmpfiles b/motioneye.tmpfiles
deleted file mode 100644
index 02aa9bf5384d..000000000000
--- a/motioneye.tmpfiles
+++ /dev/null
@@ -1,4 +0,0 @@
-d /etc/motioneye 0770 root motion
-f /etc/motioneye/motioneye.conf 0660 root motion
-d /var/lib/motioneye 0750 motion motion
-Z /var/lib/motioneye - motion motion