summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorweearc2019-01-18 03:32:27 +0800
committerweearc2019-01-18 03:32:27 +0800
commitecc5dde22fbd4a53a22d411dda92980440ac59a1 (patch)
tree9028640131838405b17aa4851efebb8a37429b75
downloadaur-ecc5dde22fbd4a53a22d411dda92980440ac59a1.tar.gz
create package
-rw-r--r--.SRCINFO16
-rw-r--r--Motrix.desktop15
-rw-r--r--PKGBUILD53
-rw-r--r--motrix-source-git-git20190112-1.src.tar.gzbin0 -> 1335 bytes
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af4d66e8681f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = motrix-source-git
+ pkgdesc = elegent downloading tool frontend for aria2c,using vue
+ pkgver = git20190112
+ pkgrel = 1
+ url = https://github.com/agalwood/Motrix
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ makedepends = git
+ depends = bash
+ depends = aria2
+ source = Motrix.desktop
+ md5sums = SKIP
+
+pkgname = motrix-source-git
+
diff --git a/Motrix.desktop b/Motrix.desktop
new file mode 100644
index 000000000000..df357b24e548
--- /dev/null
+++ b/Motrix.desktop
@@ -0,0 +1,15 @@
+[Desktop Entry]
+Name=Motrix
+Comment=download manager
+Keywords=
+Exec=/opt/motrix/motrix
+TryExec=
+Terminal=false
+Icon=/usr/share/icons/motrix.png
+Type=Applications
+Categories=
+MimeType=
+StartupNotify=false
+StartupWMClass=
+OnlyShowIn=
+Actions=
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2651069c006f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: weearc <q19981121@163.com>
+pkgname=motrix-source-git
+_pkgname=Motrix
+pkgver=git20190112
+pkgrel=1
+epoch=
+pkgdesc="elegent downloading tool frontend for aria2c,using vue"
+arch=("x86_64")
+url="https://github.com/agalwood/Motrix"
+license=('MIT')
+groups=()
+depends=('bash'
+ 'aria2')
+makedepends=('npm'
+ 'git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("Motrix.desktop")
+noextract=()
+md5sums=(SKIP)
+validpgpkeys=()
+
+prepare() {
+ git clone https://github.com/agalwood/$_pkgname.git
+ npm config set registry 'https://registry.npm.taobao.org'
+ export ELECTRON_MIRROR='https://npm.taobao.org/mirrors/electron/'
+ export SASS_BINARY_SITE='https://npm.taobao.org/mirrors/node-sass'
+
+}
+
+build() {
+ cd $_pkgname/
+ npm install
+ npm run build
+}
+package() {
+ install -d ${pkgdir}/opt
+ install -d ${pkgdir}/usr/bin
+ install -d ${pkgdir}/usr/share/icons
+ install -d ${pkgdir}/usr/share/applications
+ mv ${srcdir}/$_pkgname/release/linux-unpacked/ ${pkgdir}/opt/motrix
+ install -Dm644 ${srcdir}/$_pkgname/build/256x256.png ${pkgdir}/usr/share/icons/$_pkgname.png
+ echo -n "!/bin/bash \n /opt/motrix/motrix" >> ${pkgdir}/usr/bin/motrix
+ chmod a+x ${pkgdir}/usr/bin/motrix
+ install -Dm 644 Motrix.desktop ${pkgdir}/usr/share/applications
+}
diff --git a/motrix-source-git-git20190112-1.src.tar.gz b/motrix-source-git-git20190112-1.src.tar.gz
new file mode 100644
index 000000000000..a11f8f6362ea
--- /dev/null
+++ b/motrix-source-git-git20190112-1.src.tar.gz
Binary files differ