summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2024-03-12 18:29:37 +0600
committerzoorat2024-03-12 18:29:37 +0600
commit584671e297e2e4370d7d2a161531fc87d6886c4b (patch)
treea8c55bfd6d6a737b5968a050618f7f6548348b8d
parentd379a6bbc8de04d46ea5fd926ddcb35d41af4810 (diff)
downloadaur-584671e297e2e4370d7d2a161531fc87d6886c4b.tar.gz
adding changelog
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore13
-rw-r--r--Makefile90
-rw-r--r--PKGBUILD36
-rw-r--r--changelog.md98
5 files changed, 212 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bf76db8b2c5..a23f2f4db504 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = motrix-bin
pkgdesc = A full-featured download manager (binary version)
pkgver = 1.8.19
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/agalwood/Motrix
+ changelog = changelog.md
arch = x86_64
license = MIT
depends = gtk3
diff --git a/.gitignore b/.gitignore
index ed1769f825c2..fd1cf73e6413 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,6 @@
-# Exclude makepkg generated data
-pkg/
-src/
-
-# Exclude downloaded/generated files
-motrix-bin-*
-Motrix_* \ No newline at end of file
+*
+!.gitignore
+!Makefile
+!PKGBUILD
+!.SRCINFO
+!changelog.md
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..ffa42df81816
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,90 @@
+MAKEFLAGS += --warn-undefined-variables
+SHELL=/bin/bash
+
+REPO = $(shell grep url .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+TRASH = $(shell git check-ignore * | tr '\n' ' ')
+
+# DEFAULT
+all: clean log sum build check pre clean
+
+# just build the package
+build:
+ makepkg -sfr
+
+# build and install the package
+install:
+ makepkg --install
+
+# update checksums
+sum:
+ updpkgsums
+
+# check/lint
+check:
+ @echo "shellcheck: "
+ shellcheck -e SC2148 -e SC2034 PKGBUILD || exit 0
+
+ @echo "shell formate: "
+ shfmt -d PKGBUILD || exit 0
+
+ @echo "checking PKGBUILD: "
+ namcap -i PKGBUILD
+
+ @echo "checking build: "
+ namcap -i *.pkg.*
+
+# clean up the mess
+clean:
+ifeq ($(strip $(TRASH)),)
+ @echo "nothing to clear"
+else
+ file $(TRASH)
+ @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
+ trash-put -v $(TRASH) ; \
+ exit 0 ; \
+ fi
+endif
+
+# generate `changelog.md`
+log:
+ @echo "wait, it will take some time"
+ $(eval NAME := $(shell gh release --repo $(REPO) view --json name | jq -r .name))
+ echo "# Name: $(NAME) " >changelog.md
+ $(eval URL := $(shell gh release --repo $(REPO) view --json url | jq -r .url))
+ echo "### URL: $(URL)" >>changelog.md
+ $(eval PUBLISHED_AT := $(shell gh release --repo $(REPO) view --json publishedAt | jq -r .publishedAt))
+ $(eval AUTHOR := $(shell gh release --repo $(REPO) view --json author | jq -r .author.login))
+ echo "### published at '$(PUBLISHED_AT)' by $(AUTHOR)" >>changelog.md
+ echo "---" >>changelog.md
+ gh release --repo $(REPO) view --json body | jq -r .body >>changelog.md
+
+# prepare for commit
+pre:
+ shfmt -w PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+ git diff
+
+ git add PKGBUILD
+ git add changelog.md
+ git add .SRCINFO
+ git add .gitignore
+ git add Makefile
+
+# commit with version bump message
+commit:
+ $(eval VERSION := $(shell read -p "enter version (pkgver=$(VERSION)): " enter ; echo $${enter}))
+ @echo "commit message: \"updating to v$(VERSION)\""
+
+ @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
+ git diff --cached ; \
+ exit 0 ; \
+ fi
+
+ @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
+ git commit -m "updating to v$(VERSION)" ; \
+ exit 0 ; \
+ fi
+
+ @echo "recheck everything before pushing to AUR"
diff --git a/PKGBUILD b/PKGBUILD
index 7fce9b277c2f..66b812891173 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,30 @@
-# Maintainer: PolpOnline <aur at t0mmy dot anonaddy dot com>
+# Maintainer: zoorat <zoorat [at] protonmail [dot] com>
+# Contributor: PolpOnline <aur at t0mmy dot anonaddy dot com>
# Contributor: Jack Chen <redchenjs@live.com>
pkgname=motrix-bin
pkgver=1.8.19
-pkgrel=1
+pkgrel=2
+
pkgdesc="A full-featured download manager (binary version)"
arch=('x86_64')
url="https://github.com/agalwood/Motrix"
license=('MIT')
-conflicts=(
- 'motrix'
- 'motrix-git'
-)
-depends=(
- 'gtk3'
- 'libxcb'
- 'nss'
-)
-source=(
- "https://github.com/agalwood/Motrix/releases/download/v${pkgver}/Motrix_${pkgver}_amd64.deb"
-)
+
+conflicts=('motrix' 'motrix-git')
+depends=('gtk3' 'libxcb' 'nss')
+changelog="changelog.md"
+
+source=("https://github.com/agalwood/Motrix/releases/download/v${pkgver}/Motrix_${pkgver}_amd64.deb")
sha512sums=('8a3dab9c731268c2291f286d8efa7815046bbe00046deb938db061863d3ad3e14ddcb50ba4a7e44ada2c11d196d660bb6a762af4e6e589ddb38692266010e61a')
package() {
- tar -xf "$srcdir/data.tar.xz" -C "$pkgdir/"
+ tar -xf "$srcdir/data.tar.xz" -C "$pkgdir/"
- # Link to the binary
- mkdir -p "$pkgdir/usr/bin"
- ln -sf '/opt/Motrix/motrix' "$pkgdir/usr/bin/motrix"
+ # Link to the binary
+ mkdir -p "$pkgdir/usr/bin"
+ ln -sf '/opt/Motrix/motrix' "$pkgdir/usr/bin/motrix"
- # SUID chrome-sandbox for electron 5+ as indicated here: https://github.com/electron/electron/issues/17972#issuecomment-487369441
- chmod 4755 "$pkgdir/opt/Motrix/chrome-sandbox"
+ # SUID chrome-sandbox for electron 5+ as indicated here: https://github.com/electron/electron/issues/17972#issuecomment-487369441
+ chmod 4755 "$pkgdir/opt/Motrix/chrome-sandbox"
}
diff --git a/changelog.md b/changelog.md
new file mode 100644
index 000000000000..95d4fb733f9a
--- /dev/null
+++ b/changelog.md
@@ -0,0 +1,98 @@
+# Name: Motrix v1.8.19
+### URL: https://github.com/agalwood/Motrix/releases/tag/v1.8.19
+### published at '2023-05-03T07:13:13Z' by agalwood
+---
+![release-v1 8 x-banner](https://user-images.githubusercontent.com/1032175/235918777-7063ab93-ff2d-4f4b-a0b5-6a0ef83adc76.png)
+
+## Release Note
+
+* feat: App sidebar adds vibrancy effect on macOS @shatyuka
+* feat: Supports hiding tray icon on macOS @agalwood
+* feat: The download and upload speeds in the basic settings of the preferences support custom input speeds @SammCheese
+* feat: The advanced settings of the preferences support the setting of the RPC listening port @agalwood
+* feat: Show built-in aria2.conf path in advanced settings of preferences @agalwood
+* feat: Add log level settings in advanced settings of preferences @agalwood
+* feat: Release Linux version supporting arm32/arm64 architecture @agalwood
+* feat: Improve preferences, there will be a confirmation prompt when leaving the page without saving the settings @shatyuka
+* feat: Added macOS Universal version, Linux armv7l, arm64 version @agalwood
+* feat: Added Norwegian Bokmal translation @rubjo
+* feat: Added Thai translation @nxanywhere
+* feat: Dutch translation added @nickbouwhuis
+* feat: When the URL input box is not empty when creating a new task, the add task dialog will not be closed by mistake when pressing the Esc key or clicking the mask @shatyuka
+* feat: Support selecting directory from history directory when creating new task @agalwood
+* feat: Support cURL commands with Cookie/Referer information when creating new task @CW-B-W
+* feat: Support adding HTTP authorization request header when creating a new task @RaymondSalim
+* feat: The taskbar shows the overall download progress @shatyuka
+
+* fix: Tray icon display issue in older versions of macOS @shatyuka
+* fix: There are old wrong items in the task details file list, add a switch to download seeds automatically @dicarne
+* fix: The basic settings of the preference settings failed to modify "Automatically download magnet and torrent content" @agalwood
+* fix: Application interface rendering issue under Linux @agalwood
+* fix: Remove the tooltip of tray on macOS @shatyuka
+* fix: Restarting the app twice when saving preferences @agalwood
+* fix: Improved German translation @nickbouwhuis, @MagicLike
+* fix: Improved Persian translation @eshagh79
+* fix: Improved Traditional Chinese translation @tso1158687, @5idereal
+* fix: Improve English translation @nesaku
+* fix: Improved Spanish translation @ez-me
+* fix: Improve Vietnamese translation @CDzungx
+* fix: Improve Korean translation @quiple
+* fix: Parsing issues about Cookie/Referer when creating a new task @CW-B-W
+* fix: Showing apps doesn't restore minimized windows @shatyuka
+* fix: Update overall dependencies, Electron upgrade to version 22 @agalwood
+* fix: The border color is not changed after the task item is selected in dark mode @agalwood
+* fix: App window resizing issue @shatyuka
+* fix: The event processing problem of canceling the update during automatic update @agalwood
+
+* refactor: Optimized aria2.conf default configuration @agalwood
+* refactor: The built-in Aria2 is upgraded to version 1.36, and it is compatible with various system architectures of Windows, macOS, and Linux @agalwood
+* refactor: Improved auto-update progress bar display @agalwood
+
+**Full Changelog**: https://github.com/agalwood/Motrix/compare/v1.6.11...v1.8.19
+
+## 更新日志
+
+* 新特性: macOS 版支持隐藏托盘图标 @agalwood
+* 新特性: macOS 版本应用侧边栏增加 vibrancy 效果 @shatyuka
+* 新特性: 偏好设置的基础设置里下载和上传速度支持自定义输入速度 @SammCheese
+* 新特性: 偏好设置的进阶设置支持 RPC 监听端口的设置 @agalwood
+* 新特性: 偏好设置的进阶设置里显示内置的 aria2.conf 路径 @agalwood
+* 新特性: 偏好设置的进阶设置里添加日志级别设置 @agalwood
+* 新特性: 发布支持 arm32/arm64 架构的 Linux 版本 @agalwood
+* 新特性: 改进偏好设置,设置未保存离开页面时会有确认提示 @shatyuka
+* 新特性: 新增 macOS Universal 版本、Linux armv7l、arm64 版本 @agalwood
+* 新特性: 新增挪威博克马尔语翻译 @rubjo
+* 新特性: 新增泰语翻译 @nxanywhere
+* 新特性: 新增荷兰语翻译 @nickbouwhuis
+* 新特性: 新建任务时URL输入框不为空的情况下,按下esc键或点击遮罩时不会误关闭弹层 @shatyuka
+* 新特性: 新建任务时支持从历史目录选择目录 @agalwood
+* 新特性: 新建任务时支持带有 Cookie/Referer 信息的的 cURL 命令 @CW-B-W
+* 新特性: 新建任务时支持添加 HTTP 授权请求头 @RaymondSalim
+* 新特性: 任务栏显示整体下载进度 @shatyuka
+
+* 修复: 在旧版本 macOS 托盘图标的显示问题 @shatyuka
+* 修复: 任务详情文件列表有旧的错误项目,增加自动下载种子的开关 @dicarne
+* 修复: 偏好设置的基础设置修改“自动开始下载磁力链接、种子内的文件”失效的问题 @agalwood
+* 修复: 在 Linux 下 应用界面渲染错误问题 @agalwood
+* 修复: 移除了 macOS 版本托盘图标提示 @shatyuka
+* 修复: 在保存偏好设置时重新启动应用程序两次的问题 @agalwood
+* 修复: 改进德语翻译 @nickbouwhuis, @MagicLike
+* 修复: 改进波斯语翻译 @eshagh79
+* 修复: 改进繁体中文翻译 @tso1158687, @5idereal
+* 修复: 改进英文翻译 @nesaku
+* 修复: 改进西班牙语翻译 @ez-me
+* 修复: 改进越南语翻译 @CDzungx
+* 修复: 改进韩语翻译 @quiple
+* 修复: 新建任务时关于 Cookie/Referer 的解析问题 @CW-B-W
+* 修复: 显示应用时不会还原最小化的窗口 @shatyuka
+* 修复: 更新整体依赖,Electron 升级到 22 版本 @agalwood
+* 修复: 深色模式下任务项选定之后边框颜色不显示的问题 @agalwood
+* 修复: 应用窗口大小调整问题 @shatyuka
+* 修复: 自动更新时取消更新的事件处理问题 @agalwood
+
+* 重构: 优化了 aria2.conf 默认配置 @agalwood
+* 重构: 内置的 Aria2 升级为 1.36 版本,并适配了 Windows、macOS、Linux 多种系统架构 @agalwood
+* 重构: 改善了自动更新进度条显示 @agalwood
+
+**完整变更日志**: https://github.com/agalwood/Motrix/compare/v1.6.11...v1.8.19
+