summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2019-10-31 19:12:39 +0800
committerJack Chen2019-10-31 19:12:39 +0800
commitba444df7e36976f4b021cd02469c50d96620f5af (patch)
tree4e8dbd96bef5f3760558b769850abefc795c30c4
parent1d70d052908d32f4ab6158289a6f6264d0843855 (diff)
downloadaur-ba444df7e36976f4b021cd02469c50d96620f5af.tar.gz
update depends & script format
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD39
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cf3dccc1256..84a4951d8233 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,11 +7,12 @@ pkgbase = motrix-bin
license = MIT
makedepends = p7zip
depends = gtk3
- depends = libxcb
+ depends = nss
+ depends = libxss
conflicts = motrix
conflicts = motrix-git
source = https://dl.motrix.app/release/Motrix-1.4.1-x86_64.AppImage
- md5sums = 96f2aea1332517fb645347d5033fbabf
+ sha512sums = 1e3e1cd053453f4bd4440729ec6f95e91e6da3ceafe801cab800b1ae157c89dd50be818e44fb7a6685ca7826dfb530dc698f51cfc0015892a0893fc2abc2c15f
pkgname = motrix-bin
diff --git a/PKGBUILD b/PKGBUILD
index 09fa5d016c58..33952f866a26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=motrix-bin
pkgver=1.4.1
pkgrel=2
-pkgdesc='elegent downloading tool frontend for aria2c, using vue (binary version)'
+pkgdesc="elegent downloading tool frontend for aria2c, using vue (binary version)"
arch=('x86_64')
-url='https://motrix.app/'
+url="https://motrix.app/"
license=('MIT')
conflicts=(
'motrix'
@@ -16,36 +16,37 @@ makedepends=(
)
depends=(
'gtk3'
- 'libxcb'
+ 'nss'
+ 'libxss'
)
source=(
- 'https://dl.motrix.app/release/Motrix-'${pkgver}'-x86_64.AppImage'
+ "https://dl.motrix.app/release/Motrix-$pkgver-x86_64.AppImage"
)
-md5sums=(
- '96f2aea1332517fb645347d5033fbabf'
+sha512sums=(
+ '1e3e1cd053453f4bd4440729ec6f95e91e6da3ceafe801cab800b1ae157c89dd50be818e44fb7a6685ca7826dfb530dc698f51cfc0015892a0893fc2abc2c15f'
)
package() {
- 7z x Motrix-${pkgver}-x86_64.AppImage -o${pkgdir}/opt/Motrix/
+ 7z x "Motrix-$pkgver-x86_64.AppImage" -o"$pkgdir/opt/Motrix/"
- chmod -R 755 ${pkgdir}/opt/
+ chmod -R 755 "$pkgdir/opt/"
for i in 16x16 24x24 32x32 48x48 64x64 96x96 128x128 256x256 512x512 1024x1024; do
- install -Dm644 ${pkgdir}/opt/Motrix/usr/share/icons/hicolor/$i/apps/motrix.png \
- ${pkgdir}/usr/share/icons/hicolor/$i/apps/motrix.png
+ install -Dm 644 "$pkgdir/opt/Motrix/usr/share/icons/hicolor/$i/apps/motrix.png" \
+ "$pkgdir/usr/share/icons/hicolor/$i/apps/motrix.png"
done
- sed -i 's/Exec=AppRun/Exec=\/opt\/Motrix\/motrix/' ${pkgdir}/opt/Motrix/motrix.desktop
+ sed -i 's/Exec=AppRun/Exec=\/opt\/Motrix\/motrix/' "$pkgdir/opt/Motrix/motrix.desktop"
- install -Dm644 ${pkgdir}/opt/Motrix/motrix.desktop ${pkgdir}/usr/share/applications/motrix.desktop
- install -Dm644 ${pkgdir}/opt/Motrix/usr/share/mime/motrix.xml ${pkgdir}/usr/share/mime/application/motrix.xml
+ install -Dm 644 "$pkgdir/opt/Motrix/motrix.desktop" "$pkgdir/usr/share/applications/motrix.desktop"
+ install -Dm 644 "$pkgdir/opt/Motrix/usr/share/mime/motrix.xml" "$pkgdir/usr/share/mime/application/motrix.xml"
- mkdir -p ${pkgdir}/usr/bin
- ln -s /opt/Motrix/motrix ${pkgdir}/usr/bin/motrix
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s /opt/Motrix/motrix "$pkgdir/usr/bin/motrix"
- rm ${pkgdir}/opt/Motrix/AppRun
- rm ${pkgdir}/opt/Motrix/motrix.png
- rm ${pkgdir}/opt/Motrix/motrix.desktop
+ rm "$pkgdir/opt/Motrix/AppRun"
+ rm "$pkgdir/opt/Motrix/motrix.png"
+ rm "$pkgdir/opt/Motrix/motrix.desktop"
- rm -r ${pkgdir}/opt/Motrix/usr/
+ rm -r "$pkgdir/opt/Motrix/usr/"
}