summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-25 11:52:15 +0800
committerzxp198210052023-10-25 11:52:15 +0800
commit8c2c2004b10779c6ba459b75d514e96d7ec031a8 (patch)
treeabb1490b897b90a40dd1dd0d7c4ef1f32e3c8374
parent38b070e2ff1ccc6e0d554854fb75ba84fc1ddee8 (diff)
downloadaur-8c2c2004b10779c6ba459b75d514e96d7ec031a8.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e8f422fc3c9..9087729ada70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = motrix-git
pkgdesc = A full-featured download manager that supports downloading HTTP, FTP, BitTorrent, Magnet, etc.
pkgver = 1.8.19.r30.g7012040
- pkgrel = 1
+ pkgrel = 2
url = https://motrix.app/
arch = any
license = MIT
@@ -35,7 +35,7 @@ pkgbase = motrix-git
depends = glibc
provides = motrix=1.8.19.r30.g7012040
conflicts = motrix
- source = motrix.git::git+https://github.com/agalwood/Motrix.git
+ source = motrix.git::git+https://gitee.com/mirrors/motrix.git
sha256sums = SKIP
pkgname = motrix-git
diff --git a/PKGBUILD b/PKGBUILD
index 1ecb1f4f1ccf..7f1a7100ec7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,26 @@
pkgname=motrix-git
_pkgname=Motrix
pkgver=1.8.19.r30.g7012040
-pkgrel=1
+pkgrel=2
pkgdesc="A full-featured download manager that supports downloading HTTP, FTP, BitTorrent, Magnet, etc."
arch=('any')
url="https://motrix.app/"
_githuburl="https://github.com/agalwood/Motrix"
+_giteeurl="https://gitee.com/mirrors/motrix"
license=('MIT')
depends=('libxcb' 'gcc-libs' 'dbus' 'libxdamage' 'alsa-lib' 'mesa' 'gtk3' 'libxkbcommon' 'libxext' 'libxcomposite' \
'nspr' 'pango' 'nss' 'libdrm' 'at-spi2-core' 'cairo' 'libcups' 'libxrandr' 'glib2' 'libx11' 'libxfixes' 'expat' 'glibc')
makedepends=('gendesk' 'git' 'yarn' 'npm>=9.8.1' 'nodejs>=18.18.0')
provides=("${pkgname%-git}=${pkgver}")
conflicts=("${pkgname%-git}")
-source=("${pkgname//-/.}::git+https://github.com/agalwood/Motrix.git")
+source=("${pkgname//-/.}::git+${_giteeurl}.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname//-/.}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- gendesk -q -f -n --categories "Network" --name "${pkgname}" --exec "${pkgname}"
+ gendesk -q -f -n --categories "Network" --name "${_pkgname}" --exec "${pkgname%-git}"
cd "${srcdir}/${pkgname//-/.}"
sed '157,178d' -i electron-builder.json
yarn