summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-08-03 15:02:15 +0800
committertaotieren2021-08-03 15:02:15 +0800
commit02aee7fcf76959bd08a3291a3a21f41d4751f0bd (patch)
tree8aea0ece0278a395cf7bb507e88a521552093db7
downloadaur-02aee7fcf76959bd08a3291a3a21f41d4751f0bd.tar.gz
Update 1.10
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD67
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4717b76658f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = mounriver-studio-toolchain-bin
+ pkgver = 1.10
+ pkgrel = 1
+ url = http://www.mounriver.com/
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ license = Custom
+ makedepends = tar
+ depends = bash
+ optdepends = ch34x-dkms-git: CH341SER driver with fixed bug
+ optdepends = i2c-ch341-dkms: CH341 USB-I2C adapter driver
+ optdepends = spi-ch341-usb-dkms: SPI/GPIO driver for CH341
+ optdepends = ch341eepromtool: An i2c serial EEPROM programming tool for the WCH CH341A
+ optdepends = ch341prog-git: A simple command line tool (programmer) interfacing with ch341a
+ optdepends = ch341eeprom-git: A libusb based programming tool for 24xx I²C EEPROMs using the WCH CH341A
+ provides = MRS-Toolchain
+ noextract = mounriver-studio-toolchain-bin-1.10.tar.gz
+ source = mounriver-studio-toolchain-bin-1.10.tar.gz::http://file.mounriver.com/tools/MRS_Toolchain_Linux_x64_V1.10.tar.gz
+ sha256sums = 443a7392c42cd387a2b0445f265e9e98b020b7779d346f360a786f1c0c1a7b9b
+
+pkgname = mounriver-studio-toolchain-bin
+ pkgdesc = This MRS Toolchain includes the tool chain for RISC-V kernel chip under Linux x64 and the debug download tool OpenOCD.
+ depends = mounriver-studio-toolchain-openocd-bin
+ depends = mounriver-studio-toolchain-riscv-bin
+
+pkgname = mounriver-studio-toolchain-openocd-bin
+ pkgdesc = MRS Toolchain OpenOCD supports erasure, programming, verification and debugging of the chip.
+
+pkgname = mounriver-studio-toolchain-riscv-bin
+ pkgdesc = MRS Toolchain Support for RISC-V assembly and GNU C compilation, link operation.
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37bb465dc2db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1128d7e4598b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgbase=mounriver-studio-toolchain-bin
+pkgname=($pkgbase mounriver-studio-toolchain-openocd-bin mounriver-studio-toolchain-riscv-bin)
+pkgver=1.10
+pkgrel=1
+arch=('x86_64')
+url='http://www.mounriver.com/'
+license=('GPL2' 'GPL3' 'Custom')
+provides=('MRS-Toolchain')
+conflicts=()
+depends=('bash')
+makedepends=('tar')
+optdepends=('ch34x-dkms-git: CH341SER driver with fixed bug'
+ 'i2c-ch341-dkms: CH341 USB-I2C adapter driver'
+ 'spi-ch341-usb-dkms: SPI/GPIO driver for CH341'
+ 'ch341eepromtool: An i2c serial EEPROM programming tool for the WCH CH341A'
+ 'ch341prog-git: A simple command line tool (programmer) interfacing with ch341a'
+ 'ch341eeprom-git: A libusb based programming tool for 24xx I²C EEPROMs using the WCH CH341A')
+source=("${pkgbase}-${pkgver}.tar.gz::http://file.mounriver.com/tools/MRS_Toolchain_Linux_x64_V${pkgver}.tar.gz"
+ )
+
+sha256sums=('443a7392c42cd387a2b0445f265e9e98b020b7779d346f360a786f1c0c1a7b9b')
+
+noextract=(${pkgbase}-${pkgver}.tar.gz)
+
+package_mounriver-studio-toolchain-bin() {
+ pkgdesc="This MRS Toolchain includes the tool chain for RISC-V kernel chip under Linux x64 and the debug download tool OpenOCD."
+ depends=(mounriver-studio-toolchain-openocd-bin mounriver-studio-toolchain-riscv-bin)
+}
+
+package_mounriver-studio-toolchain-openocd-bin() {
+ pkgdesc="MRS Toolchain OpenOCD supports erasure, programming, verification and debugging of the chip."
+ install -dm0755 "${pkgdir}/opt/wch/${pkgname%-bin}"
+
+ tar -xf "${srcdir}/${pkgbase}-${pkgver}.tar.gz" --strip-components=2 -C "${srcdir}"
+ cp -r "${srcdir}"/OPENOCD/* "${pkgdir}/opt/wch/${pkgname%-bin}"
+
+ install -Dm0755 /dev/stdin "${pkgdir}/usr/bin/openocd-wch-arm" << EOF
+#!/bin/env bash
+cd /opt/wch/${pkgname%-bin}/bin
+exec ./openocd -f wch-arm.cfg "\$@"
+
+EOF
+ install -Dm0755 /dev/stdin "${pkgdir}/usr/bin/openocd-wch-riscv" << EOF
+#!/bin/env bash
+cd /opt/wch/${pkgname%-bin}/bin
+exec ./openocd -f wch-riscv.cfg "\$@"
+
+EOF
+}
+
+package_mounriver-studio-toolchain-riscv-bin() {
+ pkgdesc="MRS Toolchain Support for RISC-V assembly and GNU C compilation, link operation."
+ install -dm0755 "${pkgdir}/opt/wch/${pkgname%-bin}"
+
+ tar -xf "${srcdir}/${pkgbase}-${pkgver}.tar.gz" --strip-components=2 -C "${srcdir}"
+ cp -r "${srcdir}"/RISC-V\ Embedded\ GCC/* "${pkgdir}/opt/wch/${pkgname%-bin}"
+
+ install -Dm0755 /dev/stdin "${pkgdir}/etc/profile.d/${pkgname%-bin}.sh" << EOF
+#!/bin/sh
+[ -d /opt/wch/${pkgname%-bin}/bin ] && append_path '/opt/wch/${pkgname%-bin}/bin'
+
+export PATH
+EOF
+}
+# vim: ts=4 sw=4 et