summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-11-26 20:03:50 +0800
committertaotieren2021-11-26 20:03:50 +0800
commitc6188ff328083c0442e776e0145dc423c3f69c6a (patch)
tree8148e4e7f61cef3e09436811a9ae2e00bd0089ff
parent02aee7fcf76959bd08a3291a3a21f41d4751f0bd (diff)
downloadaur-c6188ff328083c0442e776e0145dc423c3f69c6a.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 29 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4717b76658f..80ec6025e45a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = mounriver-studio-toolchain-bin
pkgver = 1.10
- pkgrel = 1
+ pkgrel = 2
url = http://www.mounriver.com/
arch = x86_64
license = GPL2
license = GPL3
- license = Custom
+ license = custom
makedepends = tar
depends = bash
optdepends = ch34x-dkms-git: CH341SER driver with fixed bug
@@ -16,6 +16,7 @@ pkgbase = mounriver-studio-toolchain-bin
optdepends = ch341eeprom-git: A libusb based programming tool for 24xx I²C EEPROMs using the WCH CH341A
provides = MRS-Toolchain
noextract = mounriver-studio-toolchain-bin-1.10.tar.gz
+ options = !strip
source = mounriver-studio-toolchain-bin-1.10.tar.gz::http://file.mounriver.com/tools/MRS_Toolchain_Linux_x64_V1.10.tar.gz
sha256sums = 443a7392c42cd387a2b0445f265e9e98b020b7779d346f360a786f1c0c1a7b9b
@@ -26,6 +27,12 @@ pkgname = mounriver-studio-toolchain-bin
pkgname = mounriver-studio-toolchain-openocd-bin
pkgdesc = MRS Toolchain OpenOCD supports erasure, programming, verification and debugging of the chip.
+ depends = bash
+ depends = libftdi-compat
+ depends = libusb
+ depends = hidapi
+ depends = libusb-compat
+ depends = libudev.so
pkgname = mounriver-studio-toolchain-riscv-bin
pkgdesc = MRS Toolchain Support for RISC-V assembly and GNU C compilation, link operation.
diff --git a/PKGBUILD b/PKGBUILD
index 1128d7e4598b..a6fae5fa4749 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgbase=mounriver-studio-toolchain-bin
pkgname=($pkgbase mounriver-studio-toolchain-openocd-bin mounriver-studio-toolchain-riscv-bin)
pkgver=1.10
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='http://www.mounriver.com/'
-license=('GPL2' 'GPL3' 'Custom')
+license=('GPL2' 'GPL3' 'custom')
provides=('MRS-Toolchain')
conflicts=()
depends=('bash')
@@ -22,19 +22,36 @@ source=("${pkgbase}-${pkgver}.tar.gz::http://file.mounriver.com/tools/MRS_Toolch
sha256sums=('443a7392c42cd387a2b0445f265e9e98b020b7779d346f360a786f1c0c1a7b9b')
+options=('!strip')
+
noextract=(${pkgbase}-${pkgver}.tar.gz)
+_install(){
+ find ${@: 2} -type f -exec install -Dm$1 {} ${pkgdir}/opt/wch/${pkgname%-bin}/{} \;
+}
+
package_mounriver-studio-toolchain-bin() {
pkgdesc="This MRS Toolchain includes the tool chain for RISC-V kernel chip under Linux x64 and the debug download tool OpenOCD."
depends=(mounriver-studio-toolchain-openocd-bin mounriver-studio-toolchain-riscv-bin)
}
package_mounriver-studio-toolchain-openocd-bin() {
+ depends=('bash'
+ 'libftdi-compat'
+ 'libusb'
+ 'hidapi'
+ 'libusb-compat'
+ 'libudev.so')
+
pkgdesc="MRS Toolchain OpenOCD supports erasure, programming, verification and debugging of the chip."
install -dm0755 "${pkgdir}/opt/wch/${pkgname%-bin}"
tar -xf "${srcdir}/${pkgbase}-${pkgver}.tar.gz" --strip-components=2 -C "${srcdir}"
- cp -r "${srcdir}"/OPENOCD/* "${pkgdir}/opt/wch/${pkgname%-bin}"
+# cp -r "${srcdir}"/OPENOCD/* "${pkgdir}/opt/wch/${pkgname%-bin}"
+ cd "${srcdir}"/OPENOCD/
+ _install 644 bin -name "*.cfg"
+ _install 755 bin -name "openocd"
+ _install 644 share
install -Dm0755 /dev/stdin "${pkgdir}/usr/bin/openocd-wch-arm" << EOF
#!/bin/env bash